LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-03-2005, 05:06 AM   #1
arunsri
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 49

Rep: Reputation: 15
ALSA prblm / newbie pls help


I've been running slack 10.1 for a while. I had recompiled and running kernel 2.6.11.4. Actually, all these days i didnt hav sound.(since i never looked at the alsa configuration)

So now, tried to comile alsa modules for all sort of cards.....and then recompiled the kernel and rebooted it, but it said "unmute ur sound card using alsa mixer" and then run alsactl.

So I set volume levels using alsamixer and then did alsactl store to store this settings and rebooted but, the kernel is not booting up. It stops at the point where it checks BIOS data.

but i am able to get into the old 2.4 kernel nd it recogonizes alsa and i get sound in it.

wat cud be the prblm? Read tht configuration gets stored in /etc/asound.state. so do i need to reset it? how do I do it? pls. help
 
Old 09-03-2005, 06:35 AM   #2
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
Had a similair sound problem after i compiled an 2.6.12 kernel,
but my kernel booted without any problems except for not recognising alsa

you might want to upgrade your alsa-driver to alsa-driver-1.0.9b, its in -current/testing/packages/linux-2.6.12.5/

probably something else is wrong that causes your kernel not too boot
 
Old 09-03-2005, 08:05 AM   #3
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
do an lspci and include the thing
i made it as module only, me uses intel board and included tht module only, working nicely

in the PCI device also enable the needed module Sound--->alsa---->PCI

after tht if not working alsaconfig, alsamixer as usual
best of luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer prblm..pls. help arunsri Linux - Software 1 09-04-2005 01:18 AM
dsl 1.2 newbie-help pls window navigation gavininq DamnSmallLinux 2 08-20-2005 11:39 PM
[Slack 10.1] Help with ALSA pls. PLsN Linux - Newbie 5 03-07-2005 03:03 PM
2 Newbie questions - pls help to get me started ks8 Linux - Newbie 18 04-01-2004 10:12 AM
pls pls pls help me ! i'm tired with httpd config on fedora apache 2.0.48 AngelOfTheDamn Fedora 0 01-24-2004 05:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration