LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-11-2008, 12:30 PM   #1
aherrys
Member
 
Registered: Jul 2003
Posts: 64

Rep: Reputation: 15
alsa on Thinkpad T61 no sound


Hi All,

I recently installed the slackware 12.1 on Thinkpad T61 and download the alsa drivers directly from www.alsa-project.org(version 1.0.16), and compile it from scratch. My sound card is Intel ICH8 Family HD Audio Controller as shown by lspci.

So following the guidance from Alsa site I compile the driver with option --with-cards=hda-intel. The compilation went smooth and after I reboot I got the following lsmod:

Module Size Used by
nls_iso8859_1 3712 2
nls_cp437 5312 2
pcmcia 33688 0
snd_hda_intel 334424 0
snd_pcm 63368 1 snd_hda_intel
button 6096 0
thermal 14620 0
ohci1394 27632 0
processor 27760 2 thermal
yenta_socket 22476 1
snd_timer 17924 1 snd_pcm
battery 6144 0
ac 3200 0
snd_page_alloc 7560 2 snd_hda_intel,snd_pcm
ieee1394 75892 1 ohci1394
snd_hwdep 6596 1 snd_hda_intel
psmouse 35408 0
rsrc_nonstatic 8832 1 yenta_socket
pcmcia_core 33684 3 pcmcia,yenta_socket,rsrc_nonstatic
e1000 115904 0
snd 44068 4 snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
ehci_hcd 40268 0
intel_agp 21140 0
uhci_hcd 30032 0
agpgart 26096 1 intel_agp



so the modules loaded well. However when I tried to play the wav file with aplay I can't hear anything coming out. (Of course I have un mute everything on the alsamixer and max out the volume)

I searched the web for similar problem and found the following guide fronm puppy linux

http://www.murga-linux.com/puppy/viewtopic.php?t=22383

It basically stated that there are different "models" of hardware for snd-hda-intel and we need to specify the correct models. I know by doing cat /proc/asound/card0/codec#0 that my card is:

Analog Devices AD1984.

So following the directives from that puppy linux site I add the line:

options snd-hda-intel model=AD1984

under "/etc/modprobe.d/sound"
So that file looks like:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=AD1984


However after I reboot the computer still no sound. Do you guys have any idea of what is missing to cause this problem ?

Thanks in advanced for any help and suggestions

Last edited by aherrys; 07-11-2008 at 12:35 PM.
 
Old 07-11-2008, 01:35 PM   #2
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
Try with:

Code:
options snd-hda-intel model=auto
Btw, why did you compiled ALSA drivers? As far as I know, Intel HDA works just fine. At least it worked for me on older Toshiba and now on Sony notebook.
 
Old 07-11-2008, 02:03 PM   #3
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
If the options in the previous post do not work for you, as strange as it sounds, try:

Quote:
options snd-hda-intel model=Toshiba
or

Quote:
options snd-hda-intel model=Acer
Even though this is not your real model, it has work for others having this problem.


Bob
 
Old 07-12-2008, 05:34 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
See this thread.
 
Old 07-13-2008, 12:00 PM   #5
aherrys
Member
 
Registered: Jul 2003
Posts: 64

Original Poster
Rep: Reputation: 15
Hi All,

Thanks for the answers. It turns out it was a very stupid mistake. I did not to turn on the speaker option on the alsamixer. This was because when I had the speaker turn on it will make a loud beeping sound if I also turn on the Internal Mic. So instead of turning off the Internal Mic I turned off the speaker. And of course no sound came out...

Now it is solved, and from T3slider that AD1984 is not a valid option for snd-hda-intel, and it is supposed to be thinkpad I think, but even if I used the wrong option in the sound file under /etc/modprobe.d my sound card still works anyway. I guess the system just uses the default setup which turns out the same as the thinkpad option.

Thanks again for all your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ThinkPad T61 15.4" with Suse 10- anyone? Michaelus08 Linux - Laptop and Netbook 1 06-16-2008 09:47 AM
LXer: PCLinuxOS 2008 on my ThinkPad T61 LXer Syndicated Linux News 0 01-17-2008 09:50 PM
LXer: Finding the right distro for my ThinkPad T61 LXer Syndicated Linux News 0 11-28-2007 06:41 PM
thinkpad T61 fingerprint reader without PAM t163r Slackware 1 10-28-2007 12:26 PM
Thinkpad Lenovo T61 Nikosis Slackware 33 07-05-2007 06:11 AM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration