LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-10-2007, 12:05 PM   #1
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Rep: Reputation: 30
Alsa is only able to use one card


There are two soundcards in my computer: Creative SB PCI128 Ensoniq ES1371 Sound Card on PCI and Via AC'97 integrated into the motherboard.
I remember that whan I installed Slackware 11.0 on my computer some weeks ago, everything was fine: I could select both cards from alsaconf and they worked after that.
Now the situation is like this. I install fresh Slackware 11 with default 2.4.33.3 kernel as before. All goes well, I log in as root and run alsaconf, it finds both cards. When I select the Via card, it works. Speaker-test makes sound, alsamixer controls it, all fine. But when I select the Ensoniq card, it tells me that everything went fine but instead the computer still keeps using the Via card, alsamixer also lists Via as the active sound card. Even when I select Ensoniq the first time after install, when Via isn't activated yet, it still uses Via.
I have no idea what's the problem here, since I used the exact same conf the last time. I'm rather new with linux so I haven't gotten to experiment with ALSA yet, thus I don't know what to look for. Have any ideas?
 
Old 03-10-2007, 02:12 PM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,466

Rep: Reputation: Disabled
You may be able to get around this by manually creating aliases for your cards. I use a 2.6 kernel so the file will be different to yours, but this is how I set mine up in /etc/modprobe.d/sound:

Code:
 alias snd-card-0 snd-emu10k1
 alias sound-slot-0 snd-emu10k1
 alias snd-card-1 snd-ens1371
 alias sound-slot-1 snd-ens1371
 options snd-emu10k1 index=0
 options snd-ens1371 index=1
I believe that for a 2.4 kernel you should use /etc/modules.conf
 
Old 03-10-2007, 03:05 PM   #3
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
Thanks for replying.
I'll try that right when I've finished compiling 2.6.
 
Old 03-10-2007, 04:39 PM   #4
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
After kernel compile, that didn't go too well, Ensoniq had become the default soundcard and via couldn't be used. I followed your instructions and aliased Via in /modprobe.rc/sound. Now how am I supposed to change between them? : )

Kmix lists both if that's any help. I'd still need a convinient way to change which one of them is active.
 
Old 03-10-2007, 04:43 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 86
My recommendation would be to disable the onboard sound and just go with your audio card. Having both enabled can lead to conflicts such as you describe, plus there's no compelling reason to have two sound cards
 
Old 03-10-2007, 04:56 PM   #6
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
Actually there is. Headphones are connected to via from the external port in front of the pc, speakers are connected to ensoniq from the back. I was able to change the active output with a little self-made script in windows, I'm sure it should be even easier in slackware.
 
Old 03-10-2007, 07:08 PM   #7
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,466

Rep: Reputation: Disabled
Quote:
Originally Posted by kummiliim
After kernel compile, that didn't go too well, Ensoniq had become the default soundcard and via couldn't be used. I followed your instructions and aliased Via in /modprobe.rc/sound. Now how am I supposed to change between them? : )

Kmix lists both if that's any help. I'd still need a convinient way to change which one of them is active.
Normally you specify in your audio/video player program which to use. E.G.

mplayer -ao alsa:device=hw=0,0 file.mpg

Xmms has a setting in options to specify which card to use, and I think xine/gxine also have options.

F.E. I have a couple of scripts that call mplayer with different sound cards. One is connected via my vcr to my hi-fi system, and the other to my pc speakers, so I can watch movies with nice sound. SVideo out is also connected through vcr to tv.
 
Old 03-11-2007, 03:04 AM   #8
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
That's more like it, but I'm wondering, where does kde take the default soundcard from. It would perhaps be a little easier to change the output of all the programs (exept maybe the ones that are already working) at once. That might of course be hard, since KDE seems to initaliaze it's default soundcard at startup. I don't know, maybe I want too much, but it seems to be possibe.

Thanks anyway, I'll test if the Via card works at all later with this.
 
Old 03-11-2007, 04:11 AM   #9
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,466

Rep: Reputation: Disabled
I havent tried this but in kcontrol - sound & multimedia - sound system there is an option on the hardware tab to override device location. Putting something like hw:0,0 or hw:1,0 might work
 
Old 03-11-2007, 06:03 AM   #10
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
Back in Slackware. After restart Via is again the only card working. I can use hw:0,0 and hw:2,0 in the hardware tab, in both cases it lists the card as Ensoniq yet uses Via.

edit: Wait, it actually kind of works. Now that I know how to mark sound devices I tried speaker-test -D hw:0,0 and 2,0. 0,0 is Via and 2,0 Ensoniq, both worked. I'm going to test some things...

edit2: Yeah, it does work. Now all I need is to know how I can change the same option from the command line so I can make some shortcuts. Thanks.

Last edited by kummiliim; 03-11-2007 at 06:10 AM.
 
Old 03-11-2007, 10:17 AM   #11
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
Quote:
Originally Posted by kummiliim
Actually there is. Headphones are connected to via from the external port in front of the pc, speakers are connected to ensoniq from the back. I was able to change the active output with a little self-made script in windows, I'm sure it should be even easier in slackware.
Alternatively you could buy a "jack port distributor" (i don't know the proper name, sorry) thingie at a local computer/hardware store for next-to-nothing, and use 1 card with both equipment.
 
Old 03-11-2007, 10:48 AM   #12
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
Yeah, that would do the trick but I still can't belive that neighter KDE nor ALSA has a global option of which soundcard is used as active. I'll keep looking into that, thanks.
 
Old 03-11-2007, 12:59 PM   #13
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,466

Rep: Reputation: Disabled
There's really no such thing as the 'active' card. Most sound progs will use the first one (o,o) unless you tell them otherwise.
 
Old 03-11-2007, 01:11 PM   #14
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
And from where does the system take which card is the first?
 
Old 03-11-2007, 08:46 PM   #15
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,466

Rep: Reputation: Disabled
Well if you haven't specified which card to use as card 0, it will take the first it finds on the pci bus.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card conflict with Vid-Capture card ALSA Optimistic Debian 5 11-06-2007 12:20 AM
card 0:intel8x0m card 1: intel8x0, alsa mixer cannot locate them T.T Fortuner Slackware 3 06-06-2006 02:39 AM
ALSA Doesn't like my card arew264 Linux - Software 2 01-15-2006 12:17 PM
alsa cant find card true_atlantis Slackware 1 06-02-2005 06:45 PM
TV card, SBLive!, and ALSA KL2001 Linux - Hardware 3 03-03-2004 02:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration