LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-07-2003, 05:20 AM   #1
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Rep: Reputation: 30
Unhappy alsa installed, but no sound?


hi everyone,

i reinstalled slackware because i had messed it up too much;
now everything is fine and i won't make the mistakes again
which led to reinstallation.

but now i have a new problem.

i installed the newly released version of dropline gnome, and
noticed alsamixer being present. when i ran it, no controls
would show. this told me that no alsa drivers were installed.
so i went to alsa-project.org, downloaded the drivers, libs,
utils and oss-compatible library and installed them according
to instructions i found using google. the installation went well,
no warnings or errors. i then added my default sound module
to my hotplug blacklist, rebooted et voila - the gnome alsa-
mixer showed proper controls, cat /proc/asound/cards told
me i had a sound blaster live - emu10k1 installed. i had
added the following to my /etc/rc.d/rc.local:

modprobe snd-emu10k1
modprobe snd-pcm-oss
modprobe snd-seq-oss
amixer set Master 90% unmute
amixer set PCM 90% unmute

this loads the necessary modules and unmutes the master
and pcm volume; it's muted by default.

but even though everything seems to be installed properly,
i get no sound when i for instance run neverwinter nights..
sound worked with the non-alsa driver which was installed
when i installed slackware, but i wanted to try alsa since it
might give me more control and higher quality sound.

any suggestions to why my sound would not be working are
very much appreciated. if i need to provide more info, please
do not refrain from asking.

sry if i should have not made a new post, but i could find no
relevant info in these forums or elsewhere.. and though i
could have searched the net for many hours and might have
found something to help me, i wanted to try posting here
again in the hope i'd get useful advice.

kind regards.
 
Old 04-07-2003, 06:28 AM   #2
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 16
It is hard to say rightway uless sombody with exact hw and sw had the same problem.

Could you post your sound related part of cat /proc/modules?
Here is mine for example:

$ cat /proc/modules
snd-pcm-oss 37860 0 (autoclean)
snd-mixer-oss 12152 0 (autoclean) [snd-pcm-oss]
snd-es1938 11116 4 (autoclean)
gameport 1452 0 (autoclean) [snd-es1938]
snd-pcm 55552 1 (autoclean) [snd-pcm-oss snd-es1938]
snd-opl3-lib 5828 0 (autoclean) [snd-es1938]
snd-hwdep 4736 0 (autoclean) [snd-opl3-lib]
snd-timer 13352 0 (autoclean) [snd-pcm snd-opl3-lib]
snd-mpu401-uart 3168 0 (autoclean) [snd-es1938]
snd-rawmidi 12544 0 (autoclean) [snd-mpu401-uart]
snd-seq-device 3936 0 (autoclean) [snd-opl3-lib snd-rawmidi]
snd-page-alloc 4652 0 (autoclean) [snd-es1938 snd-pcm]
snd 27652 7 (autoclean) [snd-pcm-oss snd-mixer-oss snd-es1938 snd-pcm snd-opl3-lib snd-hwdep snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3332 6 (autoclean) [snd]
Also:
1) Pleas make sure you have all alsa stuff installed. Personally I always compile ALSA myself. Nowdays it comes in 5 packages: alsa-drivers, alsa-lib, alsa-oss, alsa-tools, alsa-utils (one of two last ones i think is optional).
2) Try to run other oss programs and see what happens. Some kind of mixer with oss interface or xmms with oss output plugin.
3) Check that your log for anything related to /dev/dsp. And if it is a link where to it is pointing.
4) Browse /proc/asound especially /proc/asound/oss. Do cat or less on sndstat in that dir. here is mine e.g.

Sound Driver:3.8.1a-980706 (ALSA v0.9.2 emulation code)
Kernel: Linux puma 2.4.20 #2 Mon Mar 17 22:02:15 PST 2003 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
ESS ES1938 (Solo-1) rev 0, irq 5

Audio devices:
0: ESS Solo-1 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
0: MPU-401 (UART) 0-0

Timers:
7: system timer

Mixers:
0: ESS Solo-1

5) Also make sure that actually native alsa apps work. A few SDL games support alsa natively. Or you can try xmms with alsa-xmms plugin (note, do not mix with xmms-alsa that was wriitten for alsa 0.5.x and is not supported anymore).
6) Last but not least browse documentation at www.alsa-project.org related to your specific sound card. Just loading modules may be not enough you might need to pass some extra options. That is why alsa-project people usually recomend to configure sound through /etc/modules.conf file. Most probably you can find exact content of /etc/modules.conf for your card at www.alsa-project.org.
7) Also even though i do everything by hand i would not be surprised if nowdays alsa comes with utility that generates modules.conf file for you.
Good luck,
Nick.
 
Old 04-07-2003, 06:36 AM   #3
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
agpgart 35776 3 (autoclean)
nvidia 1545440 10 (autoclean)
snd-seq-midi 3520 0 (autoclean) (unused)
snd-emu10k1-synth 3900 0 (autoclean) (unused)
snd-emux-synth 26332 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 4736 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 2952 0 (autoclean) [snd-emux-synth]
snd-seq-oss 26144 0 (unused)
snd-seq-midi-event 2984 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 33616 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul
snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 37860 0 (unused)
snd-mixer-oss 12152 0 [snd-pcm-oss]
lp 6752 0 (autoclean)
parport 23264 0 (autoclean) [lp]
keybdev 1952 0 (unused)
mousedev 4212 1
hid 18596 0 (unused)
usbmouse 2008 0 (unused)
input 3200 0 [keybdev mousedev hid usbmouse]
tuner 9696 1 (autoclean)
tvaudio 12188 0 (autoclean) (unused)
msp3400 15180 1 (autoclean)
bttv 67936 0 (unused)
i2c-algo-bit 6984 1 [bttv]
i2c-core 12708 0 [tuner tvaudio msp3400 bttv i2c-algo-bit]
videodev 5632 3 [bttv]
btaudio 10508 0
snd-emu10k1 59252 0 [snd-emu10k1-synth]
snd-pcm 55552 0 [snd-pcm-oss snd-emu10k1]
snd-timer 13352 0 [snd-seq snd-pcm]
snd-hwdep 4736 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emux-synth snd-emu10k1]
snd-page-alloc 4652 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 12544 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-seq-device 3936 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth
snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-ac97-codec 33440 0 [snd-emu10k1]
snd 27652 0 [snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-hwdep snd-util-mem snd-rawmidi snd-seq-device snd-ac97-codec]
soundcore 3332 10 [bttv btaudio snd]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
uhci 24560 0 (unused)
usbcore 58144 1 [hid usbmouse uhci]
pcmcia_core 38112 0
ide-scsi 8048 0
8139too 15272 1
mii 2240 0 [8139too]

------------------

i did install the packages myself, except for the tools-package.

thank you for your prompt response.
 
Old 04-07-2003, 06:37 AM   #4
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 16
almost forgot

ther first step in checking alsa i do is to run alsamixer in terminal window or on the console. and "tail -f /var/log/messages" (this one can only be done as a root, of course).
Also sometimes due to some screwups in install/config /dev/dsp does not have right permissions. It should be rw for others:

$ ls -l /dev/dsp*
lrwxrwxrwx 1 root root 9 Apr 2 23:46 /dev/dsp -> /dev/dsp0
crw-rw-rw- 1 root root 14, 3 Apr 2 23:46 /dev/dsp0
crw-rw-rw- 1 root root 14, 19 Apr 2 23:46 /dev/dsp1
crw-rw-rw- 1 root root 14, 35 Apr 2 23:46 /dev/dsp2
crw-rw-rw- 1 root root 14, 51 Apr 2 23:46 /dev/dsp3
 
Old 04-07-2003, 06:47 AM   #5
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
ls -l /dev/dsp*
lrwxrwxrwx 1 root root 9 Apr 6 21:36 /dev/dsp -> /dev/dsp0
crw-rw-rw- 1 root root 14, 3 Apr 6 21:36 /dev/dsp0
crw-rw-rw- 1 root root 14, 19 Apr 6 21:36 /dev/dsp1
crw-rw-rw- 1 root root 14, 35 Apr 6 21:36 /dev/dsp2
crw-rw-rw- 1 root root 14, 51 Apr 6 21:36 /dev/dsp3

^ seems the same as you have.

tail -f /var/log/messages produced no messages from alsamixer.
 
Old 04-07-2003, 07:16 AM   #6
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 16
neenee,
let's make an experiment.
1) unload all your sound related drivers (for that you might have to stop soundservers like esd or kde sound). Also if on "rmmod snd-*" you will get "module in use" check /proc/modules which modules depend on the one you are trying to uload and remove them first. The last one will be soundcore.o
2) Go to
http://www.alsa-project.org/alsa-doc...module=emu10k1

and write /etc/modules.conf and ~/.asoundrc file the way they are suggested there (do not forget oss part!)

3) run
depmod -a
as a root.
4) start "tail -f /var/log/messages"
To have something meaningfull you might want to check your /etc/syslog.conf
you probably need stuff related to:
kern.* and *.info uncomented
if it was commented out remove coments and restart syslogd. (kill -HUP syslog_pid is usually enough) just to make sure that it runs after restart check it (ps aux | grep syslogd)
5) start alsamixer. and look at log. it should say that snd-card-0 was loaded.
6) start xmms with oss plugin (but do not quit alsamixer) and try to play something. watch for messages. it should report about loading apropriate modules.

Oh and also!!!
As I posted in another thread. It seems that at the moement for some sound card modules (lke i8x0 for example) it seems that too keep them alive (i.e. loaded) you need some another application with native alsa interface running (alsamixer). I don't know really why It is kind of emperical. In fact before doing all that stuff above try doing just that. Launch alsamixer and then some application with OSS interface and see what happens. That could be a quick fix for now actually.
 
Old 04-07-2003, 07:21 AM   #7
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
running alsa mixer and then an app with oss interface
does not work.

i will try the steps you advised now.
 
Old 04-07-2003, 07:36 AM   #8
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 16
i also noticed that a lot of snd-* modules were loaded twice. why is that? do you have tow cards?
 
Old 04-07-2003, 07:38 AM   #9
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
okay. i did the steps. i get no sound from xmms when using
the oss-plugin, but i get sound when using the alsa plugin;
though only from my front speakers (5.1 setup); but the front-
speaker prob is a problem for later.

i get no sound in neverwinter nights though ; i expect it
needs the oss emulation to work through alsa..
 
Old 04-07-2003, 08:05 AM   #10
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do "ls -sl /dev/dsp*" and post the output.
 
Old 04-07-2003, 08:12 AM   #11
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
0 lrwxrwxrwx 1 root root 9 Apr 6 21:36 /dev/dsp -> /dev/dsp0
0 crw-rw-rw- 1 root root 14, 3 Apr 6 21:36 /dev/dsp0
0 crw-rw-rw- 1 root root 14, 19 Apr 6 21:36 /dev/dsp1
0 crw-rw-rw- 1 root root 14, 35 Apr 6 21:36 /dev/dsp2
0 crw-rw-rw- 1 root root 14, 51 Apr 6 21:36 /dev/dsp3
 
Old 04-07-2003, 08:42 AM   #12
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
notacoolnick - no i do not have two soundcards. i do
not know where i would disable one of two being loaded...
 
Old 04-07-2003, 09:06 AM   #13
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 16
hmm...
that part (about many snd-* modules being loaded twice is odd). i tried to do this intentionally (load same snd-* modules several times) and i could not do that.
that part you posted for Aussie (ls -ls /dev/dsp*) I think it looks ok (i have the same). I really hate to do this to you but could you also let us look at /proc/asound/oss/sndstat and /proc/asound/oss/devices. Another thing. I am shooting in the dark here. But I also did not like your gameport module it points to emu10k1-gp module i don't think it is part of alsa I think it is "kernel" module. IMHO gamport should depend on snd-emu10k1. Try to unload gameport and emu10k1-gp modules.
Also keep forgeting to ask you. Do you have hotplug running?
 
Old 04-07-2003, 09:20 AM   #14
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
i unloaded gameport + emu10k1-gp.
hotplug is running.

cat proc/asound/oss/sndstat:

Sound Driver:3.8.1a-980706 (ALSA v0.9.2 emulation code)
Kernel: Linux voyager 2.4.20 #2 Mon Mar 17 22:02:15 PST 2003 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Sound Blaster Live! (rev.7) at 0xd400, irq 4

Audio devices:
0: EMU10K1 (DUPLEX)

Synth devices:
0: Emu10k1

Midi devices:
0: EMU10K1 MPU-401 (UART)

Timers:
7: system timer

Mixers: NOT ENABLED IN CONFIG

----------------------

cat /proc/asound/oss/devices:

2: [0- 2]: raw midi
12: [0-12]: digital audio
1: : sequencer
8: : sequencer
13: [0-13]: raw midi
 
Old 04-07-2003, 10:20 AM   #15
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
i reinstalled neverwinter nights, thinking it might detect alsa and
use it or something, but it did not do the trick. it was a long shot.
i do get an error now though, in the console:

$ nwn
Warning: Couldn't set audio fragment size
audio: Invalid argument

it runs, but without sound. perhaps this error message
helps give an idea what the problem is with alsa?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sound not working, sarge with alsa installed yoyoguy2 Debian 12 07-03-2005 06:19 PM
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 02:02 PM
HELP:i915GAV alsa installed;but no sound yet deepclutch Debian 5 02-27-2005 02:25 PM
no sound in Fedora, ALSA is installed Hockeyfan Linux - Software 4 05-15-2004 01:54 AM
ALSA installed, still no sound //alias Linux - Newbie 4 07-01-2003 02:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration