LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-17-2018, 06:23 AM   #1
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,010

Rep: Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909
Alsa, Dbus, and Pulseaudio In Current


Greetz
I vastly prefer Alsa-only systems with my semi-pro soundcard that has hardware mixing but I recognize that Pulse has become a Fact of Life even though I don't ever use Bluetooth. After playing around trying to actually enjoy Pulse, then attempting to eliminate it (I've come to despise it) through many changes to Pulse itself upstream and my own attempts at simply preferring Alsa I find that for once my notes were not up to KISS standards and I'd like some current, clear, complete steps offered to get Pulse to ONLY be invoked when it absolutely has to and Alsa, like before, for everything else that can just use Alsa with no intervention and no Dbus errors.

So what are the configurations I need to accomplish this? I am well-versed in using ~/.asoundrc, somewhat skilled in "/etc/pulse" configs, and a rank newb at controlling Dbus/Dmix. I'm tired of "spaghetti" and wish to start out right immediately after I install Current.

Thanks in advance for any comments and/or assistance.
 
Old 03-17-2018, 12:23 PM   #2
JWJones
Senior Member
 
Registered: Jun 2009
Location: Cascadia
Distribution: Slackware -current
Posts: 1,067

Rep: Reputation: 359Reputation: 359Reputation: 359Reputation: 359
I'm just following this thread as a sometimes-Slackware user, who is mostly using Gentoo these days, minus dbus, pulseaudio, and other things in Linux that I'd rather avoid.
 
Old 03-17-2018, 01:40 PM   #3
globetrotterdk
Member
 
Registered: Nov 2006
Posts: 205

Rep: Reputation: 14
I sympathize and would love to do the same thing. Where I can provide a little advice as to whether this is a viable project, is to tell you that I have tried this on Devuan and it works well. Unfortunately, like systemd, pulseaudio is becoming ubiquitous. For this reason, you will need a wrapper called apulse, when you come in contact with a program that depends on pulseaudio, such as MuseScore, now in it's version 2 iteration. Unfortunately, the apulse wrapper is not in SlackBuilds.org, but the wrapper itself is here - https://github.com/i-rinat/apulse. Good luck with your project, I hope that you are successful.
 
Old 03-17-2018, 05:27 PM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,313

Rep: Reputation: Disabled
I believe Bluetooth audio works without PA nowadays? The only reason Slackware got PA is gone.
 
1 members found this post helpful.
Old 03-17-2018, 05:45 PM   #5
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,540

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
Quote:
Originally Posted by Emerson View Post
I believe Bluetooth audio works without PA nowadays? The only reason Slackware got PA is gone.
I'm not crazy about pulseaudio either, but I do like that the newest versions allow you to disable re-sampling. But, like you said, since bluez 5 now has a fork that uses alsa and doesn't require pulseaudio it makes me wonder if Pat has looked into it?
 
2 members found this post helpful.
Old 03-17-2018, 05:48 PM   #6
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,462

Rep: Reputation: Disabled
Seems like some other people are carrying on with bluez + alsa, but since I do not have any bluetooth hardware I of course can't test it...

https://github.com/Arkq/bluez-alsa
 
2 members found this post helpful.
Old 03-17-2018, 06:19 PM   #7
globetrotterdk
Member
 
Registered: Nov 2006
Posts: 205

Rep: Reputation: 14
I am not sure as to how much of this you can adapt to Slackware, as I am very new, but this is the guide that I successfully used when purging pulseaudio from my former Devuan Jessie install (I have gone completely slacky now):
http://linuxg.net/how-to-properly-re...ebian-squeeze/
Hopefully it will give you some inspiration.
 
Old 03-17-2018, 06:48 PM   #8
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,010

Original Poster
Rep: Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909
Thanks everyone. I have and have used apulse but there are some apps it won't satisfy with an Alsa-Only system. I have seen a number of posts here at LQ that reconfigure both Pulse and Alsa in such a way as to simple be Alsa > Pulseaudio where Pulse is only spawned when Alsa with or without apulse won't do the job. However some of these alterations have changed or should be changed as things, especially pulse, and apps that default to it, are developed.

I recently read that "type - hw" causes direct access to the hardware which on most cards means it's resources are only available to one app at a time - one of the claimed problems that pulseaudio sought to fix. Someone (and I'll try to find it to give that person credit) posted that changing to this

Code:
pcm.!default
{
    type asym
    playback.pcm
    {
        type plug
        slave.pcm "dmix"
    }
    capture.pcm
    {
        type plug
        slave.pcm "usb"
    }
}
does exactly what you might expect, default to a software mixer that can share the card's resources.

I'm looking to do things like this and either have things auto-switch to pulse when needed or even a manual command would be fine... just so I can limit pulse to only what absolutely has to have it. The above config works for me for sharing resources both on my laptop (embedded sound) and my Main which has an ESI Juli@ (ICE 1724) semi-pro card, although back in 14.0 days (pre pulse) the ESI did everything I ever asked of it with nary a complaint. That is no longer true and I can't just let Pulse takeover because it has almost 10 times the latency of Alsa and severely impedes any serious recording and editing.

Also I don't recall ever getting a dbus error before pulse became default and now I get them regularly and I've tried to find data on how to fix them but quite often the problem gets blamed on the app which helps me or anyone nada.

So I'm still looking but pleased to hear Bluetooth has an alternative now and of course to see a number of folks have similar interests. I do hope Patrick or Eric or someone can release a step-by-step to either eliminate pulse or get it to "play nice"
 
2 members found this post helpful.
Old 03-17-2018, 07:03 PM   #9
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,010

Original Poster
Rep: Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909
Quote:
Originally Posted by globetrotterdk View Post
I am not sure as to how much of this you can adapt to Slackware, as I am very new, but this is the guide that I successfully used when purging pulseaudio from my former Devuan Jessie install (I have gone completely slacky now):
http://linuxg.net/how-to-properly-re...ebian-squeeze/
Hopefully it will give you some inspiration.
While packaging commands are different in Slackware what you linked is almost identical to what one does to purge pulse altogether. I've tried living with pulse as is and purging it altogether just as you linked but neither is satisfactory. I am reticent to do that because there are apps that require pulse that won't respond to apulse and, unfortunately, it seems that list is growing. I don't see that changing in Alsa's favor (or mine) anytime soon so I'm figuring that if I can't have things like they used to be, where all I had to do was search and configure to get Alsa to do everything with sound I wanted, fundamentally at kernel level I should add, then I have to find a way for them to collaborate where the "driver" (and I) has priority, not the know-it-all "back seat conductor".

Again thank you very much for a thoughtful post that will very likely help others new to such change options.
 
Old 03-17-2018, 07:34 PM   #10
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,612

Rep: Reputation: Disabled
I do it this way:

1) Comment these lines in asound.conf:
Code:
pcm.default pulse
ctl.default pulse
2) Append these lines to /etc/pulse/default.pa:
Code:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
3) Keep this line in /etc/pulse/client.conf:
Code:
autospawn = yes
4) Don't start pulseaudio at login through a .desktop or otherwise.
5) Don't start pulseaudo system wide, of course.
6) Politely ask the apps that give this choice to rely on alsa if I prefer so. This usually can be done either with a configure option or setting a config file. An example is speech-dispatcher.

These settings allow to hear both some youtube stream through Firefox (using pulse) and orca reading the screen (through speech-dispatcher with alsa as audio backend). Also alsamixer and pavucontrol are both fully functional.

Last edited by Didier Spaier; 03-18-2018 at 04:06 AM. Reason: s/though/through/
 
7 members found this post helpful.
Old 03-19-2018, 03:46 AM   #11
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,010

Original Poster
Rep: Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909
Thank you Didier, that helps considerably which I don't quite understand since it appears to allow spawning pulseaudio but instead prefers ALSA which is the main issue and my distinct desire. However I must have some leftover config that conflicts to some degree because although I can now run Palemoon and listen to music at the same time that game sounds work in Steam games, for some odd reason the Firefox Nightly ( --- GitHub Firefox-FuckPA --- ) no longer plays music whether combined or alone. No biggy. I will either try going back to "normal" Firefox, use Palemoon instead, or search out what causes the problem with the NIghtly. Again, Thank You
 
Old 03-19-2018, 06:49 AM   #12
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,612

Rep: Reputation: Disabled
Quote:
Originally Posted by enorbet View Post
Thank you Didier, that helps considerably which I don't quite understand since it appears to allow spawning pulseaudio but instead prefers ALSA which is the main issue and my distinct desire
pulseaudio is only spawned if and by an application that needs it, so if an application preferably or exclusively rely on alsa this won't occur it will not spawn pulseaudio.

You can check looking at the pulseaudio processes running.
 
Old 03-19-2018, 09:32 AM   #13
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,010

Original Poster
Rep: Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909Reputation: 1909
Quote:
Originally Posted by Didier Spaier View Post
pulseaudio is only spawned if and by an application that needs it, so if an application preferably or exclusively rely on alsa this won't occur it will not spawn pulseaudio.

You can check looking at the pulseaudio processes running.
Yes I did "ps aux | grep pulse" which is how I discovered it wasn't getting launched, thus the kudos. Also I revisited the thread here about this sort of issue on Current (had forgotten that fix) and upon altering security.sandbox to "16" sound now works and I am very happy Many thanks
 
Old 03-20-2018, 12:32 PM   #14
FTIO
Member
 
Registered: Mar 2015
Location: Las Vegas, NV
Distribution: Slackware 14.1_32
Posts: 250

Rep: Reputation: 116Reputation: 116
Or, do as I have done, and when it comes to my music, I use my 14.1 system. If the next Slackware contains this escaped abortion known as pulse audio on it, 14.2 will be wiped from the drive and another distro found. One should not have to leap through hoops afire to get rid of the nasty thing called pulse on ones system...it reminds me of the old microshaft days.
 
1 members found this post helpful.
Old 03-20-2018, 10:28 PM   #15
JWJones
Senior Member
 
Registered: Jun 2009
Location: Cascadia
Distribution: Slackware -current
Posts: 1,067

Rep: Reputation: 359Reputation: 359Reputation: 359Reputation: 359
Quote:
Originally Posted by FTIO View Post
Or, do as I have done, and when it comes to my music, I use my 14.1 system. If the next Slackware contains this escaped abortion known as pulse audio on it, 14.2 will be wiped from the drive and another distro found. One should not have to leap through hoops afire to get rid of the nasty thing called pulse on ones system...it reminds me of the old microshaft days.
I know most slackers recommend that new slackers do a full installation, but I myself never do. I pick and choose what I want when I do a new Slackware installation. It's easy enough to avoid pulseaudio when you do this.

Having said this, I am currently using Gentoo on both a desktop and a laptop, both pulseaudio-free (see my signature).
 
  


Reply

Tags
alsa, current, dbus, pulseaudio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dbus-1.6.8-i486-1 in current shrourdian Slackware 2 03-25-2013 05:40 AM
Alsa to pulseaudio to Alsa - skype only problem Weber Kai Slackware 0 01-27-2012 08:23 PM
[SOLVED] Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash mad4linux Debian 1 01-26-2011 04:57 AM
[SOLVED] DBus 1.3.1 for 13.1 Current? SeRi@lDiE Slackware 11 11-05-2010 01:15 PM
DBUS Problem at -Current willysr Slackware 6 03-26-2007 11:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration