LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-17-2004, 11:48 AM   #1
bonecrusher
Member
 
Registered: Mar 2004
Location: St. Louis, MO
Distribution: Ubuntu, Debian, Slack, RH, Gentoo
Posts: 207

Rep: Reputation: 30
ALSA - CS4237B - no pcm ?


I have been trying to get alsa working. (and yes I have searched through most threads for this answer..cant find it...
The problem seems to be that I have no sound from PCM. I have CD sound working in console and KDE3.1, but nothings works as far as PCM goes. I also can't figure out to get the default card to card #1 (Card#0 is dummy).

I try:

aplay -d card1 /opt/kde/share/sounds/pop.wav
Playing WAVE '/opt/kde/share/sounds/pop.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono

(it looks like it played, but no sound...)

I have stored settings for card #1. I have tried everything I can think of.. I am sure alsa is loaded right...hmm? The Mic works, cd sound works...no pcm. (And it is nomuted). Anyway, I did notice that the device /dev/snd/pcm does not exist. the only file even close to pcm is /dev/pcmixer
And as I mentioned: Is there a way to set card #1 as default? it would save on the typing!

Welp, here are devices and ioports:

root@shea:/proc# cat devices
Character devices:
1 mem
4 /dev/vc/0
4 tty
4 ttyS
5 /dev/tty
5 /dev/console
5 /dev/ptmx
6 lp
7 vcs
10 misc
13 input
14 sound
29 fb
36 netlink
108 ppp
116 alsa
128 ptm
136 pts
180 usb
203 cpu/cpuid

Block devices:
2 fd
3 ide0
22 ide1

-=-=-=-=-=-=-=--=

root@shea:/proc# cat ioports
0000-001f : dma1
0020-0021 : pic1
0040-005f : timer
0060-006f : keyboard
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0120-0127 : CS4232 Control
0170-0177 : ide1
01f0-01f7 : ide0
0213-0213 : ISAPnP
0220-022f : CS4236+ SB
02f8-02ff : serial
0330-0331 : MPU401 UART
0376-0376 : ide1
0378-037a : parport0
0388-0389 : OPL2/3 (left)
038a-038b : OPL2/3 (right)
03c0-03df : vesafb
03f6-03f6 : ide0
0440-047f : pnp 00:08
0534-0537 : CS4231
0800-080f : pnp 00:08
0a79-0a79 : isapnp write
0cf8-0cff : PCI conf1
7400-74ff : 0000:00:0d.0
7400-74ff : 8139too
8000-8fff : PCI Bus #01
8000-80ff : 0000:01:00.0
9000-901f : 0000:00:07.2
9000-901f : uhci_hcd
9030-903f : 0000:00:07.1
9030-9037 : ide0
9038-903f : ide1
-=-=-=-=-=-=-
root@shea:/proc# cat modules
ppp_async 10368 1 - Live 0xd0ac2000
uhci_hcd 31112 0 - Live 0xd0ac8000

-=-=-=-=-=-=-
I don't know what else I should send...please let me know what files you would need to see and i will respond back.....

Thanks ahead (hopefully),

Brady
ps-I dont have anything loaded as module. So modprobe isnt working. But isapnp works. (At least is says things are activated...)
 
Old 03-18-2004, 10:36 AM   #2
bonecrusher
Member
 
Registered: Mar 2004
Location: St. Louis, MO
Distribution: Ubuntu, Debian, Slack, RH, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
Oh ya:

I forgot:
This is porobably pertinent too

I get this at boot time:



hmm(can't seem to find them with eirther dmesg or /var/log/message, but they say something like:

unable to load modules:
(can't find them or something)
oss-pcm-module
oss-mixer-module
(I know this isn't what it said but it is close i think)



Why would it not be able to find these?


-b
 
Old 03-22-2004, 07:47 PM   #3
dangerboy
Member
 
Registered: Aug 2003
Distribution: Slackware 12.1, Slackware Current, Ubuntu Hardy Heron 8.04
Posts: 110

Rep: Reputation: 15
Somehow, I think you and I are in the same boat. I have yet to get any answers, but if I do, I will let you know what worked for me. If you are interested to see my post, here it is:

http://www.linuxquestions.org/questi...light=infamous

Maybe this could give you some insiight that I couldn't see? Good luck.

Alex
 
Old 03-22-2004, 09:59 PM   #4
mooky
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Rep: Reputation: 0
I'm still a n00b, but I've successfully compiled a kernel that works pretty decently on my notebook (Thinkpad r40) You need to compile in (as a module):

oss-pcm-module
oss-mixer-module

They are under the "drivers -> sound -> Alsa" in menuconfig, you must compile them as a module as by default they are called as modules from whatever /etc/rc.d file they are called from, I _BELIEVE_ .. don't quote me on that, since I don't have my notebook with me right now to check.

You can compile them directly into the kernel also so they don't need to load them as modules tho, course then your still gonna get an error when your system boots as you'll be loading those components as part of the kernel, then it will error later on calling again to try to load them as modules. You'll have to find the correct config file and edit out the module calls.

Hope I've been of some small help. If I am mistaken, please, don't kill me, I'm a n00b and still learning myself
 
Old 03-23-2004, 07:02 AM   #5
bonecrusher
Member
 
Registered: Mar 2004
Location: St. Louis, MO
Distribution: Ubuntu, Debian, Slack, RH, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
yes, but

Quote:
Originally posted by mooky
I'm still a n00b, but I've successfully compiled a kernel that works pretty decently on my notebook (Thinkpad r40) You need to compile in (as a module):

oss-pcm-module
oss-mixer-module

They are under the "drivers -> sound -> Alsa" in menuconfig, you must compile them as a module as by default they are called as modules from whatever /etc/rc.d file they are called from, I _BELIEVE_ .. don't quote me on that, since I don't have my notebook with me right now to check.

You can compile them directly into the kernel also so they don't need to load them as modules tho, course then your still gonna get an error when your system boots as you'll be loading those components as part of the kernel, then it will error later on calling again to try to load them as modules. You'll have to find the correct config file and edit out the module calls.

Hope I've been of some small help. If I am mistaken, please, don't kill me, I'm a n00b and still learning myself
I got alsa working for the most part. I finally had to get the new drivers 1.0.3, then compile the kernal with JUST sound support. I then compiled the alsa driver, and lib, and utils.
Dont forget to uninstall old ALSA packages with removepkg or pkgtool. (I prefer pkgtool for this). THEN install all the new ALSA stuff. (1.0.3b at time of writing). I then recompiled the kernal again with alsa and alsaoss-emulation compiled in as MODULES. This finally got it working correctly. It loads my card on boot and does everything it's suppose to. (after i ran alsamixer then alsactl store) that turns the pcm and master on, and then saves that as default info. It is a shame it couldn't have just worked the way I had it, as I feel alsa should be able to be compiled in as non-mondule. But oh well...it works...well almost..in kdm, artsd has to be turned off or it doesn't want to work right. and I have found some other problems. But at least most things are working now.


-b

Last edited by bonecrusher; 03-23-2004 at 09:01 AM.
 
Old 03-23-2004, 08:59 AM   #6
bonecrusher
Member
 
Registered: Mar 2004
Location: St. Louis, MO
Distribution: Ubuntu, Debian, Slack, RH, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
Just a quick update,
I got everything working under KDE 3.2.1!
I am a happy person now. I set Artsd to on but selected Auto instead of ALSA. (For Audio device section). And then turned it back on... rebooted, and then everything started working fine.. (CD/Xmms/et al) Anyway, I guess installing new KDE/new ALSA/New Kernel, finally paid off. If I can help anyone out let me know, and I will go into more detail about what I did to get it all working. So at any rate I am sitting here listening to a Moby mp3 while writing you in Konquerer. Ahhh... (Sigh of relief...)

-b

Last edited by bonecrusher; 03-23-2004 at 09:03 AM.
 
Old 03-23-2004, 05:22 PM   #7
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Yea, It's a good feeling, huh? I just went thru the same crap. Could play music thru xmms but that was it. No sound server, no alsamixer, no audio cd playing.... Uninstalled all alsa packages and compiled new ones from source and everything works great now.... Modified modules.conf to load all the necessary mods that the new alsa built... sox doesn't whine about stuff anymore either... Those default slack-paks are compiled so generically that they don't seem to FULLY support any card... Just enough to have BASIC sound I guess.... Using a specific ./configure switch for your card probably helps alot too...

Last edited by jong357; 03-23-2004 at 05:26 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa - missing pcm JurajPsycho Linux - Software 2 03-30-2005 05:16 AM
pcm kmix, alsa problem with sis7012 ivan.tg Slackware 0 07-01-2004 06:47 AM
PCM anyone? (alsa) dhbiker Slackware 9 04-21-2004 06:52 AM
alsa pcm error with 2.6.1 kernel GŠutama Linux - Software 3 03-02-2004 12:44 AM
No PCM through ALSA wuck Linux - Software 1 11-07-2003 07:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration