LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-04-2018, 06:58 AM   #1
aaditya
Member
 
Registered: Oct 2013
Location: India
Distribution: Slackware
Posts: 162
Blog Entries: 2

Rep: Reputation: Disabled
alsa 1.1.7 not working in Slackware current


alsa failed to work after upgrade to 1.1.7.

Got error:

Code:
ALSA error: snd_pcm_hw_params_set_period_time_near failed: Invalid argument.
Downgrade to 1.1.6 worked.

The issue is known upstream: https://bugzilla.redhat.com/show_bug.cgi?id=1640602

System details:

Code:
$ inxi -Av1
System:    Host: slackware Kernel: 4.14.78 x86_64 bits: 64 Desktop: Xfce 4.12.4 Distro: Slackware 14.2 
CPU:       Dual Core: Intel Core i3-5005U type: MT MCP speed: 789 MHz min/max: 500/2000 MHz 
Graphics:  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
           Display: server: X.Org 1.20.3 driver: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.2.4 
Audio:     Device-1: Intel Broadwell-U Audio driver: snd_hda_intel 
           Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.14.78 
Drives:    Local Storage: total: 931.51 GiB used: 505.94 GiB (54.3%) 
Info:      Processes: 181 Uptime: 2h 30m Memory: 11.64 GiB used: 1.72 GiB (14.8%) Shell: bash inxi: 3.0.24
 
Old 11-05-2018, 06:41 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,238
Blog Entries: 29

Rep: Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437Reputation: 2437
Member Response

Hi,

From -current Changelog;
Quote:
l/alsa-lib-1.1.7-i586-2.txz: Rebuilt. Fixed PCM interval. Thanks to aaditya.
Hope this helps.
Have fun & enjoy!
 
2 members found this post helpful.
Old 11-06-2018, 03:08 AM   #3
aaditya
Member
 
Registered: Oct 2013
Location: India
Distribution: Slackware
Posts: 162

Original Poster
Blog Entries: 2

Rep: Reputation: Disabled
Thank you Pat. :-)

It works!
 
  


Reply

Tags
alsa, slackware-current


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa problem after the latest slackware-current update perfect_circle Slackware 8 04-26-2006 03:15 PM
slackware-current and alsa equinox Slackware 13 05-10-2005 04:06 AM
Alsa broke while upgrading to Slackware-current Almighty-Bob Linux - Software 5 03-16-2005 09:07 PM
alsa / slackware current / Intel i810 hjles Slackware 14 01-25-2005 07:11 AM
Alsa not working correctly with SB Live under Slack Current njbrain Linux - General 5 04-01-2004 10:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration