LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-28-2020, 09:24 AM   #16
RadicalDreamer
Senior Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 1,077

Rep: Reputation: 529Reputation: 529Reputation: 529Reputation: 529Reputation: 529Reputation: 529

Thanks rherbert!

You can edit your System tray to hide one of volume controls. I prefer to use kmix because I can switch audio sources with it with ease and I like the other one because I can adjust the volume with it with my keyboard so I just hide it.

Last edited by RadicalDreamer; 02-28-2020 at 09:25 AM.
 
2 members found this post helpful.
Old 02-29-2020, 12:33 PM   #17
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
Just, within the last hour, I installed kde5 to a recent installation of -current and, yes, there are two volume icons.

Last edited by cwizardone; 02-29-2020 at 03:11 PM.
 
Old 02-29-2020, 01:06 PM   #18
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
Back in Xfce-4.12 now, but while using kde5 I noticed the GTK theme settings were missing, or, perhaps, they have been moved and I couldn't find them.

Last edited by cwizardone; 02-29-2020 at 01:25 PM.
 
Old 02-29-2020, 04:17 PM   #19
rherbert
LQ Newbie
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware64-current
Posts: 19

Rep: Reputation: 17
Quote:
Originally Posted by cwizardone View Post
Back in Xfce-4.12 now, but while using kde5 I noticed the GTK theme settings were missing, or, perhaps, they have been moved and I couldn't find them.
https://alien.slackbook.org/blog/pam...ges-available/


Quote:
alienbob
February 13, 2020 at 14:16
From the announcement: ” GTK apps now also automatically inherit Plasma’s settings for fonts, icons, mouse cursors and more.”

For now, and as always, the best reference for KDE5/Plasma remains AlienBOB's blog. Just sayin'.

Last edited by rherbert; 02-29-2020 at 04:19 PM.
 
1 members found this post helpful.
Old 02-29-2020, 05:49 PM   #20
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
Saw this, "...a much better integration of GTK+ based applications with the Plasma desktop theme, through the use of client-side decorations...."

But didn't read it to mean the GTK settings options had been completely removed. I would rather have the settings, but, then, I won't be running kde5, except for testing, every now and then.
 
Old 03-01-2020, 11:08 AM   #21
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
If one is only going to use kde5, then it doesn't matter, but kde5 still "doesn't play well with others."
Yesterday's installation to -current fouled my networkmanager and sound configurations in Xfce-4.12.
I was able to fix the network problem by re-installing networkmanger, but was not able to fix the sound problem, even after deleting every kde5 configuration file I could find in ~./home/user and ~./home/user/.kde.
Finally, I deleted (removepkg) every trace of kde5 from the hard drive, ran fstrim and rebooted.
Problems solved and Xfce-4.12 was once again running as it should.
I haven't re-installed kde4 and will not be installing kde5, again, for any reason.
OTOH, as I said, if the only DE you are going to use is kde5, then no problems.

Last edited by cwizardone; 03-01-2020 at 11:09 AM.
 
Old 03-01-2020, 02:12 PM   #22
Regnad Kcin
Member
 
Registered: Jan 2014
Location: Beijing
Distribution: Slackware 64 -current .
Posts: 289

Rep: Reputation: 188Reputation: 188
The beauty of Linux is the ability to customize on a rock-solid foundation.

The glory of Slackware (and of -current, particularly) is that one has full access to a complete and ever-expanding set of the tools that one needs to build (epoikodomeo) a customized working environment according to one's needs, preferences, and the time and effort that the individual is able and willing to expend. Some assembly may be required.

Last edited by Regnad Kcin; 03-01-2020 at 02:15 PM.
 
Old 03-01-2020, 09:24 PM   #23
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,123

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
Quote:
Originally Posted by cwizardone View Post
If one is only going to use kde5, then it doesn't matter, but kde5 still "doesn't play well with others."
<snip>
OTOH, as I said, if the only DE you are going to use is kde5, then no problems.
This could also have easily been worded; If one is only going to use xfce, then it doesn't matter, but xfce still "doesn't play well with others."

OTOH, as I said, if the only DE you are going to use is xfce, then no problems.


Last edited by chrisretusn; 03-01-2020 at 09:25 PM.
 
Old 03-02-2020, 01:08 AM   #24
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
Quote:
Originally Posted by chrisretusn View Post
This could also have easily been worded; If one is only going to use xfce, then it doesn't matter, but xfce still "doesn't play well with others."

OTOH, as I said, if the only DE you are going to use is xfce, then no problems.

Well, in a "recommended" full installation of Slackware, Xfce and kde have to peacefully co-exist, but kde5 mangles the Xfce settings. Xfce does not trash the kde5 setting.

Last edited by cwizardone; 03-02-2020 at 09:46 AM.
 
Old 03-02-2020, 10:55 AM   #25
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,123

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
Quote:
Originally Posted by cwizardone View Post
Well, in a "recommended" full installation of Slackware, Xfce and kde have to peacefully co-exist, but kde5 mangles the Xfce settings. Xfce does not trash the kde5 setting.
So if Xfce does not trash the KDE5 setting why is it, if I have tried the Xfce desktop, decide I don't like it, go as far to delete the related files/directories from my home directory, Xfce insist on adding the following file:
Code:
~/.config/xfce/xfconf/xfce-perchannel-xml/xfce-notifyd.xml"
This replaces KDE Notification service with Xfce Notify Daemeon disabling KDE notifications.

This ONLY happens IF I have switched to the Xfce desktop in the past. If I have never used Xfce, then this does not happen. I have machines that have never used Xfce, all is well. Only on machines that have use Xfce does this problem occur.

This problem is fixable. The thread discussing this is here

Bottom line Xfce cause this problem. Just like KDE causes a similar problem in Xfce.
 
Old 03-02-2020, 11:07 AM   #26
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,731

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
Quote:
Originally Posted by gegechris99 View Post
When I first installed KDE5 at end of 2019, I also had two volume controls in system tray. One was the Plasma audio control and the other one was kmix. I uninstalled kmix package to keep only the Plasma volume control.
Quote:
Originally Posted by cwizardone View Post
Just, within the last hour, I installed kde5 to a recent installation of -current and, yes, there are two volume icons.
Yes, I had this too. The way I fixed it is:
1) Right click on the desktop and choose Customize Layout
2) Click the little icon at the end of the panel (Configure Panel)
3) Hover the mouse over the system tray and click Configure
4) Choose the volume control that you don't want (note, they are different) and change Visibility to Always Hidden.

For what it's worth, this issue appeared for me long before the recent updates.
 
2 members found this post helpful.
Old 03-02-2020, 11:22 AM   #27
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado, USA
Distribution: Slackware
Posts: 614

Rep: Reputation: 199Reputation: 199
Simultaenous Audio Inputs

How do I enable simultaneous audio inputs in the latest ktown/KDE5 with -current & pulse? Simultaneous audio inputs used to work just fine. I'm not sure when this stopped working but it seems recent, maybe since the last kde5 updates.

My setup plays a single audio input in kde5 just fine. When a second audio input attempts to play simultaneously that process seems to wait until the first process is complete.

This only affects audio specifically in kde5. I am able to play simultaneous audio in tty2 & tty3 for example while kde5 is up in tty7. Makes me think pulse is running fine but the setting I need to find is in kde5. I tried poking around in both the pulse and kmix settings in the systray but no joy.

EDIT:
Found this in the syslog
Code:
Mar  2 10:03:08 desktop pulseaudio[9794]: [alsa-sink-ALC887-VD Analog] alsa-sink.c: Error opening PCM device front:1: Device or resource busy

Last edited by Chuck56; 03-02-2020 at 11:55 AM. Reason: add syslog info
 
1 members found this post helpful.
Old 03-02-2020, 11:38 AM   #28
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,555

Original Poster
Blog Entries: 1

Rep: Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962Reputation: 2962
@chrisretusn,
Interesting, but I've not had that problem. Notifications worked as they should in both kde5 and Xfce.
 
1 members found this post helpful.
Old 03-02-2020, 03:14 PM   #29
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 167

Rep: Reputation: 122Reputation: 122
Quote:
Originally Posted by chrisretusn View Post
So if Xfce does not trash the KDE5 setting why is it, if I have tried the Xfce desktop, decide I don't like it, go as far to delete the related files/directories from my home directory, Xfce insist on adding the following file:
Code:
~/.config/xfce/xfconf/xfce-perchannel-xml/xfce-notifyd.xml"
This replaces KDE Notification service with Xfce Notify Daemeon disabling KDE notifications.

This ONLY happens IF I have switched to the Xfce desktop in the past. If I have never used Xfce, then this does not happen. I have machines that have never used Xfce, all is well. Only on machines that have use Xfce does this problem occur.

This problem is fixable. The thread discussing this is here

Bottom line Xfce cause this problem. Just like KDE causes a similar problem in Xfce.
This config file also shows up under ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce-notifyd.xml
You can delete or rename it, restart x into plasma, and it will still be remade in the same location. I'm still not sure if that's an xfce4 vs plasma issue, or an upstream issue with how dbus services are started.

Quote:
Originally Posted by cwizardone View Post
@chrisretusn,
Interesting, but I've not had that problem. Notifications worked as they should in both kde5 and Xfce.
Notifications will still "work" with both xfce4 and plasma installed, but its actually running xfce4-notifyd in both DEs. You will only notice that xfce4-notifyd is running if you try to change the settings for the plasma notification system. Guess it's too late for you to check though, since you removed plasma.
 
2 members found this post helpful.
Old 03-02-2020, 08:32 PM   #30
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,123

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
Quote:
Originally Posted by 0XBF View Post
Notifications will still "work" with both xfce4 and plasma installed, but its actually running xfce4-notifyd in both DEs. You will only notice that xfce4-notifyd is running if you try to change the settings for the plasma notification system. Guess it's too late for you to check though, since you removed plasma.
Yes notifications do work, but not all of them. This is how I started looking in to this. I was wondering why I wasn't getting some notifications. It was then that I noticed tha KDE Notifications was disabled and the Xfce Notify Daemeon was being used.

This by-the-way is a new problem for me. This issue did not surface until after some updates in Slackware64-current and ktown sometime before February 24th or so. That is when I noted the thread discussing this issue. By then I had already found the "work around" 0XBF has also discovered.

It is interesting to note that I have a laptop with Slackware46-current (full install) and Plasma5 (ktown) installed in which Xfce has never been used. This issue is none existent on that laptop. The interesting and puzzling thing to me is I went ahead and switched it over to Xfce. Later I switched back to KDE Plasma. This issue does not happen only on this laptop. The only difference between my other machines and this laptop is the laptop boots to runlevel 4 using SDDM to login. I switched between desktops using the SDDM interface. All of my other machines boot to runlevel 3 and I use startx to fire up the DE and use xwmconfig to set which window manager to start. I have not tried this yet on the laptop but plan to, to see what happens.

Edit: Testing didn't make a difference, this laptop as far as KDE Plasma goes has no issues and this is with nothing removed from 'home'. One thing I did notice is that:
Code:
~/.config/xfce/xfconf/xfce-perchannel-xml/xfce-notifyd.xml
is not there.

Last edited by chrisretusn; 03-02-2020 at 08:53 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware 14.2 x86_64 plasma 5 installation. when I run "xwmconfig", "xinitrc.plasma" is not listed as an option? rockinroyle Slackware 9 07-31-2016 03:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration