LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   All Things KDE5/Plasma for Slackware Users. (https://www.linuxquestions.org/questions/slackware-14/all-things-kde5-plasma-for-slackware-users-4175670109/)

LuckyCyborg 07-19-2020 10:19 AM

BTW, I do not remember if I mentioned already somewhere else and if this isn't somehow off-topic, BUT I have a box where the KDE4 shipped by -current runs like a Hero on top of the elogind "donated" by latest KTown.

Basically, I removed the ConsoleKit2, then installed elogind and upgraded dbus.

That's all I needed to run KDE4 on top of a login1 API while even XFCE as shipped by -current runs also with no visible issues.

mlangdn 07-19-2020 05:11 PM

I had my first Plasma glitch this morning. I was removing google-earth to upgrade to a newer version. After the removal, I deleted the desktop icon shortcut , ran deb2txz on the new file, then installed. I popped up kmenuedit to create a new item for the new GE, made it, then moved it to the desktop. No icon on the desktop worked at that point. None in the tray worked, and there were no applications at all in the start menu. Had to do a hard reset, then all was fine again. No problems since. Oh well.....

cwizardone 07-22-2020 02:06 AM

"Konsole in 2020"

Notable improvements to Konsole,
https://tcanabrava.github.io/2020/07...nsole-in-2020/

cwizardone 07-25-2020 09:47 AM

This week's list of new features, changes and bug fixes for kde5,

https://pointieststick.com/2020/07/2...rd-on-wayland/

gmgf 07-29-2020 06:33 AM

For info if you update 'plasma-wayland-protocols' to 1.1.0 version, plasma-wayland session crash, it need this patch:

https://invent.kde.org/libraries/pla...404ae95b.patch

and 'kwayland-server' need to be rebuild with this 'plasma-wayland-protocols' version patched.

Alien Bob 07-29-2020 10:37 AM

Quote:

Originally Posted by gmgf (Post 6150564)
For info if you update 'plasma-wayland-protocols' to 1.1.0 version, plasma-wayland session crash, it need this patch:

https://invent.kde.org/libraries/pla...404ae95b.patch

and 'kwayland-server' need to be rebuild with this 'plasma-wayland-protocols' version patched.

Thanks Gerard.

gmgf 07-29-2020 11:11 PM

This day in current ChangeLog:

x/hack-fonts-ttf-3.003-noarch-1.txz: Added.
Thanks to alienBOB.
x/noto-cjk-fonts-ttf-2.001-noarch-1.txz: Added.
Thanks to alienBOB.
x/noto-fonts-ttf-20171024-noarch-1.txz: Added.
Thanks to alienBOB.

I think it's one good news, for 'plasma' users ;)

Thanks, Eric ;)

Alien Bob 07-30-2020 09:55 AM

Quote:

Originally Posted by gmgf (Post 6150564)
For info if you update 'plasma-wayland-protocols' to 1.1.0 version, plasma-wayland session crash, it need this patch:

https://invent.kde.org/libraries/pla...404ae95b.patch

and 'kwayland-server' need to be rebuild with this 'plasma-wayland-protocols' version patched.

The new 1.1.1 release of plasma-wayland-protocols which should appear on download.kde.org any moment now, includes this fix.

gmgf 07-31-2020 08:47 AM

Ok, Eric, this new version fix the problem ;)

enorbet 07-31-2020 01:59 PM

Minor bug on Late June -Current with KTown. In System Settings > Workspace Behavior if I select "Virtual Desktops" System Settings crashes and closes. It does post a Notification that it crashed though ;)

Right now I'm wrestling with a sudden change in Desktop behavior in KTown. I've been using the same .conkyrc in numerous distros and numerous instances of Slackware and all work EXCEPT very suddenly and for no apparent reason my Main install on my new SSD (which is awesome!) had Conky suddenly revert to a black background instead of showing the Desktop Wallpaper through transparency. No changes were made to .conkyrc. In fact I even copied over the .conkyrc on my new Main from the hdd install I originally cloned onto SSD.

I suspect it may have something to do with KWin since Conky is still transparent in Xfce and naturally (no compositor) only has black background in Fluxbox. I don't think I changed anything on purpose for Kwin yet behavior is different in original and clone.

FWIW both kwin_x11 and kwin_wayland are running. That's normal right?

Edit: Hmmm maybe it happened after I setup and used Fluxbox?

drgibbon 07-31-2020 03:09 PM

Quote:

Originally Posted by enorbet (Post 6151415)
Minor bug on Late June -Current with KTown. In System Settings > Workspace Behavior if I select "Virtual Desktops" System Settings crashes and closes. It does post a Notification that it crashed though ;)

I've had this before, but on two recent fresh installs of ktown it's disappeared.

pomf 07-31-2020 04:42 PM

Quote:

Originally Posted by gmgf (Post 6150836)
This day in current ChangeLog:

x/hack-fonts-ttf-3.003-noarch-1.txz: Added.
Thanks to alienBOB.
x/noto-cjk-fonts-ttf-2.001-noarch-1.txz: Added.
Thanks to alienBOB.
x/noto-fonts-ttf-20171024-noarch-1.txz: Added.
Thanks to alienBOB.

I think it's one good news, for 'plasma' users ;)

Thanks, Eric ;)

191M of disk space wasted, into the greylist noto went ;)

LuckyCyborg 07-31-2020 05:31 PM

Quote:

Originally Posted by enorbet (Post 6151415)
FWIW both kwin_x11 and kwin_wayland are running. That's normal right?

No, it is NOT normal. Probably you messed something.

I assure you that on a Wayland/Plasm5 session runs only kwin_wayland, while in a classic X11/Plasma5 session runs only kwin_x11.

LuckyCyborg 07-31-2020 05:34 PM

Quote:

Originally Posted by pomf (Post 6151464)
191M of disk space wasted, into the greylist noto went ;)

Who cares about additional 200MB wasted, when we are already have around 15GB occupied by system, as it is with The Recommended Full Install?

drgibbon 07-31-2020 05:45 PM

Quote:

Originally Posted by enorbet (Post 6151415)
FWIW both kwin_x11 and kwin_wayland are running. That's normal right?

Negative!


All times are GMT -5. The time now is 02:32 AM.