-   Slackware (
-   -   All clocks correct, except KDE taskbar clock (

GrapefruiTgirl 03-13-2007 01:19 PM

All clocks correct, except KDE taskbar clock
My BIOS had/has the correct time before and after the new time change the other day.
My OS also shows the correct time on my login AND when I go into the date/time settings. System logs are all timestamped correctly too, and file-times etc.
The clock in my KDE taskbar is 3 hours fast., if I right click the taskbar clock, I get the date and time settings thing, which shows the correct time, even though the clock I just right clicked is wrong.

My time-zone is set correctly, and saves as LOCAL time upon shutdown.

Any clues anyone? I searched LQ and got results having nothing at all to do with KDE or clocks (Am I using the search thing right? I usually get weird results) and google wasn't much help either.

H_TeXMeX_H 03-13-2007 04:08 PM

Must be something about the KDE setting. I'm not familiar with KDE, but it must be somewhere in the control panel.

GrapefruiTgirl 03-13-2007 04:18 PM

:) Funny thing is, the control panel shows the correct time!
The correct time is everywhere except in the taskbar applet.
<-- baffled..

H_TeXMeX_H 03-13-2007 04:26 PM

That's very strange ... I really don't know.

XGizzmo 03-13-2007 06:22 PM

It sounds like the kde clock is set to display the wrong time zone. If you have a wheel mouse try hovering over the clock and scroll the wheel.
also you could try deleting the config ~/.kde/share/config/clock_panelapplet

GrapefruiTgirl 03-13-2007 07:10 PM

Hey, thanks for those suggestions. Unfortunately scrolling the mouse wheel over the applet did nothing, but I did delete the file you specified, and since nothing changed yet, I'm assuming any change that may occur will do so after I kill KDE and restart, so I will update again after I do that shortly.

Daedra 03-13-2007 07:27 PM

try this command as root


and see if that fixes your prob.

GrapefruiTgirl 03-13-2007 07:39 PM

OK, logging out and back in to restart KDE, I see that having deleted the .config file for the clock_applet only caused my appearance settings for the clock to revert to default, but didn't change the time.
I tried netdate, and I suspect the request went out but my firewall blocked the returning data, because it returned 'netdate failed.'. Does netdate need the NTP port open? If so, there's the problem, or part of it..
:) Thanks again. I will do a test with the time port allowed by the firewall and see what happens.

GrapefruiTgirl 03-13-2007 08:19 PM

OK, netdate repeatedl;y returns the following:

netdate: send: Operation not permitted
Connection with udp to failed.
Even though I have allowed outgoing and incoming TIME and NTP protocol packets via the firewall.
Last thing to check as far as 'netdate' goes, would be that my inetd.conf is fully commented out, but.. Well, I can't see that preventing me from sending the request.
I'm connected through a Windows machine by LAN, maybe therein lies the issue..

deltabrown 03-14-2007 12:38 PM

Are you running nptdate as root? Check the man page, but I think a '-g' option will allow a 'big' correction. ntpd can not be running at the same time.

I don't think the firewall is the issue as you should have an 'ESTABLISHED-RELATED' connection with the time server if you initiate the connection from inside the firewall (assuming common firewall rules apply).

I don't know if this will fix the KDE issue but should allow you to sync-up your clock. Also check into `hwclock --systohc` to also sync the BIOS real-time-clock (I do this as a cron job on all servers).

One last suggestion is to verify the proper time zone files... should be /etc/localtime and also an informational link named /etc/localtime-copied-from -> /usr/share/zoneinfo/...something...
`ls -al /etc/local*` should do the trick.

GrapefruiTgirl 03-14-2007 06:03 PM

Great :) I love when another new person shows up with suggestions!
@ Deltabrown, Yes, I ran 'netdate' as root, and incidentally I did check the man page while I was experimenting with it, but don't recall anything about the -g option. Iwill however check again shortly. I still am leaning towards that this is a KDE issue, and may have to pursue that angle, since all the system clocks including the KDE control panel show the correct time. It is the oddest thing.
- I agree with you on the firewall, too. And btw, I am not running the ntpd at all.
I will look into syncing the HWclock to system time, never know, 'something's' going to work eventually :P
My localtime file is correct, but I didn't know about the symlink you indicated there, I will look into that vey shortly too (like after supper :) I'm hungry right now!!)
Thanks very much for the input; I'll post the results soon!

GrapefruiTgirl 03-14-2007 06:29 PM

UPDATE: Netdate (at least my installed version) has no -g option, only -l for limit and -v for version.

I have synced the hwclock --systohc, that command worked fine, but no change.
And finally, yup my localtime file is correct, and the symlink exists and is correctly linked.
:( pooey!! lol, well thanks for the suggestions! I will continue to experiment meanwhile, and if/when I determine exactly how to fix it, I'll share. Jeepers, am I the only person with this issue?

Daedra 03-15-2007 02:10 AM

I had the problem to, but netdate worked for me, try this one...


Eternal_Newbie 03-15-2007 05:37 AM

Try using a totally different server for netdate, like one of the pool server for netdate, eg

That way you will see the problem with netdate is on your side or if the server is blocking unauthorised requests. It is also better practice to use pool servers.

I'm afraid I have no clue about your original problem. Does it show up under fluxbox and XFCE?

krussell 03-15-2007 08:51 AM

Hello GrapefruiTgirl :-)
I faced the same problem, and you don't have to use any command line for this as i understand.
Just right click the clock, check what "timezone" it is showing.
May be the timezone has +6 (or something) so it is showing the wrong value (sorry using a windows pc). Keep the timezone in your locality, then go to control center and also check for the timezone and make sure it is same as the clock, now in administrator mode correct the time.

All times are GMT -5. The time now is 09:50 PM.