-   Slackware (
-   -   agetty hangs on 10.1 (

Barx 04-11-2005 04:19 AM

agetty hangs on 10.1
Hi all

I have a problem on a laptop (Acer Aspire 1513 , Athlon 64 ecc ecc)

This is a clean install. For few days (about 1 week) all worked properly

Now I have a big problem on boot (I set to boot on level 4): X can't start, and there's no way to switch to another console by ALT-Fx nor CTRL-ALT-Fx.

But I'm able to login by ssh. So I tried switching to runlevel 3.

The login prompt re-appears, but I can't enter the username (it seems that it can't receive keystrokes)

If I switch to runlevel 4 it hangs, but I see messages like

INIT: Pid 7363 [id c2] seem to hang.

I get 4 lines with four distinct pids and ids

These pids correspond to agetty.

Now i changed the default runlevel to 3 but I always have this problem on boot

If I switch to runlevel 1 the system freezes on "Going to single user mode ..." and the prompt doesn't appear.

Do you have any suggestion?

Tnx all in advance

gbonvehi 04-11-2005 04:43 PM

You can enter your system by booting from Slackware CD 2 or 1, mounting your harddrive somewhere like /mnt with: mount -t reiserfs /dev/hda0 /mnt
Of course you need to change the parameters to suit your system.
Then you can edit the files you need there and also do: chroot /mnt. That will change your root directory (/) to /mnt
But before all that you should remember which changes you made to make agetty crash, any update or something?

Barx 04-12-2005 02:01 AM

I can login via SSH and I have full access to the system, but only via ssh.

I can't understand which are last changes to the system because I've installed it few days ago and it's still unmodified ..

This error seem born by itself .. no idea.

And I'm asking in this forum to hear some idea on which to test

The strange thing is that 1 time on 10 boot it works properly, but I can't understand why ...

gbonvehi 04-12-2005 02:23 AM

That's very strange then. Did you try seeing the log files with SSH while you try to log-in from your laptop? Any other output besides the hang problem?

Barx 04-20-2005 12:49 PM

Finally I found the problem: the usb mouse

If rc.hotplug runs when the usb mouse is already connected i get that error.

To avoid this problem there are three ways:

- connect the mouse when rc.hotplug is ran
- disable rc.hotplug
- use kernel 2.4

I tried both 2.6.10 and 2.6.11 precompiled, I tried upgrading the hotplug package, I also tried updating udev, but there's no way to have the system working when booting with the usb mouse connected.

For now I connect the mouse later, this is a laptop and isn't a problem to plug and unplug the mouse

I haven't tried with a mouse of another brand, and I haven't tried compiling the kernel by myself.
And also I haven't tried an old 2.6 kernel.

Do you have any suggestion to have the system booting with the mouse connected??

(if there's no solution , I'll continue plugging the mouse later .. )

Tnx all

gbonvehi 04-20-2005 08:16 PM

Try adding the modules the mouse loads to hotplug's blacklist in /etc/hotplug/blacklist.

All times are GMT -5. The time now is 08:00 AM.