-   Slackware (
-   -   After slackpkg update(all current p'kges), Slackware 10 stops loading (black screen). (

SlawioG 11-27-2004 07:17 PM

After slackpkg update(all current p'kges), Slackware 10 stops loading (black screen).
After installing and configuring this distro (it took me half a day) I thought, that it would be a good idea to update installed packages. I installed slackpkg, edited configuration files (pointing to the local server with current version) and started updating all ("slackpkg upgrade slackware"). Everything had looked fine, there were no errors, so I've rebooted (ctrl+alt+del) after it finished updating. From that point Slackware stopped responding - it just hangs after "Checking Bios....", no reaction, just blank, black screen.

What's going on? Do I have to update everything manually (oh dear God, it's so exhausting and borring - maybe I'm getting lazy). have a clue?

[Edit] I've just figured out what went wrong. I didn't notice that, the kernel was upgraded to 2.4.27 and the old one (2.4.26) was deleted. I should have launched lilo... :/ Nevertheless thanks for reply.

deleshai 11-27-2004 09:57 PM

Just a quick thought that I tried and worked.. I still have to fix what I am working on but this is what I did.
I did a new kernel and when I loaded it I got a blank screen, the drive seemed to still be moving so I wated a few moments and logged in even so I could no see anything.
try to log in as root
then startx
in slack 10 I dont think you need a password.
Not a fix but worth trying

Bluesuperman 11-27-2004 10:14 PM

It is most likely a problem with your video drives and resolution settings ... or your remove video support from the kernel.

Load up the slackware CD and mount the root partition rw and in the lilo config make vga = normal. Then chroot to the directory you just mounted and run your lilo confi ... if you are using lilo.

It that does not fix it ... try using the default kernel.


Slovak 11-28-2004 09:19 AM

Run xorgconfig from cli, that should do the trick since you also updated X, found out the hard way myself last time I updated like that from a virgin install.

All times are GMT -5. The time now is 01:33 AM.