-   Slackware (
-   -   afp error using 14.1 opening finder window from MAC 10.6.2 (

micnet 12-29-2013 10:33 PM

afp error using 14.1 opening finder window from MAC 10.6.2
My old 13.0 box worked fine. Just installed 14.1 and trying to get my old stuff working again.

I get this error when trying to login to my Slack box from my Mac.
Mac OS is 10.6.2, Slack 14.1

Finder menu=> Go -> Connect to Server
Connecting to Server, Connecting to afp://
Then I get the login/password dialog box, enter the data, then the message:
"You entered an invalid username or password. Please try again. OK"

Of course I confirmed that I can log in from Telnet and Xterm, so the login/password is good.
No error messages in log files.

Any suggestions, and thanks in advance!!

gengisdave 12-30-2013 12:09 AM

afp is not valid for non-mac, try using smb:// or nfs:// (the first is easier), but, what kind of login are you trying? just shared folder or something more?

micnet 12-30-2013 01:31 AM

Worked before. Just trying to open a finder window to access files on my home directory on the Slackbox.

gengisdave 12-30-2013 01:40 AM

Is netatalk running on slack? Can you see its log?

micnet 12-30-2013 05:53 AM

Thanks for taking an interest.

There seem to be NO entries in either /var/log/messages or /var/log/syslog. Very strange.

But wait, I may have deeper problems with 14.1. I can not get an X client like xeyes to display on other X windows servers. Some clients work on my Mac 10.4 X server while NONE work on 10.6. For instance: xpdf works on 10.4 mac, but does not work on 10.6.

Do you want to see an 'strace'? Is slack 14.1 just a looser? Should I go back to 13.0? Configuration issues are one thing, but debugging serious errors in programing and compiling are another!!

gengisdave 12-30-2013 01:51 PM

not totally sure, because it requires many tests, but it seems newer versions of macos dumped x11 libraries or use a slightly different one, so it's no more possibile this cross-use, more info needed :) (i have a maverick installed, i can do some test in the future)

speaking of netatalk, 'ls -l /var/log/packages/netat*' to see if package is installed, then check that his script is launched at boot 'ls -l /etc/rc.d/rc.atalk' and check it has execution perms (usually 755, or 'chmod 755'), then it's only a config problem

All times are GMT -5. The time now is 03:57 PM.