LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-04-2020, 05:41 PM   #1
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,939

Rep: Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001
Advice on Pure ALSA for -Current and KDE/KTown Needed


Greetz
Since the Pure ALSA directory in Extra only contains KDE files for v4 I assume KTown won't work as Pure ALSA.

So what is the recommended procedure for running KTown and defaulting to (nearly) Pure ALSA whenever possible? I'd prefer Pulseaudio never actually load. Is that possible with KTown?

Last edited by enorbet; 04-09-2020 at 12:29 AM.
 
Old 04-04-2020, 07:41 PM   #2
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,240

Rep: Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932Reputation: 4932
It may just require compiling ktown on an alsa-only system. You may want to grep through the source directory first for any pulseaudio options, so you can revert them before compiling.
 
Old 04-05-2020, 06:04 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,083

Rep: Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881
Try recompiling ktown's phonon and phonon-gstreamer packages. May be sufficient. And remove plasma-pa package.
 
2 members found this post helpful.
Old 04-05-2020, 06:08 PM   #4
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,939

Original Poster
Rep: Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001
Thank You Alien Bob. I'll try that and report back.
 
Old 04-06-2020, 11:23 PM   #5
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,939

Original Poster
Rep: Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001
I had hoped to be getting back with good news but I'm stopped short as SDDM works but won't launch Plasma5 and I get numerous errors trying to launch from runlevel 3 with startx, even DBus errors. I'm doing this on a fresh install so Alien Bob is it best to install from the iso leaving out KDE altogether as a starting point? and then installing KTown, then converting to multilib, then going Pure Alsa and then rebuilding the two phonon files?
 
Old 04-07-2020, 02:14 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,083

Rep: Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881
Your guess is as good as mine. Recompiling getreamer and photon packages should not kill Plasma5.
 
Old 04-09-2020, 12:36 AM   #7
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,939

Original Poster
Rep: Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001Reputation: 3001
Apparently I screwed up leaving out a couple Wayland packages. I installed those and KTown ran great. Then I setup MultiLib and it still runs great. I'm getting an idle resource usage of ~4% CPU and ~8% RAM even with Baloo running unmodified for a day. Now I guess I'm ready to tackle re-compiling the phonon packages after I try Pure-ALSA setup. I really hope I can get KTown running as Pure ALSA but this latest version, 5.68.0, runs really sweet. Kudos Alien Bob... you da Man.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware-current 64 bit, pure-alsa, how to manage updates for pure-alsa-system? igadoter Slackware 17 11-19-2018 03:10 AM
[SOLVED] Thanks for the pure alsa software in /extra/pure-alsa-system hitest Slackware 118 11-16-2018 05:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration