LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-12-2003, 02:25 PM   #1
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Rep: Reputation: 30
Angry adsl-start problems in slack 9.1


HI!

ok, this is my prob;

AFTER 3 GOD DAMN MONTHS WAITING FOR MY ADSL, i get the lovely dsl package. i log into linux, full of enthusiasm.

i use the adsl-setup command, everything seems fine. i do the adsl-start command. it says "connected".

i try to search the net, wont work. its like im not even connected. i do the adsl-setup again, same way, no mistakes. i try adsl-start again. this time it dont even say "connected", it makes alot of "........"'s, and eventually it says there's some kind of problem with "ppp2" or something. any1 with the answers i need? would REALLY apreciate it!! (btw, the adsl works in Windows)

// Thanks
 
Old 11-13-2003, 04:02 AM   #2
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
anyone...? please please
 
Old 11-13-2003, 04:32 AM   #3
plosiv
LQ Newbie
 
Registered: Sep 2003
Distribution: Slackware 9.1
Posts: 10

Rep: Reputation: 0
What kind of modem do you have?

I myself have an USB Speedtouch modem which works like a charm. If you have one of those, check speedtouch.sf.net. Which will tell you everything you need to know and do to get it to work.
 
Old 11-13-2003, 04:41 AM   #4
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Sounds like you need to set up PPPoE. Try the roaring peguin package, it's on the Slack install disc in the network directory. In slack 9.0, it's called rp-pppoe-3.5-i386-1.tgz

On another note, could you watch the language a little bit? There are younger readers that use this forum, after all.

Enjoy!
--- Cerbere
 
Old 11-13-2003, 09:23 AM   #5
davidschob
Member
 
Registered: May 2003
Posts: 56

Rep: Reputation: 17
can you ping any ip addresses? it sounds like it may be a dns problem. I use rp and sbc dsl and had to manually put in the dns servers as rp wouldn't grab them from the servers.
 
Old 11-13-2003, 11:08 AM   #6
fasta
Member
 
Registered: Aug 2003
Location: Livorno - Italy
Distribution: Debian
Posts: 84

Rep: Reputation: 15
Connect then "man host" && tell us if your DNS are correctly resolving names.
If not

vi /etc/resolv.conf


add 1 line

"nameserver <DNS_SERVER_IP>"

for each DNS you were provided with.

GL
 
Old 11-14-2003, 07:42 AM   #7
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
aight, sorry for the language. well, i usually don't use dns. do i NEED it for adsl to work? and i am using the roaring penguin i think. its the adsl-start command anyway. and what's the pppoe thingie for?
 
Old 11-14-2003, 09:19 AM   #8
davidschob
Member
 
Registered: May 2003
Posts: 56

Rep: Reputation: 17
You need to resolve domains somehow. There is a RP function that gets the DNS servers from the host (under DNS you type "SERVER"), but, at least in my case, it didn't always work. Best bet is to run adsl-setup again and manually put in the DNS servers of your ISP. If you don't know them, they're usually posted somewhere on their website, or a tech support guy should be able to help.

Good luck.
 
Old 11-14-2003, 09:20 AM   #9
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
But dude, i got no idea what my dns is. you did get that i got ADSL, not DSL- right?
 
Old 11-14-2003, 09:21 AM   #10
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
and i've tried the adsl-setup like 5 times
 
Old 11-14-2003, 10:15 AM   #11
davidschob
Member
 
Registered: May 2003
Posts: 56

Rep: Reputation: 17
I hear you... Check with your ISP's website or give the tech support number a call they'll give them to you. Just tell them you can't seem to get your machine to pull them from the server. Without some sort of name service your internet will be up but you won't be able to resolve any names.
 
Old 11-14-2003, 10:17 AM   #12
iro
LQ Newbie
 
Registered: Dec 2002
Location: Australia
Distribution: Slackware-current
Posts: 10

Rep: Reputation: 0
Install roaring penguin PPPoE (as described above).

Find out the DNS server's IP address (If you ring your ISP they will tell you this, or duplicate your Windows DNS settings if they exist).

Put your DNS servers IP address (as described above) in /etc/resolv.conf and run:

Code:
adsl-setup
that will start a setup utility. Answer a few questions there, including such things as your user/pass, and firewall preferences, and you should be away. You can then run:

Code:
adsl-start
or
Code:
adsl-stop
as required.

Yes, a DNS server is needed!

DNS allows you to type in www.google.com and actually have it routed to the right IP address out there.

Last edited by iro; 11-14-2003 at 10:22 AM.
 
Old 11-14-2003, 10:19 AM   #13
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
i've done the adsl-setup, it still wont work. and i dont use dns in windows. when i try the ipconfig config command, i dont see no dns. i gotta dialup the adsl myself, i dunno if that got anything to do with it...?
 
Old 11-14-2003, 10:20 AM   #14
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Original Poster
Rep: Reputation: 30
my windows ipconfig:



Ethernet adapter Local Area Connection:



Connection-specific DNS Suffix . : lan

IP Address. . . . . . . . . . . . : 10.0.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.0.0.138



PPP adapter adsl:



Connection-specific DNS Suffix . :

IP Address. . . . . . . . . . . . : 80.212.14.223

Subnet Mask . . . . . . . . . . . : 255.255.255.255

Default Gateway . . . . . . . . . : 80.212.14.223
 
Old 11-14-2003, 10:21 AM   #15
iro
LQ Newbie
 
Registered: Dec 2002
Location: Australia
Distribution: Slackware-current
Posts: 10

Rep: Reputation: 0
If you browse the web in Windows, I can guarantee you that you use a DNS server.

try

ipconfig /all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl-setup or adsl-start not found as user! bnchakraborty Linux - Newbie 2 01-18-2008 10:23 PM
Monitoring ADSL (to keep online), adsl-start michaelsanford Linux - Networking 7 07-12-2006 06:43 PM
adsl problem foe slack 10 shazde Slackware 2 07-22-2004 03:28 AM
Slack 9.1 / ADSL issue Cyclops Slackware 4 10-25-2003 08:10 AM
USB ADSL modem and Slack Savagekitty Slackware 2 08-28-2003 08:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration