LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Adobe Reader 9 associated itself to every file type in Xfce 4.4. (https://www.linuxquestions.org/questions/slackware-14/adobe-reader-9-associated-itself-to-every-file-type-in-xfce-4-4-a-860522/)

stf92 02-03-2011 01:35 PM

Adobe Reader 9 associated itself to every file type in Xfce 4.4.
 
kernel 2.6.21.5, GNU/Linux (slackware 12.0).

Hi:
I had the bad idea of installing Adobe in my linux box and, as a result, even when I click on a .flac file the reader opens. What is bad about this is that Xfce help system is very poor. Menu bar>Help uses internet to open the site page, where there is very little help indeed.

Right clicking, for example, an HTML file, I can choose the application to open it with and I'll be asked if I want this to be the default action. But for every file type I should be making this work! Perhaps deleting a hidden file in ~/ where xfce registered the associations. I do not want to uninstall Adobe as it is really fast scanning docs. Any hint?

frankbell 02-03-2011 10:24 PM

Since this is Slackware, I'm assuming you have KDE installed. If so . . .

Open Konqueror and click Go-->Applications-->Settings-->File Associations.

Use the "Find" window to locate the file types and correct the associations.

I would also junk Acrobat Reader and use a Okular (the old Kpdf).

I haven't yet run into a PDF that Okular did not handle just fine (if you still have to use Windows, junk Acrobat Reader and use Foxit Reader).

stf92 02-04-2011 07:22 AM

Thanks for your reply. KDE I have it installed, only for the benefit of its apps. But as a desktop environment I use Xfce. So it's really Xfce who must handle file associations, I think.

To make things worst, I seem to have lost the original associations. If I had a file whose type was unfamiliar to me (and suppose the file command does not know the type either), Xfce knew and a click revealed the application it was designed to run it with.

I'll give Okular a try. Foxit Reader is my default PDF reader in Windows.

Coming back to the issue, if I only knew where Xfce keeps the assocs, I would edit or remove the file. Another course of action would be just to delete ~/. after relocating my personal data. I assume the next execution of Xfce would create all the necessary files again. Regards.

Perceptor 02-04-2011 07:43 AM

Why don't you just reinstall the xfce package?

stf92 02-04-2011 07:48 AM

Yes, I gave that a thought already, but wasn't quite sure. Seems easier and that's what I'll do. Thanks.

dh2k 02-04-2011 08:27 AM

1> You say you are using Slackware 12.0 in your first post? Okular is for KDE4.* - found on Slackware 13.0 and higher.

2> Is your problem the same for all users and root or just your user profile?

If it is just your profile then (edit or) delete (backup first? - your choice)
~/.local/share/applications/defaults.list
Code:

cp ~/.local/share/applications/defaults.list /tmp/defaults.list_BACKUP
rm ~/.local/share/applications/defaults.list

This will then default to system wide default apps.

If the problem is system wide then ... will complete soon!

stf92 02-04-2011 03:35 PM

1> I do use Slackware 12.0.

2> Just for my user account. There are two of them: a normal user and root.


I did then the deletion thing, and the normal user seems to have come back to the normal values. Problem solved. A noticeable thing, however, is that ~/.local/share/applications/defaults.list, where ~/ is the normal user dir, is empty. It's only line is
Code:

[Default Applications]
, although before the deletion (I exited X after the deletion and restarted it) it was not empty. All entries were associations with Adobe, except one.

The fact that it is empty, therefor, comes as no surprise, except for the non-Adobe entry. The true default associations must be built-in into the code, I suppose. For else, how does xfce know that it must open .txt files with mousepad, as it in fact does? Well, good bye and thanks for your repl and generous help.

frankbell 02-04-2011 05:24 PM

I regularly use multiple window manager/desktop environments on the same computers, though I tend to default to Fluxbox as my primary choice: Fluxbox/KDE/Gnome depending on the distro and computer.

Manipulating file associations under one has always carried through to the others when I've changed environments.

I don't think you have different sets of file association for XFCE and for KDE--I think both desktops access the same database, problably in a hidden file or directory in your /home, but display the interface to it differently.

If I am wrong, I trust that someone will educate me.

stf92 02-05-2011 06:13 AM

Thank you guys.

dh2k 02-06-2011 04:59 AM

Quote:

Originally Posted by dh2k (Post 4248274)
1> You say you are using Slackware 12.0 in your first post? Okular is for KDE4.* - found on Slackware 13.0 and higher.

2> Is your problem the same for all users and root or just your user profile?

If it is just your profile then (edit or) delete (backup first? - your choice)
~/.local/share/applications/defaults.list
Code:

cp ~/.local/share/applications/defaults.list /tmp/defaults.list_BACKUP
rm ~/.local/share/applications/defaults.list

This will then default to system wide default apps.

If the problem is system wide then ... will complete soon!

3> System wide application defaults can be found (I think) in file at path
Code:

/usr/share/applications/mimeinfo.cache
these are over-ridden by user settings at
Code:

~/.local/share/applications/defaults.list
if ~/.local/share/applications/defaults.list has any file-type entries in defaults.list


All times are GMT -5. The time now is 10:37 AM.