LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-11-2003, 11:36 PM   #1
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
Adding fonts in Slack 9


I'm a newbie to Slackware, I am trying it out as an alternative to the Mandrake distros I have been using for some time now. I got everything running well for the most part, but I can't seem to get imported fonts to work, or even figure out how to restart xfs for that matter.

On Mandrake this is how I got them to work: First, I went to the directory all the other fonts were in, /usr/X11R6/......./fonts and created 2 directories, one for windows TTF fonts which I copied from my windows partition, and another for the artwiz fonts for Fluxbox. I then put the fonts in their respective directories, ran mkfontdir for the artwiz fonts, ran ttmkfdir >fonts.dir for the windows fonts. Then I edited /etc/X11/fs/config, and added the paths to the 2 new directories to the "catalog" entry in that file. Then I also added the new directories to /etc/X11/XftConfig. When I had done that, I ran /etc/rc.d/init.d/xfs restart, and voila, fonts work.

Now, it appears to me that Slackware deals with fonts in a completely different manner than MDK, which is not really all that surprising since MDK decides to change how they deal with fonts from version to version.

So far, in Slackware 9.0 I have created the directories for my new fonts, and copied the fonts I want to add to these new directories (a la what I did for Mandrake). I tried running ttmkfdir and mkfontdir (as root of course), and the commands do not even seem to be present on my system, though their man pages are. No worries, I just mounted my Mandrake partition and copied the fonts.dir files over. I then added the 2 new directories to /etc/X11/fs/config.

The problem I am having now, is that I have no XftConfig file. Nor do I see an init.d directory in /etc/rc.d (I am guessing this is MDK-specific?). And I can't seem to find the location of the xfs script so I can restart the font server (possibly also MDK-specific). I tried rebooting to let the font server reinitialize, and I couldn't see my new fonts.

If anyone could provide some insight as to how I can get these fonts working in Slackware, I would appreciate it.

Thanks,
Erik

Last edited by Locura; 05-12-2003 at 12:16 AM.
 
Old 05-12-2003, 06:13 AM   #2
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
So yr problem is normal!! On SLack 9.0 doesn't exists mkfontdir...
You must follow these steps:

1- Create yr directory and copy the fonts inside
2- Add yr directory path to the file /etc/X11/XF86Config (at the lines FontPath...)
3- Run INTO yr font directory: fc-cache -f

All should works!!!
Bye
Obscure

Last edited by Obscure; 05-16-2003 at 11:56 AM.
 
Old 05-12-2003, 01:31 PM   #3
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Original Poster
Rep: Reputation: 30
So, running that fc-cache command will restart the font server and allow me to see my new fonts?
 
Old 05-12-2003, 05:54 PM   #4
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
Yes!! The font server is integrated with XFree (I'm talking about XFree version 4.3.0)!

fc-cache -f rebuild the fonts.dir and fonts.scale files but you must tell to X to use this type of file adding a line in /etc/X11/XF86Config as shown in previous msg
Remember to use -f option to REbuild the file indexs (fonts.dir and fonts.scale)

Last edited by Obscure; 05-13-2003 at 05:52 AM.
 
Old 05-13-2003, 02:47 PM   #5
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Original Poster
Rep: Reputation: 30
Well, I also seem to have no fc-cache command. Again, though, the man page is there, just no command. Am I missing a package or something?
 
Old 05-14-2003, 06:35 AM   #6
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
It's strange!!
If you have Slack 9.0 and Xfree 4.3.0 fc-cache command should be installed!!Maybe is in a different path!
I don't know from which pkg or apps comes this command!!
Anyone knows??
I'll try to find an answer...
 
Old 05-14-2003, 06:56 AM   #7
JoooN
Member
 
Registered: Feb 2003
Distribution: Slackware 9.0
Posts: 46

Rep: Reputation: 15
run /usr/X11R6/bin/fc-cache
 
Old 05-14-2003, 10:33 AM   #8
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Original Poster
Rep: Reputation: 30
I installed fontconfig, and was able to run fc-cache. Fonts work great now, thanks for all your help guys.

Last edited by Locura; 05-15-2003 at 11:22 PM.
 
Old 05-14-2003, 11:07 PM   #9
tipaul
Member
 
Registered: Apr 2003
Location: Laval, Quebec, Canada
Distribution: Ubuntu
Posts: 121

Rep: Reputation: 15
Unhappy Adding Fonts in Slack 9 - GDM FAILED!?

I've used the 3 steps mentionned above... But I have a BIG problem:

When my Slack box is starting and come up to the start of GDM, it keeps restarting GDM (4-5 times) and after that, I got a message that "...Display 0:..." is deactivated...

I've started slack under runlevel 3, test it with startx under user and root and it works well...

So it seems that gdm is bugging with the newly installed fonts...

The steps I've done is:
(1) Create TTF2 dir under /usr/X11R6...FONTS dir...
(2) Copied all my fonts (.TTF files only) from my WindowsXP fonts directory to TTF2...
(3) executed fc-cache -f under the TTF2 dir...
(4) added TTF2 directory to /etc/X11/XF86Config

===================

Now, I've removed TTF2 dir, re-run fc-cache -f , deleted TTF2 entry in my XF86Config... And everything is back to normal!!!...

Is there something special about GDM involving fonts installation?
 
Old 05-15-2003, 04:14 AM   #10
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
I'm not a font expert!!!

Yr steps are correct and the problem really seems on gdm!!
Remember to check that all font files must have read permision (444)
In XF86Config file, the FontPath lines have a order priority!
Maybe gdm has a problem with this!Try to add yr font-line at the last of FontPath list....
And you should control which fonts gdm uses...
 
Old 05-15-2003, 11:09 PM   #11
tipaul
Member
 
Registered: Apr 2003
Location: Laval, Quebec, Canada
Distribution: Ubuntu
Posts: 121

Rep: Reputation: 15
Lightbulb And Finally...!

HEY! You've managed to cure my problem!!!

The 444 (root=read, users=read and others=read) wasn't set!
There was only read for root enabled!

Now everything is back on track PLUS Windows Fonts Installed!

Big Thanks!
 
Old 10-19-2003, 06:24 PM   #12
preswang
Member
 
Registered: Oct 2003
Location: UK/Chinese
Distribution: Slackware9.1
Posts: 55

Rep: Reputation: 15
Quote:
Originally posted by Obscure
So yr problem is normal!! On SLack 9.0 doesn't exists mkfontdir...
You must follow these steps:

1- Create yr directory and copy the fonts inside
2- Add yr directory path to the file /etc/X11/XF86Config (at the lines FontPath...)
3- Run INTO yr font directory: fc-cache -f

All should works!!!
Bye
Obscure
I have done the 3 steps, but I still can not see the ttf fonts. Should I need to use ttmkfdir?
Thanks!
 
Old 10-20-2003, 05:35 AM   #13
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
Probably yes!
Normaly the 3 steps works!!
ttmkfontdir crate a fonts.dir file for your true type fonts
Probably the previous users just add the new fonts at TTF dir just present and the fonts.dir was already present into!
Probably if you crate a new dir you need to create a new fonts.dir with ttmkfontdir
Probably....
 
Old 10-20-2003, 11:31 PM   #14
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 248

Rep: Reputation: 31
Take a look at this thread for more information:

http://www.linuxquestions.org/questi...threadid=77536
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Live CD - adding fonts satimis Linux From Scratch 3 08-11-2005 01:29 AM
Adding new fonts in Suse9.1 John_Emad SUSE / openSUSE 6 02-09-2005 05:40 PM
adding fonts marie-p Linux - Newbie 4 01-24-2005 11:34 AM
adding fonts to OOwriter jeanrev Linux - Software 2 09-02-2004 11:42 PM
Adding fonts to gimp jayakrishnan Linux - General 2 06-18-2003 06:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration