LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-01-2005, 05:58 AM   #1
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,194

Rep: Reputation: 47
actual uptime


I leave my Slack lappy on 24/7 and just unplug it during a thunderstorm. When idle, it shuts down to a powersaving suspend mode from the command line when a user types 'exit'.

'uptime' displays how long my user has been logged in (I think). My uptime now should be around a week. This is what I get:

bash-3.00$ uptime
05:47:52 up 5:16, 2 users, load average: 0.07, 0.37, 0.44

The current time is 5:47, so the uptime is 5 minutes and 16 secs-is that right? How can I see the pc uptime?

Last edited by linuxhippy; 08-01-2005 at 06:06 AM.
 
Old 08-01-2005, 06:30 AM   #2
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
Thats 5 hours and 16 minutes, I would think that that the uptime is the time since the laptop was last brought out of powersave mode.

On my desktop it is the, well, uptime - how long since it was booted
 
Old 08-01-2005, 08:56 AM   #3
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
how did you make your suspend work?
 
Old 08-01-2005, 09:23 AM   #4
glussier
Member
 
Registered: Jul 2005
Location: Montreal, Qc, Canada
Distribution: Fedora Core 5/6 Slackware 10.1/11
Posts: 120

Rep: Reputation: 15
Quote:
Originally posted by maginotjr
how did you make your suspend work?
You need to have enabled APM or ACPI support in your kernel and then read the following mini-HOWTO (easy to understand): http://www.ibiblio.org/pub/Linux/doc...y-Powered.html
 
Old 08-01-2005, 06:07 PM   #5
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,194

Original Poster
Rep: Reputation: 47
I have an old Compaq laptop that's pre-ACPI, so I enabled APM in the kernel when I re-built it from 2.4.29

I put 'sudo /usr/bin/apm -s' in my ~/.bash_logout file and in /etc/sudoers allowed user linuxhippy to use apm -s. Now when my user types exit from console, the pc goes into a suspend mode. Suspend is also enabled in my pc bios. My /etc/sudoers line is this on LinuxHippyII:

linuxhippy LinuxHippyII = NOPASSWD: /usr/bin/apm -s

Last edited by linuxhippy; 08-01-2005 at 06:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
actual source file? jsheffie Solaris / OpenSolaris 15 07-20-2005 08:53 AM
Getting actual directory name subu_s Programming 6 01-13-2005 08:59 AM
USB TV Tuner or Actual TV? dgeronimo General 4 12-28-2004 05:58 PM
Kernels actual config theonebeyond Linux - General 4 09-20-2004 07:49 AM
Actual Operating Systems martinpanda Linux - General 21 01-24-2002 08:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration