-   Slackware (
-   -   ACPI kills USB? (

rignes 05-16-2004 09:27 PM

ACPI kills USB?
The other day there was a thunderstorm in my area but I was away from my PC. However, I could ssh into it and shut it down that way. I realized as I was doing this that it would not turn of but just sit there telling me to "power down". This got me thinking of power management.

I'm running Slackware 9.1 upgraded to the 2.6.6 kernel. My motherboard only support ACPI so I compiled in the needed parts and installed acpid from the slack 9.1 CD. Powering off then worked perfectly fine. BUT all my USB devices stopped working. Additionally, there were errors about probing the gameport failing.

I know it sounds strange. I've even tried compiling the power management stuff as modules and directly into the kernel. I also tried turning on the main heading to powermanagemetn but then didn't make a choice between AMP or ACPI (I didn't bother with APM because my mobo doesn't support it).

Anyway, I need to gather some more info before I can post a well formed question, however, I was just wondering if anyone else out there has seen anything similar happen?



hoopyfrood 05-17-2004 01:28 AM

Hi Brian,

I had a similar problem with my PC. By default, my BIOS enabled ACPI, but doing so cause problems with USB assigning IRQs. As a result USB wouldn't work with Mandrake Linux. Obviously, this wasn't an issue as my desktop PC doesn't need ACPI -- so I switched this option off in my BIOS and regained control of my USB ports.

I'm now having the exact opposite problem with an old IBM Thinkpad laptop on which I'm trying to run a "mini" distro called Luit Linux. In this case, Luit Linux is compiled with APM but not ACPI support-- because of a problem with some Thinkpad hardware, Luit Linux crashes when trying to load USB support on bootup, as ACPI support is required. So I have to manually disable USB to have Luit Linux boot. Pretty useless, since my external floppy and flash card are unaccessible via Linux without USB support.

A bit of snooping on Google suggests that ACPI and USB are connected, as with/without it some systems set up conflicting IRQs which causes problems.


rignes 05-17-2004 04:33 PM

Well, I managed to get it to work, though I can't say I really fully understand just WHY it works. All I did was stop monitoring all IRQ's in the BIOS, then turn on ACPI in the kernel. I didn't compile any of the modules with it. Just the ACPI support part. (IE, no ac adapter, battery, fan, etc) and it seems to work. I have all USB devices working AND the system powers down when I halt it. Since it's a desktop that's all I really need.

I'd like to learn more about ACPI and how Linux interacts with it. It seem to be a kind of voodoo to me right now.

Time to head over to the tldp and read the ACPI howto. :D


All times are GMT -5. The time now is 12:03 PM.