-   Slackware (
-   -   Accessing windows drive from my "normal" user. (

At0mic_PC 07-31-2003 06:57 PM

Accessing windows drive from my "normal" user.
Ok as root I can access my windows drives. /dev/hda1 /dev/hdb3 I did what the slack install recommended and they are /fat-c and /fat-d. The problem is that I can't access them from my atomic account like I want to. I store my MP3's on /fat-d and would like to listen to them.

I have tried editing my /etc/fstab

/dev/hdb3 /fat-d vfat unmask=0000 0 0

Then I rebooted the system and used this at su -

chmod -f 777 atomic-atomic /fat-d

Still doesn't work right. Am I missing anything?

JayCnrs 07-31-2003 07:08 PM

In your fstab it should be umask=000, this should give you access.


At0mic_PC 07-31-2003 11:15 PM

Didn't work... I have got to be using something wrong or something... (Obviously :p)

Here is my /etc/fstab:

/dev/hdb1 swap swap defaults 0 0
/dev/hdb2 / reiserfs defaults 1 1
/dev/hda1 /fat-c vfat unmask-000, 0 0
/dev/hdb3 /fat-d vfat unmask=000, 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Cerbere 08-01-2003 06:42 AM

I think you should wear your glasses (they don't make you look *that* funny).

There is no 'n' in -->umask<--

Also for your fat-c entry, you have a '-' where you should have a '='

--- Cerbere

At0mic_PC 08-01-2003 07:34 AM

I don't know man... I think they make me look like a dork. I guess so does doing stuff like that hah. Besides I like the contacts better.

It works! Thanks for the help guys.

Cerbere 08-01-2003 11:12 PM


brice2nice 08-01-2003 11:33 PM

or use user instead of umask like :

/dev/hdb3 /fat-d vfat user,noauto 0 0

In this case the user wich mount /fat-d will be owner of file in this partoche.

All times are GMT -5. The time now is 12:52 AM.