LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-06-2011, 12:56 AM   #1
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
A solution for nouveau problems with fresh install of slackware64-current


After a fresh install of Slackware64-current could not get X to start correctly with the nouveau driver. When ever X started display was scrambled. Only kde would partially work with desktop effects enabled, but very slow. Without desktop effects enable kde was also scrambled. After trying several things and googling came up with the following.
To get X to work created a nouveau-kms.conf file in /etc/modprobe.d with the following text.
Code:
options nouveau noaccel=1
The one draw back to this solution is that Kde will not start with desktop effects enabled. Hopefully this will help someone else with similar problems. Maybe someone else has a better solution.


video card: Nvidia Geforce 6150se nForce430

Last edited by colorpurple21859; 02-06-2011 at 08:16 PM.
 
Old 02-06-2011, 06:29 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Are you against the nVidia driver on ideological grounds? If not, I would recommend using the closed-source nvidia driver; I use it and it works nicely
 
Old 02-06-2011, 07:05 AM   #3
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.15.3) UEFI enabled
Posts: 347

Rep: Reputation: 71
It's not all bad

With the Nvidia 6150LE on board chipset I am having no problems with current.
Don't know what the difference is but nouveau + 64 current works as advertised for me.
I don't play games just everyday surfing, email, and study

my 2 cents
john
 
Old 02-06-2011, 08:37 AM   #4
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Original Poster
Rep: Reputation: 184Reputation: 184
@Snark1994
I have nothing against the nvidia driver, I don't play games so I wanted to use the nouveau driver since it is now officially part of current.

@AllyTrotter
I tried nouveau driver when it was first introduced at Rworkmans website had to recompile kernel with the config-genereic config file, and use a xorg.conf file to get nouveau to work. Sometime between then and now I went back to using the nvidia driver, I think all I did was change the name of the driver in my xorg.conf file back to nvidia after reinstalling nvidia, but not sure. After nouveau became official tried to revert back to nouveau unsuccessfully so I did a fresh install to see if that will help. This solution is what I did to get nouveau to work.


@Rworkman if you happen to read this.
When I did a Xorg -configure this is the error that appeared
Quote:
(EE) LoadModule: Module xgi does not have a xgiModuleData data object.
(EE) Failed to load module "xgi" (invalid module, 0)
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
dlopen: /usr/lib64/xorg/modules/drivers/radeonhd_drv.so: undefined symbol: miEmptyData
(EE) Failed to load /usr/lib64/xorg/modules/drivers/radeonhd_drv.so
(EE) Failed to load module "radeonhd" (loader failed, 7)
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
Configuration failed.
The /root/xorg.conf.new that was created had the nouveau driver listed.

This is the errors that I got when the scrambled X would start.
Quote:
Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 5 11:56:25 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "fbdev" (module does not exist, 0)
resize called 1024 768
video card: Nvidia Geforce 6150se nForce430
Attached Files
File Type: log Xorg.0.log (33.7 KB, 2 views)

Last edited by colorpurple21859; 02-06-2011 at 09:06 AM.
 
Old 02-06-2011, 02:01 PM   #5
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.15.3) UEFI enabled
Posts: 347

Rep: Reputation: 71
colorpurple

try with your fresh install no xorg.conf and a normal user not root
let X pick the driver when starting up

john
 
Old 02-06-2011, 02:19 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Original Poster
Rep: Reputation: 184Reputation: 184
Quote:
try with your fresh install no xorg.conf and a normal user not root
let X pick the driver when starting up
Already tried that and with several different settings enabled or disabled in xorg.conf I get the best results by using the above solution without a xorg.conf file.
 
Old 02-06-2011, 07:30 PM   #7
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 212Reputation: 212Reputation: 212
colorpurple, Are you running with the huge kernel by any chance? If so, you should use the generic with an initrd.

There are a handful of chipsets that acceleration should be disabled for. IMO - nouveau noaccel=1 should be default for guaranteed stability, and allow the user to enable to test.
 
Old 02-06-2011, 08:13 PM   #8
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Original Poster
Rep: Reputation: 184Reputation: 184
Quote:
Are you running with the huge kernel by any chance
No, I'm using the generic kernel. Even tried recompiling the kernel to get rid of unneeded drivers to no avail.
 
Old 02-27-2011, 11:24 AM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Original Poster
Rep: Reputation: 184Reputation: 184
The kernel release 2.6.38-rc6 fixed all problems mentioned above, as far as I can tell, for those interested. Was able to disable the nouveau-kms.conf file in /etc/modprobe.d.

Last edited by colorpurple21859; 02-27-2011 at 02:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fresh Slackware64-current RAID-1 + LVM + LUKS: pvcreate not working gargamel Slackware 6 03-23-2010 02:24 PM
fresh install of slackware64 and having troubles with my LV for home agentc0re Slackware 1 12-05-2009 05:22 AM
[SOLVED] Video Problems in VirtualBox on Slackware64-current TSquaredF Slackware 8 10-20-2009 11:44 PM
asciidoc + docbook problems on slackware64-current Ron Parker Slackware 2 07-17-2009 01:29 PM
help install slackware64-current christyler2009 Slackware 2 06-26-2009 11:31 AM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration