-   Slackware (
-   -   A solution for nouveau problems with fresh install of slackware64-current (

colorpurple21859 02-06-2011 01:56 AM

A solution for nouveau problems with fresh install of slackware64-current
After a fresh install of Slackware64-current could not get X to start correctly with the nouveau driver. When ever X started display was scrambled. Only kde would partially work with desktop effects enabled, but very slow. Without desktop effects enable kde was also scrambled. After trying several things and googling came up with the following.
To get X to work created a nouveau-kms.conf file in /etc/modprobe.d with the following text.

options nouveau noaccel=1
The one draw back to this solution is that Kde will not start with desktop effects enabled. Hopefully this will help someone else with similar problems. Maybe someone else has a better solution.

video card: Nvidia Geforce 6150se nForce430

Snark1994 02-06-2011 07:29 AM

Are you against the nVidia driver on ideological grounds? If not, I would recommend using the closed-source nvidia driver; I use it and it works nicely :)

AlleyTrotter 02-06-2011 08:05 AM

It's not all bad
With the Nvidia 6150LE on board chipset I am having no problems with current.
Don't know what the difference is but nouveau + 64 current works as advertised for me.
I don't play games just everyday surfing, email, and study

my 2 cents

colorpurple21859 02-06-2011 09:37 AM

1 Attachment(s)
I have nothing against the nvidia driver, I don't play games so I wanted to use the nouveau driver since it is now officially part of current.

I tried nouveau driver when it was first introduced at Rworkmans website had to recompile kernel with the config-genereic config file, and use a xorg.conf file to get nouveau to work. Sometime between then and now I went back to using the nvidia driver, I think all I did was change the name of the driver in my xorg.conf file back to nvidia after reinstalling nvidia, but not sure. After nouveau became official tried to revert back to nouveau unsuccessfully so I did a fresh install to see if that will help. This solution is what I did to get nouveau to work.

@Rworkman if you happen to read this.
When I did a Xorg -configure this is the error that appeared

(EE) LoadModule: Module xgi does not have a xgiModuleData data object.
(EE) Failed to load module "xgi" (invalid module, 0)
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
dlopen: /usr/lib64/xorg/modules/drivers/ undefined symbol: miEmptyData
(EE) Failed to load /usr/lib64/xorg/modules/drivers/
(EE) Failed to load module "radeonhd" (loader failed, 7)
(++) Using config file: "/root/"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
Configuration failed.
The /root/ that was created had the nouveau driver listed.

This is the errors that I got when the scrambled X would start.

Current version of pixman: 0.20.2
Before reporting problems, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 5 11:56:25 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "fbdev" (module does not exist, 0)
resize called 1024 768
video card: Nvidia Geforce 6150se nForce430

AlleyTrotter 02-06-2011 03:01 PM


try with your fresh install no xorg.conf and a normal user not root
let X pick the driver when starting up


colorpurple21859 02-06-2011 03:19 PM


try with your fresh install no xorg.conf and a normal user not root
let X pick the driver when starting up
Already tried that and with several different settings enabled or disabled in xorg.conf I get the best results by using the above solution without a xorg.conf file.

disturbed1 02-06-2011 08:30 PM

colorpurple, Are you running with the huge kernel by any chance? If so, you should use the generic with an initrd.

There are a handful of chipsets that acceleration should be disabled for. IMO - nouveau noaccel=1 should be default for guaranteed stability, and allow the user to enable to test.

colorpurple21859 02-06-2011 09:13 PM


Are you running with the huge kernel by any chance
No, I'm using the generic kernel. Even tried recompiling the kernel to get rid of unneeded drivers to no avail.

colorpurple21859 02-27-2011 12:24 PM

The kernel release 2.6.38-rc6 fixed all problems mentioned above, as far as I can tell, for those interested. Was able to disable the nouveau-kms.conf file in /etc/modprobe.d.

All times are GMT -5. The time now is 02:33 PM.