-   Slackware (
-   -   A few minor problems in Slackware 11 (

Blitzkreig75 02-16-2007 06:45 PM

A few minor problems in Slackware 11

First, thanks to the help I've recived thus far. You all have been paitient with me and that is very appriciated.

Slackware 11, kernel
Seagate Cheetah 36.4Gb U320 SCSI hot swap
DFI Infinity DAGF
ATI x800XL
AMD X2 4400+
2x 512Mb Crucial Ballistix Tracers DDR500

Okay, I read the info about 'how to' get my ATI card working fully, I'll get working on that now.

*Note: All other minor issues have been fixed with that same info in the sticky. Thanks.

Thanks in advance.

Slack1_more 02-16-2007 10:57 PM

Well, you need to do some reading!
There is a sticky in this Forum about enabling graphics card acceleration, and it talks about installing the ATI driver for your graphics card, and then changing the appropriate configuration file that goes with that driver.
I can't help you directly as I have an NVidia card and driver, but for me the configuration file is :
/etc/X11/xorg.conf - and this contains lots of useful comments to carry out (1) and (4) immediately, as well as some hints about (5). This last will depend on what the manufacturer has enabled in your Linux driver.
As I said, all the information is on this site, you need to search for it. There is even a search engine!! Get busy!


jifengcao 02-17-2007 10:08 AM


mode "1280x800-60"
# D: 108.003 MHz, H: 63.983 kHz, V: 60.021 Hz
geometry 1280 800 1280 25728 8
timings 9259 248 48 131 131 112 4
hsync high
vsync high
accel true
rgba 6/0,6/0,6/0,0/0

try compile the framebuffer module in the kernel

Blitzkreig75 02-17-2007 11:20 AM

(disregaurd this post. I';m an idiot ><)

Blitzkreig75 02-17-2007 11:22 AM


Originally Posted by Slack1_more
..../etc/X11/xorg.conf - and this contains lots of useful comments to carry out....

When I try to run that exact command I get "Permission denied" even when running it before launching X for the first time upon boot. No matter if I'm user or root.

H_TeXMeX_H 02-17-2007 11:35 AM

What do you mean the ATI drivers don't work with kernel 2.6 ? I'm quite sure that they do.

Remember that you have to be root to edit /etc/X11/xorg.conf

you would need to edit it with something like 'vim'.


vim /etc/X11/xorg.conf

Blitzkreig75 02-17-2007 12:31 PM

Thanks, using the vim before got it to work. :D

Now, on to the ATI driver..... I've folowed the instructions to the letter but I'm stuck early on. I'm supposed to do this from the diractory that has the downloaded driver:

rpm2tgz (filename here).rpm
installpkg (filename here).tgz
cd /lib/modules/fglrx/build_mod --- This command returns 'no such file or directory.

Now I'm stuck once again ......

swampdog2002 02-17-2007 01:14 PM

Unless I am mistaken, but doesn't ATI offer a shell script in order to install their proprietary driver? It appears that whenever you are converting the rpm to a Slackware package that it is not building and installing the necessary modules for your ATI card, hence the error about a non-existent directory. I have not tried installing ATI's drivers for some time, but would imagine that this is in direct comparison to how the NVIDIA drivers are installed, where running the shell script builds and installs the NVIDIA modules for the current kernel.

Blitzkreig75 02-19-2007 10:36 PM

Yes, there's an instller package available from ATI, but I'm not certain what to do with it.

How would I run the installer for the ATI driver?

Forgive my ignorance, but I'm confused about 'shell scripts' and ATI's installer. I kinda need my hand held through the process.

H_TeXMeX_H 02-19-2007 10:39 PM

well, first make sure it's executable, then run it ... in a terminal it would be: (Note that it should probably be run as root)


chmod a+x

Blitzkreig75 02-19-2007 11:51 PM


I got the dual monitors to work!!!!

Thanks to everyone for their patience.

FWIW, I had to play with aticonfig several times before I got it figured out.

What I had to do was, Dual-head initialization, had to configure the resolutions, and do this all from the prompt outside of the desktop. I do not know why, but I couldn't get the aticonfig to work from the command prompt in the desktop.

I had some trouble getting the ati installer to work, I was not using "sh" before running it. ATI has an instructional thing that told me to do that. The installer ran fine after I was typing (without the quotes) "sh ./

Anyhow, I'm a little more Linux-smart now.

Again, thanks for all the patience and help!

All times are GMT -5. The time now is 09:13 PM.