LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-11-2009, 11:55 AM   #1
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Rep: Reputation: 16
A Akonadi question...


I mean, I know what it does, but I'm not to clear on its importance or if I really need it. I don't use Kontact.


I just installed 13.0 this morning (fresh install).
I keep getting a D-bus error when KDE loads. It doesn't even happen all the time.

I noticed it the one time I logged in as root to download/install the nvidia drivers. And then the first I'm a logged in as user.

I followed the instructions per this thread. It solved the problem for a while, but now it's back.

I'm trying really hard to like KDE 4. So basically, I'd like to know, since I don't use Kontact, if I just remove the thing all together will it be okay?
 
Old 09-11-2009, 12:03 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
On the one computer running KDE on this LAN with Slackware64 13.0,
I issued "removepkg /var/log/packages/akonadi-1.1.2-x86_64-1" and
no longer get those error messages, nor have any problems. If it
is just for a PIM, why is it installed to begin with?
 
Old 09-11-2009, 12:46 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
Quote:
I'm trying really hard to like KDE 4. So basically, I'd like to know, since I don't use Kontact, if I just remove the thing all together will it be okay?
Many of us are trying hard to like KDE 4. I'm using 13.0 32-bit and KDE 4 with my new HTPC. Very sharp and pleasing to my eyes. But bugs and unwanted options are just that.

As a test, last night I removed both the akonadi and strigi packages. I had already disabled those options in my user account system settings. Yet when I removed the packages KDE refused to start. Possibly some minor editing of the /usr/bin/startkde script might allow KDE to boot without those packages. Seems the KDE devs have pretty much made those packages required.

Based upon Bruce's post above, seems my startup problem might only be the missing strigi package and not the akonadi package. Someday when I migrate my office machine to KDE 4 I suspect both packages might prove useful. Right now I seen no value with either with an HTPC.
 
Old 09-11-2009, 01:03 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
I haven't investigated it well enough, but before I removed akondai,
I used the System Settings or whatever to basically disable strigi.
There is no reason for either of those on any system in my sight.
When Slackware ran without that, then I removed akondai. It boots
a wee bit faster now, and doesn't spam the screen with error msgs
like it did with those running.

This is on my wife's comp, but there is too much about KDE4 that is
not to our computing tastes anymore. Before KDE4 it was somewhat
tolerable, but not anymore. Her computer is an Athlon 64 3200+.
It's not even a dual core. She had Slackware 12.1 on it before I
upgraded to Slackware64 13.0.

We expected to get some performance boost with the x86_64 arch,
as the other 2 comps on this LAN running it. However, the opposite
has proven true. Soon I'm going to reinstall without some options,
most notably no Qt/KDE. On the other 2 64-bit boxen I'm running
Fluxbox and enjoying the performance expected from Slackware
and the new 64-bit port.

Granted, my wife only runs Thunderbird, Firefox, Open Office, and
some file and video utils. She doesn't need a DE. That's a total
waste of resources for her needs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Akonadi dbus error in Slackware kingbeowulf Slackware 7 03-26-2010 12:32 PM
akonadi won't start : libmysql.c error serafean Gentoo 2 07-18-2009 06:18 PM
Akonadi/QT QMySQL Help!! kapz Linux - Desktop 8 06-25-2009 04:04 PM
Akonadi not connecting to MySQL zuser Linux - Desktop 0 04-20-2009 05:05 PM
LXer: Akonadi Hacking Meeting LXer Syndicated Linux News 0 04-26-2007 06:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration