-   Slackware (
-   -   8.1b2 CD installs w/o a compiled 2.4.18 Kernel??? (

NightSky 05-21-2002 01:06 PM

8.1b2 CD installs w/o a compiled 2.4.18 Kernel???
What a senerio! Booted off CD. Installed twice and can boot up fd0 bootdisk made during installation. Once i am in things work but I have no kernel installed??? Unknown Version!! So setup is very selective! ;D Yowza! I have never compiled -fairly new to linux. What dir is the kernel supose to install in? Am I suposed to have vmlinuz, intrid, and Bzimage? I selected the 2.4.18bare.i kernel.
Was reading other thread and wondering if someone would be so kind as to enumerating the compile steps along with what dir and terminal to work out of. A little explaination of what files and dir hav to be accessed. Man i am going to lose my job!!! Can't let this go!! Using Loadlin for dualboot. Hellllp! What to do???
:study: E-mail me at b/c my slackware is slacking :rolleyes:

neo77777 05-21-2002 01:17 PM

did you install kernel source during OS install?
the kernel is under /usr/src/linux if the source is installed.

tifkat 05-22-2002 09:54 PM

Hey NightSky,

Are you installing over the top of your old system or are you doing a clean install? Also, do you object to letting LILO handle your dual boot? This is how I setup my dual boots and it's very robust and quicker to boot straight into linux as it boots directly.


NightSky 05-22-2002 10:30 PM

Clean install
Have installed about 5 times and ea time there seems to be an oddity? Maybe not. I really hate messing with mbr... bc if one system goes both go. Had that happened with this attempt to install 8.1 I think I wld trash this thing. When I attempt to boot into slack first it say the vmlinuz image can't be found. When I manage to get a boot initiated I get an error 1 message. Compressed image. System halted. Didn't have this trble before.
At one point I tried to reinstall my previous install but i used the damn installation disk to mk and extra boot disk. U cn't configue anything either till you cn boot in regular not with bootdisk. Crap i had chnged my email over to mozilla... think i was stupid to format my previous install. going to see if i can find some current iinfo on loadlin... thanks tifkat

tifkat 05-22-2002 11:21 PM

Nah, if you mess up your MBR, a quick boot into DOS and then run the command "fdisk /mbr" will make windows boot ok. This can also be done if you want to remove LILO and go back to booting just windows and return to running loadlin to run linux.

Or boot from a slackware install disk and at the lilo prompt type "linux root=/dev/hde2" or whatever your root partition for linux is, and when you login, then just run '/sbin/lilo' and it will create the lilo boot. Of course this assumes a running slack install.

LILO really is quite safe.


NightSky 05-28-2002 06:33 PM

Started over again. The install appears good but still no kernel.
I did install kernel source and choice the bare.i kernel... but a kernel needs to be compiled. Can I install tar drivers off of floppy to use during compile? Thanks

tifkat 05-28-2002 11:12 PM

This is _weird_! Not installing a kernel.. Does the system boot? It can't boot without a kernel.

I downloaded that Beta2 ISO I mentioned in the other thread. I've been meaning to install it and take a look at it, but I've been working 14 hour days.. add 3 hours of travel to that, and you get a very busy tiffers :)

NightSky 05-29-2002 08:25 PM

Long Hours!!!
Man are they trying to kill you with all those hours ;) I am booting with bootdisk...the install gave me the option to install kernel and I choice bare.i also choice the opt to install the kernel source. Why didn't you download the 8.1RC1 ver? You take care get some sleep there. I will continue playing around with the sys till its right. Reading docs and like that. I need to go ahead and compile the kernel anyway. Get my feet wet. Won't have much time either - have to work ;) too

jtshaw 05-29-2002 10:42 PM

Boot off the floppy, look to see if vmlinuz exsists in either / or /boot. If not go to /usr/src/linux. If you are booting off of 8.1b2 then /usr/src/linux should be a simulink to /usr/src/linux-2.4.18. Now you can compile your kernel... here are the basic commands, they should be run in this order (stuff in () are my notes on what the command does....

make menuconfig (allows you to configure your kernel, I believe the slackware source install includes the configuration they used for the kernel on the CD so you might be able to skip this step).

make dep (makes the dependancies)

make bzImage (makes a kernel image)

make modules (builds all the modules configure in make menuconfig)

make modules_install (installs the modules in /lib/modules/2.4.18)

You now have a kernel, now copy /usr/src/linux/arch/i386/bzImage to /boot/bzImage-2.4.18

Edit /etc/lilo.conf to boot that kernel (if you need help with this let us know).

Run lilo

Your should be good to go.

On a note about LILO and the MBR... it is best to put it on the MBR, as said before, DOS can redo the MBR if LILO won't boot.


NightSky 05-29-2002 11:23 PM

John, thanks. I don't have lilo installed am trying to use loadlin. But regarding the compile 1) how do I compile so that the configurations that work during boot are what i compile? 2) what if the modules I need are not in the lib? 3) how do I chk to see if my hdd is being supported - according to docs this is first thing i shld do but I don't know?

tifkat 05-31-2002 07:04 PM

A change from slack8.0 ?
Hey Nightsky,

I downloaded slackware current last night. This morning I'm browsing through the /kernels directory and find this:

For a Linux partition (ext2, minix, ...) to mount as root"

loadlin c:\vmlinuz root=/dev/hdb2 ro

in a file called loadlin16c.txt. By the looks of it, you have to copy whichever kernel you want to use to boot with, to somewhere on you windows partition/drive. Then boot with the above line.

Give this a try and let me know what happens. There are a bunch of kernels in the same directory as the readme file for loadlin :)

If it works, you'll have to copy any new kernels you compile to the windows partition/drive and boot from it the same way.


NightSky 05-31-2002 10:23 PM

tifkat, that is the setup i have been working with.
first I edit msdos.sys setting gui=0
edit config.sys create menu:
edit autoexec.bat to create linux prompt

From Linux
#mkdir /win
#mount -t vfat /dev/hde1 win
# cd /root
#cp loadlin* /win/linux
#cp /boot/vmlinuz /win/linux
#cd /win/linux
Reboot into windows, cp vmlinuz c:\
Reboot and choose Linux frm menu
loadlin c:\vmlinuz root=/dev/hdb2 ro

Process starts and I get the following display:

compressed image
halted! error 1

and the system freezes so I have to shut it off from the back power swithch.... Mind you this setup worked before... Never ran into this compressed image thing before? I have read throug docs looking for referrence to such an error. With this new install i have ext3

Other things that this EID-E drive will only work on ide1 with jumper set to slave although its the only drive on that channel... I can't get it to boot as secondary master and my asus 52x udma33 cdrom came in. I am disgusted with this whole setup crap! thanks for trying to help tifkat... but you need to get some rest kiddo ;) later

tifkat 05-31-2002 11:08 PM

Ok, so it's failing while decompressing the kernel (it's common to have a compressed kernel :) )

Sounds to me like you have a corrupt kernel image (vmlinuz)
Or you're overclocking your cpu. :D


NightSky 05-31-2002 11:57 PM

How about slackware8.1rc2 ;)
i don't over clock cpu's they are fast enough on there own :) tried the kernel off cdrom, tried kernel from boot disk, tried kernel image from /boot/vmlinuz... they all failed... sounds like a don't know what i am doing. And I don't - So I ordered a 10gb ata66 hdd that i will use for slackware. That will eliminate having to set 2nd hdd as slave... keeping a somewhat uniform platform.

NightSky 06-18-2002 09:24 PM

Hey tifkat, miss seeing you around. Hope your job cuts you some slack ;) I reinstalled slack8.0 on new 10gb ata66, 7200rpm
hdd by its lonesome. Think I will just upgrade packages as i get more proficient with operations. I don't think i will wipe my sys out again. Reinstalls with slack are not as easy as win98 reinstalls. lol later dude

All times are GMT -5. The time now is 07:27 PM.