-   Slackware (
-   -   64-current with KDE, desktop rotated and mirrored after update (

Noway2 05-06-2012 09:29 AM

64-current with KDE, desktop rotated and mirrored after update
This morning I performed an update of my Slackware64-current system. I booted to a console (X not running) and performed the following commands (a procedure I've used many times before):

slackpkg update
slackpkg install-new
slackpkg upgrade-all

It installed new packages, including Calligra, and then upgraded the older ones. When it was done, I logged in as a non privileged user and issued a startx command to launch KDE. KDE started, but the desktop is mirrored and rotated (upside down). The text is still English, but it is backwards. I don't see any changes to Xorg.conf, profile, or anything else that would explain it.

Edit: I saw these links, which seem to be the same or similar problem, but with the desktop in the state it is in, I can't even figure out how to bring up a configuration that I can use to try these.

Any suggestions on how to restore the desktop, save a re-install?

repo 05-06-2012 09:38 AM

If you use nvidia, reinstall the nvidia driver.

Kind regards

allend 05-06-2012 09:43 AM

Did you run 'slackpkg clean-system' to remove old packages? There were some package removals.
As this is an X upgrade, you also need to reinstall any proprietary video driver package you may have been using.
Personally, I have seen no problems since I performed the latest update to Slackware-current. Graphics and input devices are all just fine.

Noway2 05-06-2012 10:58 AM

A thank you to both of you! Running clean-system and rebuilding the driver did the trick. Running clean system, which I hadn't done before, removed a boat-load of packages including old KDE files. @allend, I am using the NVidia drivers, which seem to work better than the Nouveau on this particular machine. I had thought about rebuilding them briefly, but since this wasn't a kernel update had discounted the idea.

allend 05-06-2012 11:13 AM

Glad you got it working!
I also use the nVidia proprietary driver (currently 295.40). Just curious, are you also affected by this bug?

Noway2 05-06-2012 12:35 PM

No, I haven't see that one. I tried to duplicate the problem as you described, by logging out and then restarting the X session and all appears well. I did notice that the HDD ran a good bit and it was a little slow to initialize when I re-logged (I was starting to think something had locked up). However, I am running 295.20. My video card is: nVidia Corporation C67 [GeForce 7000M / nForce 610M] (rev a2).

allend 05-06-2012 11:49 PM

Thanks for the testing. I am starting to suspect the nVidia driver 295.40 is the problem.

Noway2 05-07-2012 03:56 AM

Based upon past experience, that would be a plausible theory. It used to me common to have to find the particular driver that would work with your system, which was more often than not a few revs back from the current. Here is a link to a thread that brings back memories:, especially the how to install nvidia guide after installing the Ath 5K (wireless) drivers.

WhiteWolf1776 05-07-2012 10:08 AM

I had the exact same issue... thought about getting a picture of it as it was looking like a cool russian fount... then I re-installed the Nvidia binaries and fixed it.

All times are GMT -5. The time now is 10:06 PM.