LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-25-2007, 11:09 AM   #1
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Rep: Reputation: 15
3D working but now it won't shutdown or log off


Hello.
I just got my 3D acceleration working. It wasn't as hard as I had thought. But I've had a weird aftereffect. Since then, whenever I shutdown or log off, my screen shuts down. Almost like I'm stopping using the ATI drivers. And I know thats what should happen when your computer shuts down, but the rest of my computer is staying on. Weird. The only change I made what to get my 3D working, which is working quite nicely I might add. But I would like to be able to shutdown my computer. Any Ideas? Thanks.
 
Old 09-25-2007, 02:44 PM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,194

Rep: Reputation: 50
What ATI card is it and which driver did you install? Are you using any other hardware and drivers that might cause a conflict (ndiswrapper, for example)? Which windows manager are you using? I recently had an experience after switching from KDE to Fluxbox and when using ndiswrapper I would have a similar problem on a laptop that uses xorg's ati driver. With KDE it never happened and upgrading ndiswrapper to 1.47 fixed it.
 
Old 09-25-2007, 03:03 PM   #3
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
I have an ATI X850XT. I was using the current ATI drivers from their website. I don't using ndiswrapper or anything like that as it on a desktop. And as a X manager I am using Fluxbox as well.
 
Old 09-25-2007, 06:57 PM   #4
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
I have uninstalled the ATI drivers and so I can now shutdown my PC, but if I could fix this it would be nice as I would like to have 3d acceleration. Any ideas?
 
Old 09-25-2007, 08:30 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,366

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Are you starting in runlevel 3 (ie you boot to a command prompt)? If so, when you exit X, it is possible that there is a problem with the framebuffer. Try changing /etc/lilo.conf to use the "vga = normal" video driver instead of a framebuffer (ie comment out whatever is currently being used [put a # before the only uncommented line vga=???] and uncomment "vga = normal" [by removing the # in front of it]). Then run lilo as root (and reboot).

Note that this is only one possibility -- I may be way off here. I'm just guessing that when X exits it doesn't restore the framebuffer properly. Using the standard (though ugly) console display may fix it.
 
Old 09-25-2007, 09:42 PM   #6
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
Here is /etc/lilo.conf. This is what it looked like. I haven't changed a thing...


# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset

# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda1
label = Linux
read-only
# Linux bootable partition config ends
 
Old 09-25-2007, 10:12 PM   #7
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
Another thing I just found out. When I do glxgears I get this:

theking@slackware:~$ glxgears
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
47691 frames in 5.0 seconds = 9538.166 FPS


It starts to give me FPS readings though, but not before I get all the permission denied's. That and when I run something such as bzflag I get some more permission denieds and it is almost like I do not have 3D rendering by the way the screen looks. And something I just now found out is when I went to KUser I got this error:

Error opening /etc/shadow for reading.


Any ideas. I would really like to continue to use Linux but this is beginning to be a huge pain and I have reinstalled about 3 times when running into graphic driver issues.
 
Old 09-26-2007, 01:17 PM   #8
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
I am already had those changes when I opened up that text file. So any ideas anyone? I feel like I'm slowly killing my PC every time I have to basically pull the plug.
 
Old 09-26-2007, 02:30 PM   #9
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,194

Rep: Reputation: 50
Have you tried the ati and/or radeon drivers provided with Xorg? I'm not familiar with your card model so I don't know if they'll work with it. Also, have you tried KDE instead of Fluxbox? Personally, I love Fluxbox but sometimes it helps to try a different window manager for troubleshooting.

The "permission denied" errors and your comment about bzflag sounds like your user is not a member of the video group. Make sure it is (and the audio group while you're at it). For KUser, did you have root permissions when trying to use it?
 
Old 09-26-2007, 06:22 PM   #10
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
I used the default radeon drivers (I think) when I first installed Slack, but I could not get 3D acceleration. So I had to use these.
 
Old 09-27-2007, 02:40 PM   #11
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
I really like Slackware, but I think I may try another distro. Not Ubuntu or anything but maybe something Slackware deprived. But then again, when it is setup it will be worth it.

Last edited by toasty_ghosty; 09-27-2007 at 08:35 PM. Reason: Was temp. Insane.
 
Old 09-28-2007, 09:40 PM   #12
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,366

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
ATI drivers have always spelled trouble. They are now open-sourcing their drivers, so hopefully they will improve in time, but they have some issues at the moment. You would have to do some searching around the forums for ATI drivers or something to solve your problem (I have an nVidia card and therefore am of little help to you). Of course, switching to another distro is always an option if you want, but don't make it specifically because of the video card issue which can be solved. (If you want to switch go for it, however)
 
Old 09-29-2007, 03:52 AM   #13
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,890

Rep: Reputation: 569Reputation: 569Reputation: 569Reputation: 569Reputation: 569Reputation: 569
"Slackware deprived" -that's really funny!
 
Old 09-29-2007, 04:57 PM   #14
toasty_ghosty
Member
 
Registered: Aug 2007
Posts: 69

Original Poster
Rep: Reputation: 15
To be honest, I really like Slackware and the ideas that it implies. Also, switching distros will be just a temporary solution as they will also have their issues. That and if anything is going to have issues it is going to be ATI drivers as we all know how good they currently are. So I think that I may just have to live without 3D acceleration as of now and wait for some new drivers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Log Rotation for snort log does not seem to be working CentOS4.5 JasonKretzer Linux - Security 3 06-25-2007 12:25 PM
shutdown log file ashley75 Linux - General 4 01-04-2007 01:12 PM
SElinux / shutdown log linmix Linux - Software 0 09-23-2005 05:01 PM
where is log for shutdown xkwauk Linux - Software 2 05-28-2004 07:18 PM
where is the shutdown log? hamish Red Hat 4 09-28-2003 05:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration