-   Slackware (
-   -   3D-Desktop with a low-end graphics (

Tux-Slack 09-23-2007 06:04 AM

3D-Desktop with a low-end graphics
I'm trying to get 3ddesk running on my slack 12 laptop with a SiS M760 graphics card. I did quite some searching about this and I came up that this should be possible as this card has some OpenGL support.

So I've got installed DRI, DRM, GLX, and glxgears are running good and show FPS around 400-500FPS. But runing glxinfo crashes my X.

But when I run 3ddeskd I get this:

fire@xendria:~$ 3ddeskd
3ddeskd: glXIsDirect failed, no Direct Rendering possible!
3ddeskd: Please configure hardware acceleration.  Exiting.
Daemon started.  Run 3ddesk to activate.

Linux kernel is, vanilla with bootsplash patch.

serafean 09-23-2007 06:36 AM


SIS760 you say... From experience, I can say its a plague for linux (luckily its not spreading); more here. To be more precise :

The 760 3D engine is called "Ultra256" or "Mirage 2". Hence, the driver supports these chipsets as regards all 2D and video features. As I stated a couple of times, there is no hardware accelerated 3D support for these chipsets.
(from the FAQ on the same site).


Tux-Slack 09-23-2007 07:05 AM

So in short I can forget about any 3D desktop?

serafean 09-23-2007 07:17 AM

I guess you may say that...


Tux-Slack 09-23-2007 07:37 AM

Great. I bought crap...

duryodhan 09-23-2007 08:23 AM

3d desktop .

don't believe all the hype about it. I found it to be a pain to use.

H_TeXMeX_H 09-23-2007 10:02 AM

Yeah, what can I say, sis doesn't make the best graphics cards ... nor does it make the best of anything that I know of. Just buy a cheap nvidia card, or maybe an Intel ?

Tux-Slack 09-23-2007 12:27 PM

Laptop with integrated graphics chip. Can't do.

Tux-Slack 09-23-2007 12:35 PM

Ok, update. I installed sis drivers older that I already had, and crahsed my X every time I started it up. So I did a reinstall of xf86-vide-sis package from slackware DVD directory x/.
Then installed sisctrl and added a few lines in X:

Section "Device"
        Identifier "VESA Framebuffer"

        # Now for the real thing:
        Driver "sis"

        # EnableSiSCtrl must be set to use SiSCtrl
        Option "EnableSiSCtrl" "yes"

        # [sisctrl] Set CRT1 device type (Note: overrides auto-detection)
        Option "ForceCRT1Type" "NONE"

        # [sisctrl] Set CRT2 device type (Note: overrides auto-detection)
        Option "ForceCRT2Type" "LCD"

        # [sisctrl] LCD related options
        # Currently all set to defaults

        # [sisctrl] Enable/disable Gamma correction for CRT1
        Option "CRT1Gamma" "on"

        # [sisctrl] Enable/disable gamma correction for CRT2
        Option "CRT2Gamma" "on"

        # [sisctrl] Brightness/contrast for CRT1 and CRT2
        Option "Brightness" "0.000 0.000 0.000"
        Option "Contrast" "0.000 0.000 0.000"

        # [sisctrl] Saturation for CRT1
        Option "CRT1Saturation" "0"

        # Xv (video overlay) head selection
        Option "XvOnCRT2" "yes"

        # [sisctrl] Xv (video overlay) related options
        Option "XvDefaultContrast" "2"
        Option "XvDefaultBrightness" "10"
        Option "XvDefaultHue" "0"
        Option "XvDefaultSaturation" "0"
        Option "XvDefaultDisableGfxLR" "no"
        Option "XvGamma" "off"

And now after runing glxinfo I get these errors:

fire@xendria:~/Mozilla/sisctrl-0.0.20051202$ glxinfo
name of display: :0.0
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  16
  Current serial number in output stream:  17

H_TeXMeX_H 09-23-2007 12:54 PM


Originally Posted by Tux-Slack (Post 2901169)
Laptop with integrated graphics chip. Can't do.

Well that really sucks :(

As you read about the card ... it is absolute crap no matter what you do on any OS. I say sell the laptop and get a new one ... that's the only solution in this case. Or, maybe you can find some hardware genius that can rip that chip outta there and solder in a new one, and he'd probably need to do other things with the buses and the ram and many things ... ok, well, that's highly unlikely. Sorry ...

dracolich 09-24-2007 09:28 AM

I would say forget about 3ddesktop on that laptop. Maybe you can search Google for a third party driver. That worked for me in the past when Slackware still used XFree instead of Xorg. My laptop has the ATI Mobility U1, using the Xorg radeon driver, set to 32MB in BIOS and 3ddesktop is not smooth, like on my 64MB nvidia card, but tolerable.

As for it being a pain to use, that's because you have to bind controls to keystrokes. For example: to shift right a common binding is to use 6 on the keypad. On a laptop it's even less convenient since most that I've seen use the Fn key to activate keypad controls.

For KDE there's a replacement for the pager called minipager3d (from designed to work with 3ddesktop so when you click on a page it uses 3ddesktop to switch. As far as I can tell it's independent from keybindings. I haven't read all the docs about it so I could be wrong.

All times are GMT -5. The time now is 12:33 AM.