LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-24-2005, 06:22 AM   #1
hansidm
LQ Newbie
 
Registered: Feb 2004
Location: Fortaleza, Brazil
Distribution: Slackware 10.1
Posts: 7

Rep: Reputation: 0
Unhappy 3D Acceleration ok, but OpenGL slow


Hello all,

I'm having some troubles with my ATI Radeon card.

I have installed the latest drivers from linuxpackages.net. glxinfo tells me that Direct Rendering is enabled. glxgears gives me 2000+fps, but the KDE OpenGL screensavers are really slow. 1fps or less.

Does someone have any clue?

Thanks.
 
Old 08-24-2005, 08:18 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.2
Posts: 1,491

Rep: Reputation: 50
what about a look at your xorg.conf file??
 
Old 08-24-2005, 08:27 AM   #3
Spectre630
LQ Newbie
 
Registered: Aug 2005
Location: Akron, OH
Distribution: Slackware 10.2
Posts: 12

Rep: Reputation: 0
I've just fixed a similar problem to this myself within the past 24 hours.

Here's what I did:

1) I installed this (Slackware repackaged) version of the drivers: http://www.linuxpackages.net/download.php?id=7254

2) and being sure to add the following line to fstab (which was never mentioned anywhere by ATI):
tmpfs /dev/shm tmpfs defaults 0 0

I got this info from the Slackware FAQ:
http://wiki.linuxquestions.org/wiki/...ary_drivers.3F

(For what it's worth, I don't know if the drivers or the fstab line really did the trick, but after doing those and rebooting, things finally worked).
 
Old 08-24-2005, 09:08 AM   #4
hansidm
LQ Newbie
 
Registered: Feb 2004
Location: Fortaleza, Brazil
Distribution: Slackware 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Spectre630
[B]
1) I installed this (Slackware repackaged) version of the drivers: http://www.linuxpackages.net/download.php?id=7254

2) and being sure to add the following line to fstab (which was never mentioned anywhere by ATI):
tmpfs /dev/shm tmpfs defaults 0 0
Thanks. Step number 1 I've already done. Step 2 I'm going to try it today.

I'll post here if it works.

I had a look in xorg.conf but it looks good to me. Loads dri and glx.
 
Old 08-24-2005, 12:16 PM   #5
fcaraballo
Member
 
Registered: Feb 2004
Location: WA
Distribution: Slackware
Posts: 230

Rep: Reputation: 31
Quote:
Originally posted by Spectre630
which was never mentioned anywhere by ATI
ATI Proprietary Linux Release Notes
Quote:
3D Applications Produce Open of Shared Memory Object Failed Error Message

This information applies to the following system configurations:

* ATI Proprietary Linux Driver version 3.14.6 and later

The following may occur when trying to run certain 3D applications:

* 3D image appears corrupt or blank
* Missing textures
* System performance drops sharply

The following error message may also appear numerous verdana:

FGLTexMgr: open of shared memory object failed (Function not implemented) __FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed! fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!

The display driver requires POSIX Shared Memory to be enabled on the system in order to run these applications correctly. This feature should be enabled by default on most current Linux distributions, but may be disabled intentionally by some system administrators or not included in older distributions.

To enable POSIX Shared Memory on your system, perform the following as root:

1. Add the following line to /etc/fstab (if it isn't there already): tmpfs /dev/shm tmpfs defaults 0 0
2. Mount shared memory as follows: mount /dev/shm
3. Issue the following command to check that it mounted properly: mount | grep "shm"

If the mount was successful, then the following output (or similar) should appear:
tmpfs on /dev/shm type tmpfs (rw)

At this point, POSIX Shared Memory is enabled. Your 3D applications should run properly and the error message above should no longer occur.

If the output from this command is blank, then the mount failed.

If /dev/shm fails to mount, then this feature may not be turned on in your Linux kernel. In this case we recommend upgrading to a more recent Linux kernel, or contacting your Linux Distribution vendor for more information on enabling POSIX Shared Memory.

For further information and general help on driver or software installation, game issues, and more, visit the ATI FAQ website.

Last edited by fcaraballo; 08-24-2005 at 12:21 PM.
 
Old 08-24-2005, 12:19 PM   #6
Spectre630
LQ Newbie
 
Registered: Aug 2005
Location: Akron, OH
Distribution: Slackware 10.2
Posts: 12

Rep: Reputation: 0
hehe, fiiiine. But their install information/quick guide doesn't say anything about it.
 
Old 08-24-2005, 04:53 PM   #7
hansidm
LQ Newbie
 
Registered: Feb 2004
Location: Fortaleza, Brazil
Distribution: Slackware 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
It worked perfectly adding these lines to fstab. Finally smoothy OpenGL

Thanks everybody.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3d Acceleration/OpenGL Problems in Suse 9.3 suse123456789 SUSE / openSUSE 6 07-16-2005 10:26 PM
OpenGL - 3D Acceleration Setup! perry Linux - Hardware 1 04-26-2004 02:00 PM
OpenGL acceleration in X StickyIcky Linux - Newbie 3 11-04-2003 04:03 PM
Compiling OpenGL apps with H/W acceleration L33t_H4x0R Linux - Software 0 02-03-2003 11:06 AM
3D Acceleration OpenGL sickels Linux - Software 2 07-09-2001 04:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration