-   Slackware (
-   -   32 bit google-chrome on multilib current SSL? (

damgar 04-10-2010 03:38 PM

32 bit google-chrome on multilib current SSL?
I just about have 32 bit google-chrome working on a current multilib system. I've managed to get the internal flash working, but I still can't access oddly enough. The page tells me SSL error and starting from the terminal gives the following error:

bash-4.1# google-chrome
/usr/bin/google-chrome: /usr/lib/ no version information available (required by /usr/bin/google-chrome)
/opt/google/chrome/chrome: /usr/lib/ no version information available (required by /opt/google/chrome/chrome)
[26290:26303:1355440866:ERROR:base/] Error initializing NSS with a persistent database (sql:/root/.pki/nssdb): NSS error code -5977
[26290:26303:1355440928:ERROR:base/] Error initializing NSS without a persistent database: NSS error code -5925
[26290:26303:1355441358:ERROR:net/socket/] handshake failed; NSS error code -12268, net_error -107

On pure 64 or 32 bit systems I've always modified the slackbuild to link to /usr/libARCH/firefox for the files since the missing seamonkey files a few months ago. Everything has always worked well that way. I am assuming that I am getting this error due to missing 32 bit libraries, but I don't know what they would be. I have a 32 bit firefox working just fine on this system. Any ideas about what I'm missing?

manu-tm 04-11-2010 02:33 AM

I recently had similar issues but no idea what was going on. So I could switch back soon to Firefox. Sorry for the helpless answer but don't forget google-chrome is still beta (after a ***really*** long time...)

willysr 04-11-2010 04:08 AM

try to link them to seamonkey packages.
I'm also using Google Chrome from SlackBuilds, and it worked.

damgar 04-11-2010 10:31 AM


Originally Posted by willysr (Post 3931526)
try to link them to seamonkey packages.
I'm also using Google Chrome from SlackBuilds, and it worked.

Are you using the i386 Slackbuild on a multilib system?

EDIT: SOLVED. It turns out those linked files can be to seamonkey or firefox, but simply having a 32 bit firefox apparently isn't enough. Installing the seamonkey package from slackware current (32 bits) on the multilib system now allows for SSL. I had also tried the mozill-nss package and that didn't do it either. Kind of a PITA but this is solved and I thank everyone for there input!

willysr 04-11-2010 12:20 PM

great to hear it's working
i'm using 32 bit SlackBuild :)

dugan 06-13-2010 09:44 PM

damgar, thank you very much for working this out. I just set up 32-bit Chrome on on my multilib system, had the exact same problem, and then solved it with your solution.

I had to actually install the full 32-bit Seamonkey package; a 32-bit compatibility version didn't do it.

Do you know if replacing Seamonkey with a 32-bit version is going to cause any problems?

damgar 06-13-2010 10:20 PM

It hasn't caused me any that I'm aware of. :)

Glad it helped.

All times are GMT -5. The time now is 07:05 AM.