-   Slackware (
-   -   3.6GB RAM instead of 4GB ??? (

masterross 05-19-2006 02:16 PM

3.6GB RAM instead of 4GB ???
hi there,

just setuped new server and i see that availeble RAM is only 3.6GB instead of 4GB??

any idea why?


Wells 05-19-2006 03:12 PM

Just as a guess, this is going to be an AMD64 system. Take a look in bios for something called "memory hole" and play with that setting. Typically, if you set that to use a hardware mapped memory hole the problem should go away.

Very often this setting will be found somewhere under the northbridge settings of the bios.

masterross 05-19-2006 03:28 PM

actually it's dual Xeon
i'll check in bios


Wells 05-19-2006 03:45 PM

So that you know, the reason that this is happening is that x86 architecture pushes the PCI Option ROMs into the space just below the 4gb point in memory. So, when you actually have enough memory to reach the 4gb point, you lose some of that memory because it is being taken up by ROMs instead. Some bios's have the capability to remap the RAM above this point so that you can actually use it.

Mircale 05-20-2006 04:11 PM


Originally Posted by masterross
hi there,

just setuped new server and i see that availeble RAM is only 3.6GB instead of 4GB??

any idea why?

I had just the same few days ago.
While BIOS POST reported 4 gigs available the kernel uses only 3,5 gigs (just like 4096 - 512 is 3584)
I even thought it's broken memory :).

The problem solved after I've enabled support for 64G of memory in the kernel. All 4G were there.


brooky9999 09-03-2008 02:39 PM


My Slack 12.1 box (running cannot see all 4Gb of RAM. I have enabled High Mem (64Gb) in the kernel and recompiled, but still when I run:


Free -m
It just says Mem: Total = 2915.

The BIOS sees 4096Mb.

Any thoughts?


keefaz 09-03-2008 02:50 PM

Are you sure you replaced the old kernel with your new one ?
A way to quick check:

zcat /proc/config.gz | grep HIGHMEM

brooky9999 09-03-2008 03:02 PM

Hi Keefaz,

I though I had... but when I grep config.gz, I get both options:

# CONFIG_HIGHMEM4G is not set

Is that correct?


keefaz 09-03-2008 03:07 PM

Yes, it is your new kernel (default has not CONFIG_HIGHMEM64G=y IIRC)

brooky9999 09-03-2008 03:10 PM

Hmmm... exactly. Now I'm stumped :-(

Thanks anyway,


keefaz 09-03-2008 03:44 PM

Maybe post infos about your motherboard and processor, by luck another one with the same config may have solved this issue

symatic 09-04-2008 08:07 AM

Look at this wonderful utilization of ram. Sorry continue on:

symatic@secular:~$ free -m
            total      used      free    shared    buffers    cached
Mem:          1010        982        27          0        141        498
-/+ buffers/cache:        342        667
Swap:          486          2        483

All times are GMT -5. The time now is 12:29 PM.