-   Slackware (
-   -   3.2.38 kernel freezes when using KDE on Asus K53SD (

natharran 02-07-2013 01:41 PM

3.2.38 kernel freezes when using KDE on Asus K53SD
Hello guys, please help.

I'm having this odd issue with the new 3.2.38 kernel. I'm using Slackware 14.0 (64 bit) on Asus K53SD. So far, I've been regularly upgrading 3.2.x kernel without any problems, but this time GUI doesn't work as it should and I don't have a clue why.

After KDE starts it works for only a couple of seconds (20-30), then entire system freezes and nothing can be done except for a hard reset. If I don't log into a KDE session and switch to tty1-6 instead, everything works just fine. What troubles me most is that I made no changes to a kernel config, I'm still using the original generic config shipped with Slacware 14.0.

Since it only happens with GUI I expect, of course, a bug in a graphics driver. My notebook has nVidia Optimus, I have nouveau blacklisted, latest original nVidia drivers installed (have been using them with 3.2.37, working fine), but I'm not using bumblebee. If I'm not mistaken, KDE should be using an Intel graphics driver (included in kernel source).

This is a lspci output, if it helps:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 1652
        Flags: bus master, fast devsel, latency 0, IRQ 53
        Memory at dc400000 (64-bit, non-prefetchable) [size=4M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at e000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915

Unless it's a bug, what else can be wrong? Does any one else have this issue?

Btw, I also have Slack14 on another notebook - Acer eMachines (HD Radeon) and everything works smoothly there with 3.2.38 so I guess it is related to the specific Intel chipset or the Optimus thing.

Thanks so much for any info.

tuxbg 02-07-2013 02:30 PM



  Regardless of your chipset (though it seems more common with intel), if KDE
  crashes on startup, try disabling the Composite extension (which will also
  disable all of the fancy desktop effects).  Place the following content in
  a file at /etc/X11/xorg.conf.d/disable-composite.conf:
    Section "Extensions"
      Option "Composite" "Disable"

natharran 02-07-2013 04:31 PM


Originally Posted by tuxbg (Post 4886468)
This is from CHANGES_AND_HINTS......

Thank you, tuxbg, for your reply. Yeah, I know of this, I believe it is often recommended if KDE crashes during startup on VMs. However, my KDE does start, it even works for a short time. Then the whole system freezes totally (so it's not just a KDE crash). Nothing can be done but turning the computer off via the power button. I tried it to be sure - to disable the Composite extension - but it doesn't help.

And there's another thing, after the system freezes, the CPU probably starts to overheat because it's fan runs like there's no tomorrow.

I guess there's one "solution" - simply to skip this kernel and hope that it'll be ok in a next one (I'm back on 3.2.37 now).

Any other ideas anyone?

cynwulf 02-08-2013 03:57 AM

There are quite a few fixes/changes relating to i915, I'd suggesting filing a bug report and just sticking with 3.2.37 for now.

natharran 02-08-2013 05:53 AM


Originally Posted by caravel (Post 4886860)
There are quite a few fixes/changes relating to i915, I'd suggesting filing a bug report and just sticking with 3.2.37 for now.

Thank you, caravel. I guess it's my only option right now. I'll fill a bug report and mark this thread solved.


natharran 02-09-2013 09:42 AM

Just FYI,

if anyone else has this problem, 3.4.29 kernel, which I believe also has a long time support, doesn't share this issue and runs just fine.


All times are GMT -5. The time now is 10:07 AM.