LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-15-2009, 12:49 AM   #1
amiga32
Member
 
Registered: Mar 2009
Location: Illinois
Distribution: slackware bro
Posts: 161

Rep: Reputation: 38
2 questions (modules and boot parameters)


Hi guys,

I just compiled latest stable kernel on 12.2 and have two questions:

!) When I modprobe acpi-cpufreq it only sticks to /proc/modules during that session. When I reboot it is longer there and I have to re-modprobe it for my cpu to scale down. Is there any way I can get this to stick so it is there next time I reboot?

2) During boot my hard drives get auto-checked for RAID options. I don't RAID my hard drives and my dmesg says to use raid=noautodetect to stop this from happening. Am I just supposed to add that option to lilo.conf somewhere or where do I add that option? It doesn't say.

I am new to Linux Questions and Slackware, sorry.

Thanks guys
 
Old 03-15-2009, 01:27 AM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546
The modprobe command is not permanent but session only. To load a module with each reboot requires loading the module every time. The acpi-cpufreq module can be loaded by editing the /etc/rc.d/rc.modules script. The acpi-cpufreq module is generic. If possible try one of the CPU specific modules, such as powernow-k7, powernow-k8, etc.

I don't know whether the raid=noautodetect boot parameter will provide the effect you seek, but to test, edit /etc/lilo.conf or /boot/grub/menu.lst to add the kernel boot option. If you use lilo, be sure to run lilo -v after editing lilo.conf.
 
Old 03-15-2009, 01:42 AM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
) When I modprobe acpi-cpufreq it only sticks to /proc/modules during that session. When I reboot it is longer there and I have to re-modprobe it for my cpu to scale down. Is there any way I can get this to stick so it is there next time I reboot?
one is to edit the /etc/rc.d/rc.local script add modprobe acpi-cpufreq or create a file in your /etc/modprobe.d/ so it does that.
Quote:
2) During boot my hard drives get auto-checked for RAID options. I don't RAID my hard drives and my dmesg says to use raid=noautodetect to stop this from happening. Am I just supposed to add that option to lilo.conf somewhere or where do I add that option? It doesn't say.
image=/mnt/hdc1/boot/vmlinuz-2.6.28.7
label="slk12.2kde4"
root=/dev/hdc1
append="raid=noautodetect"
read-only
the auto check does not slow anything down it is just reading bios.

Last edited by Drakeo; 03-15-2009 at 01:45 AM.
 
Old 03-15-2009, 01:43 AM   #4
amiga32
Member
 
Registered: Mar 2009
Location: Illinois
Distribution: slackware bro
Posts: 161

Original Poster
Rep: Reputation: 38
Hi Woodsman,

The powernow drivers are for AMD computers and the old Intel speedstep drivers appear to be deprecated. I am using acpi-cpufreq with ondemand governor for Enhanced Intel Speedstep throttling. I think it is working ok. It scales my 3.000 GHz E8400 down to 2.000 GHz, I am not sure how it scales up though.

I will try adding that other option to lilo.conf and see what happens.

Thank you for your help!

EDIT: Thank you to you too Drakeo

Last edited by amiga32; 03-15-2009 at 01:44 AM.
 
Old 03-15-2009, 02:24 AM   #5
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,559

Rep: Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348
To load a module on every boot, rc.modules* is the place for it.
/etc/modprobe.d/* files are for module options, blacklisting (never load), and other special considerations -- adding a module to one of those files will never cause it to be loaded when it otherwise wouldn't, except for one of the "special considerations" using an "install" directive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to load modules (with parameters) at boot time? Akhran Debian 5 10-25-2006 01:20 PM
Inserting modules with extra parameters petersum Linux - Hardware 2 10-16-2006 07:02 PM
How to call the modules and pass parameters to it? shendeswanand Linux - Software 1 12-31-2005 10:18 PM
passing parameters to network modules muru Linux - Networking 4 10-21-2005 11:44 AM
howto pass parameters to modules Sammy2ooo Linux - Software 5 07-01-2003 09:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration