LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   2.6.24.2 kernel - framebuffer problem? (https://www.linuxquestions.org/questions/slackware-14/2-6-24-2-kernel-framebuffer-problem-622200/)

ak-87 02-19-2008 06:44 AM

2.6.24.2 kernel - framebuffer problem?
 
I've compiled 2.6.24.2 kernel using old config file. I have set vga=773 option in my grub conf. file and I had 1024x768 resolution during boot up on older kernel versions, but after upgrade to 2.6.24* kernel version I only get black screen during boot (if I remove vga=773 option there are boot messages, of course). Also, on my Arch installation on same machine, after upgrade to 2.6.24 kernel there is same problem.

It is obvious that the problem is with kernel/framebuffer module. Machine is Sony Vaio FE41S notebook with nVidia graphics.

Any ideas?

Thank You in advance!

dracolich 02-19-2008 09:46 AM

What version was your previous kernel? It sounds like you're just missing something. I'm using 2.6.24 but not 2.6.24.2 and I have no problem with the framebuffer console with an nvidia card (GeForce2 MX400 64MB). I always quickly browse the menu after importing my previous kernel's config to make sure everything is still checked properly. In my kernel config these are the relevant settings I have been using since approx. 2.6.21:

Device Drivers ->
Graphics support ->
<M> /dev/agpgart
<M> DRM
<Y> Support for fb ->
<Y> Firmware EDID
<Y> Video mode handling
<Y> Tile blitting
<Y> VESA VGA
NOTE: despite having an nvidia card the nvidia settings remain <N>
<Y> Console display drivers ->
<Y> Video mode selection
<Y> Framebuffer console
<Y> Compiled-in fonts
<Y> 8X8
<Y>8X16

rkrishna 02-19-2008 09:50 AM

i have never tried the new kernel,
teh various possibilities are
1.try vesafb instead of nvidiafb, and try, or
2.compile it as built-in or try make it as module

why dont you patch it with vesafb-tng so that we can specify the fb resolution as we want, like video=vesafb:1024x768-32@86

make sure ur grub entry look like this
Code:

kernel          /boot/vmlinuz-2.6.24xx root=/dev/hdax ro vga=791
790,791,792 gives various color depths

best of luck
rkrishna

T3slider 02-19-2008 03:54 PM

I don't think you CAN use nvidiafb if you use the proprietary drivers. I may be completely wrong (haven't had time to compile a kernel for a while -- still on 2.6.22.9), so take this advice with a grain of salt, but you should make sure NOT to enable nvidiafb. For whatever reason, looking through my .config file I compiled nvidiafb as a module, which isn't being used (since I'm using the proprietary drivers). So if you have trouble excluding the nvidiafb driver, compile it as a module. Note that this may not even apply to you if you didn't enable nvidiafb in the first place, in which case you can disregard this message.

dracolich 02-19-2008 05:15 PM

Quote:

Originally Posted by T3slider (Post 3062914)
I don't think you CAN use nvidiafb if you use the proprietary drivers. I may be completely wrong (haven't had time to compile a kernel for a while -- still on 2.6.22.9), so take this advice with a grain of salt, but you should make sure NOT to enable nvidiafb. For whatever reason, looking through my .config file I compiled nvidiafb as a module, which isn't being used (since I'm using the proprietary drivers). So if you have trouble excluding the nvidiafb driver, compile it as a module. Note that this may not even apply to you if you didn't enable nvidiafb in the first place, in which case you can disregard this message.

That sounds kinda' familiar. I read something like that back when I was learning how to activate my fb console. It has something to do with the drivers accessing the device. Both nvidiafb and nvidia can't use the same device at the same time.

ak-87 02-20-2008 04:12 AM

Previous kernel version was 2.6.23.12 and everything was working just fine. As I mentioned, the problem is not just with Slackware but with Arch's stock kernel also (after upgrade to 2.6.24x kernel version).

I've checked selected config options and they are absolutely same as those I used from 2.6.21.5-smp stock kernel (2.6.22.9, 2.6.23.4, 2.6.23.12).

Also, although it is Nvidia graphic card framebuffer uses vesafb module, not nvidiafb (it is blacklisted). I tried with vga=791 option and the thing is - sometimes it boots properly (proper resolution, shows all messages), but most of the time I get black screen.

Thank You for your replies.

rkrishna 02-20-2008 04:52 AM

Quote:

Originally Posted by ak-87 (Post 3063445)
I tried with vga=791 option and the thing is - sometimes it boots properly (proper resolution, shows all messages), but most of the time I get black screen.

Thank You for your replies.

vesafb : compile in, i mean not as module(y not m)


All times are GMT -5. The time now is 07:02 PM.