-   Slackware (
-   -   19th april -current update vs AMD's APU... (

FeyFre 04-24-2013 11:08 AM

19th april -current update vs AMD's APU...
So I have tried -current update of 19th April update on my PC based on AMD's APU A4-3400(Radeon HD 6410D video core) on mine Asrock A75M-HVS motherboard(as you can see CPU model is pretty old).
Two main reasons of upgrade:
1. Kernel upgrade. I hoped for radeon driver related fixes.
2. xorg downgared back. I hoped for decreasing chances to get video-driver related issues.

So, unfortunately none of list happened.
Issue details:
1. Boot into console(runlevel=3 ).
2. Login
3. Run startx(xfce4 configured to run).
All works as expected.
4. Switch back to terminal using Alt+Ctrl+F1 Alt+Ctrl+F6(or Zap it).
Here I expected to see my cli interface or login prompt. But I see only black screen with green rectangular zones spread randomly over the screen instead. However, it does not frozen. It reacts changes on terminal. I.e. while I typing command I can see zones are changing. I can run commands successfully, and they will be execute. Neither reset nor clear command helps. Switching back to X terminal(C+A+F7) however restores X graphics successfully.

Consider this as test report.
I know radeon support not so good as we want, but I wonder, could it be my fault? Does somebody else have such behaviour? Could kernel parameter "nomodeset" influence this? Or CPU overclocking capabilities?

zakame 04-26-2013 02:50 AM

I generally set "nomodeset" (lol) when using the fglrx driver for less headache (this leaves me with no text mode terminal once X11 loads, though.) As of late though, I get the same output you're seeing, when switching from X11 to text virtual console.

FeyFre 04-29-2013 06:21 AM

So I tried recently released driver AMD Catalyst 3.4. tried in both w/ & w/o nomodeset.
Good news are:
Now it supports 3.7 and 3.8 kernels out of box, and one not need to sniff over internet for weird fglrx-3.8.patch in order to build it.
No X crashes so far(but I spent no so much time testing to be sure).
Bad news:
Despite of bugfixes, it still cannot return back to framebuffer console after starting X. Now, when switch to console it partially correctly guesses videomode. If I saw green rectangles before, now I partially can see and recognize text: it looks like it switched to wrong X resolution, multiplied by 2 of that it thinks. Now I see 2 column screen, columns show equal picture. But even those picture is not correct. They looks like stripes, i.e. every even row is black(clear). And last glitch, probably caused by two first is columns are to high. I see only first 1/3 of picture on my monitor. To read result of my recent command I forced to insert a whole bunch of empty line to cause terminal to scroll.

All times are GMT -5. The time now is 02:03 PM.