-   Slackware (
-   -   1680 Kb floppy fails for GRUB bootloader (

aus9 08-29-2004 01:05 PM

1680 Kb floppy fails for GRUB bootloader

I have successfully tested 1440 Kb msdos and (since the linked post) 1440 Kb ext2 floppies for booting the 2.6 kernel using 3 floppies as per link

Below is my vain attempt to get 1680 Kb floppies to work. Note that while my normal system is live I seem to have no trouble creating the floppies but on full reboot GRUB has some trouble.

It may be a dead end as it may be my BIOS, it has 2 main options 1.44 and 2.88 for floppy and yep they seem to make no difference.

HERE are my thoughts so far.

Notes on creating ext2 formatted floppies size 1680 Kb For the Grub floppy system for kernel 2.6 series

1) All commands are in su mode
2) Create size on an UN mounted floppy using command
fdformat /dev/fd0u1680
3) Put on fs using command
mke2fs /dev/fd0u1680
4) Mount floppy for copying files with command
mount -t ext2 /dev/fd0u1680 /mnt/floppy
5) I made 3 floppies -floppy 2 has vmlinuz and floppy 3 has initrd.gz on each. Due to my success with the 1440 Kb way, I don't think its necessary to do anything to these 2 mbr's.
6) Floppy 1 needs the following files and structure
/boot/grub/stage 1
/boot/grub/stage 2
/boot/grub/menu.lst (see instruction 7)

7) Open a text editor and create a file to be saved as /mnt/floppy/boot/grub/menu.lst
(contents are:)
device (fd0) /dev/fd0u1680
title floppy
root (fd0)
pause "insert floppy 2 then press enter"
kernel /vmlinuz root=/dev/hda1 ro
pause "insert floppy 3 then press enter"
initrd /initrd.gz

Note that you may need to change the hda1 to whatever your /etc/fstab says it should be.

8) For floppy 1 that is mounted all commands are in su mode assume press enter at end of each line
1) type grub
2) type device (fd0) /dev/fd0u1680
3) type root (fd0)
4) type setup (fd0)
The output is a success but when floppy is unmounted and rebooted grub hangs. I suspect either my BIOS or my device map is wrong.
Notice that the "1680" works on a booted linux system. Its the unbooted one that I am having trouble with.

9) Another attempt was to use a successful ext2 1440 Kb floppy 1 with an amended menu.lst
Floppy 1 menu.lst became
title floppy
root (fd0)

device (fd0) /dev/fd0u1680

pause "insert floppy 2 then press enter"
kernel /vmlinuz root=/dev/hda1 ro
pause "insert floppy 3 then press enter"
initrd /initrd.gz

NOTES Now I know that is wrong as it fails. It may work if I knew the absolute Grub speak for the device 1680 floppy hardware. What I am trying to do is, allow the 1440 Kb floppy load as in the past and then try to tell grub that the next floppy is 1680 Kb. (And same size for floppy 3)

PS I also tried a file on the floppy but as you can suspect I have not got the syntax right on the floppy. The syntax for the DEVICE command has been tested and is good when my curent system is booted from the hd.

aus9 09-11-2004 11:37 PM

Altho this is not solved, some discussion as started on offtopic thread.

ideas include....

toms rescue floppy uses a ram drive and the size is 1722Kb so there must be a solution around any bios restrictions.

Trying different syntax and commands on the (fd) /dev/fd0u1680 with or without a file on the floppy

so far no success but if this helps anyone see an error in my attempt or know how it should be done let me know.

In the unlikely event that lilo users peruse this post and know lilo can use non-single floppies to boot large kernels feel free to mention it and the source of your success.

Ignore this of course if you have a cd burner, boo hoo

aus9 09-12-2004 12:12 AM

First looks at Toms replace kernel onto a single 1722 Kb

faq for toms

A the kick in the navel suggests large kernel on single floppy not going to be solved by Toms

Cedrik 09-12-2004 01:23 PM

I tried with a fd0u1722, then fd0u1680 all attempt fail.

As in each try, I formated the 3 floppy with the same size, the failure come at first, grub does not load, I just see 4 char on screen : GRUB, that's all.

I ended to make a kernel that fit on a 1440k floppy and all went fine.

All times are GMT -5. The time now is 04:07 PM.