LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-16-2018, 09:53 AM   #1
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu
Posts: 273

Rep: Reputation: 39
14.2 stable 32-bit alien's libreoffice-dict-XX-6.0.4 installs in /usr/lib and /usr/lib64


14.2 stable 32-bit alien's libreoffice-dict-nl-6.0.4-i586-1alien.txz installs its libreoffice/share/extensions/dict-nl/ in /usr/lib and /usr/lib64, the contents of which directories seem to be identical.
Is this on purpose or an oversight?
 
Old 05-17-2018, 12:50 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,184

Rep: Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166
It has been like that with all the Libre Office 6.x releases. I noticed a while ago but forgot (dit not care enough I guess) to do something about it.
It's not a fault in the SlackBuild. Nowhere in there is "/usr/lib64" a location that is used for 32bit. Seems to originate from the LO sources. Patch welcome, or else I'll let the SlackBuild script handle it.
 
Old 05-17-2018, 02:56 AM   #3
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu
Posts: 273

Original Poster
Rep: Reputation: 39
Thank you for responding.
I personally would go for handling things in the SlackBuild script.
 
Old 05-18-2018, 07:57 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,184

Rep: Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166Reputation: 5166
I found out that the error was actually in the libreoffice.SlackBuild - the script does not remove 100% of old package contents.
I fixed it locally and the next libreoffice packages should be OK.
 
3 members found this post helpful.
Old 05-19-2018, 03:33 AM   #5
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu
Posts: 273

Original Poster
Rep: Reputation: 39
Thank you. Your work is really appreciated.
Kind regards, Dick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] /usr/lib and /usr/lib64 - glibc locale bartgymnast Slackware 12 11-19-2013 03:07 PM
slackware64 /usr/lib /usr/lib64 question disturbed1 Slackware 29 02-14-2010 08:05 AM
/usr/lib vs /usr/lib64 Johncc330 Slackware 2 07-01-2009 01:04 AM
Location of libraries in /usr/lib/ or /usr/lib64/ in Slackware64 niels.horn Slackware 2 06-24-2009 04:25 AM
Relocat /usr/lib and /usr/lib64 to a different path schokshi Fedora 3 08-30-2005 09:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration