LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-09-2018, 05:20 PM   #1
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,407

Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
14.2 - Sound problems yet again


Once again I am tearing my hair out trying to get sound working in Firefox. I have YouTube playing with no sound. I go to Kmix | Audio Setup | Audio Hardware Setup and select my Terratec USB sound card as the default, and every single time I do this it changes back to the HDA Nvidia sound card - presumably some audio output on my video card which I don't need or want.

This is not the first time I've had a problem with audio since LP's work of genius made its way into Slackware. I used to have a problem with KDE thinking my USB microphone was my audio output. Genius. Sheer genius.
 
Old 06-09-2018, 06:34 PM   #2
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 518

Rep: Reputation: 275Reputation: 275Reputation: 275
You can set the default audio output in pulseaudio from the file /etc/pulse/default.pa by following this guide (section):
https://wiki.archlinux.org/index.php..._output_source
edit- after changing the pulseaudio config you need to stop all pulseaudio sessions and you might also need to clean the pulseaudio config folder from the user's home directory:
/home/user_name/.config/pulse/
- start pulseaudio (pulseaudio -D) as the user and check first if the file xxxxxxxxxxxxxxxxxx-default-sink reflects the changes in /etc/pulse/default.pa, that's the default sound card you chose. If positive, you don't need to clean up the folder.
edit - end

You could also blacklist the nvidia audio driver in case you see it loaded (lsmod) by creating /etc/modprobe.d/hdmi-audio.conf with the following content:
Code:
blacklist snd-hda-codec-nvhdmi
#or
#blacklist snd_hda_codec_nvhdmi
P.S.
And, you could also tell the snd driver the order you'd like to have your sound cards (drivers) loaded from /etc/modprobe.d/sound-order.conf, with the following content - substitute the driver name and respect the syntax, leave the fist comma where it is:
Code:
options snd slots=,your_first_card_sound_driver,snd_hda_codec_nvhdmi
Restart and check the audio cards order with:
Code:
cat /proc/asound/cards

Last edited by abga; 06-10-2018 at 06:23 PM. Reason: P.S. + addendum - pulseaudio conf folder clean-up + form=from
 
2 members found this post helpful.
Old 06-10-2018, 09:18 AM   #3
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,407

Original Poster
Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
Thank you abga. I should have done my research before blowing steam.
 
Old 06-10-2018, 06:21 PM   #4
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 518

Rep: Reputation: 275Reputation: 275Reputation: 275
Happy to help! Don't worry about "blowing steam", I share your "appreciation" towards the design & quality of pulseaudio. At times I also feel the need to show my "physical attraction" towards it, if you know what I mean...
Besides, I learned myself something new while trying to help you, I didn't know about the possibility to tell the snd driver the order in which you like to have the audio cards drivers loaded, thus affecting the final order in which alsa+pulseaudio enumerates them (the last - P.S. point). Found it on the Internet while looking for the correct syntax for snd_hda_codec_nvhdmi (dash or underscore), which I believe now it is with underscore, although both should work.
There was another very interesting doc page from Nvidia I stumbled upon, related to the HDMI audio output under Linux, good read even if you personally don't need it, some other Slackers might find it useful:
https://download.nvidia.com/XFree86/...udio-document/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems (alsaconf cannot find sound modules.) vmlinuz.gz Linux - Newbie 8 11-12-2008 03:36 AM
Sound problems in Slackware 11 with Sweex sound card RicardoB Linux - Hardware 0 04-30-2007 01:34 PM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-18-2006 11:44 PM
Sound Problems: CD works, no system/mp3/video sound tabnaka SUSE / openSUSE 5 01-13-2006 12:33 PM
Problems getting sound to play under Mandrake w/2 sound cards HGeneAnthony Linux - Hardware 1 07-02-2004 02:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration