LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 10-28-2013, 05:11 AM   #1
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
14.1RC3 Konqueror http://inode/directory?


Clean install of 14.1RC3, brand new user, logged into kde.

When I click on the default Konqueror launcher on the taskbar, it tries to open http://inode/directory, which annoyingly gets intercepted by my idiotic ISP's failed resolution catcher which redirects to http://advancedsearch2.virginmedia.com/main?InterceptSource=0&ClientLocation=uk&ParticipantID=jqlc435patgs4w79dx7g33u8otdryt35&FailureMode= 1&SearchQuery=&FailedURI=http%3A%2F%2Ftext%2Fhtml&AddInType=4&Version=2.1.8-1.90base&Referer=&Implementation=0

If I remove /etc/resolv.conf so that the lookup fails, Konqueror opens a blank page (no error messages).

Now, I know the ISP shouldn't be doing this as it's not compliant to the RFCs, but many of them are doing it these days.

It's only the icon on the taskbar launcher, the one in the K menu for Konqueror "Web browser" works just fine.

So, what's this http://inode/directory all about then?

Last edited by GazL; 10-28-2013 at 06:21 AM. Reason: thanks Ruari. :)
 
Old 10-28-2013, 06:04 AM   #2
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,016

Rep: Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033
Quote:
Originally Posted by GazL View Post
P.S. How do I stop the forum from turning those into URLs other than wrapping them in code blocks?
So that you can write URLs like http://inode/directory without breaking the flow of the sentence and/or making a link? Just use a pair of [noparse][/noparse] tags around the URL, e.g. [noparse]http://inode/directory[/noparse]

P.S. And yes I did have to put [noparse][/noparse] tags around my [noparse][/noparse] tags to explain this!

P.P.S. If you are ever using another forum that supports BBCode but does not support [noparse][/noparse] tags, you can sometimes achieve the following (at least for URLs) by wrapping other tag types around the URL, e.g. [b]http://inode/directory[/b]. If you don't want formatting try using [size][/size] or [color][/color] tags and intentionally setting the formatting to be the same as the surrounding text (e.g. set [size=2]http://inode/directory[/size] or [color=black]http://inode/directory[/color]). If you want to be really clever [size][/size] or [color][/color] tags around the some of the square brackets or other tags to achieve a [noparse][/noparse] workalike, e.g. write [size=2][[/size]b]bold text[/b[size=2]][/size] to display [b]bold text[/b]

Last edited by ruario; 10-28-2013 at 06:48 AM. Reason: Updated example to use [noparse][/noparse], used shorter example URL, added another post script
 
1 members found this post helpful.
Old 10-28-2013, 06:18 AM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Original Poster
Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Thanks Ruari. That's exactly what I meant. I tried [pre][/pre] but that didn't work.
 
Old 10-28-2013, 07:33 AM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Original Poster
Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
update: I think the blank page I was referring to, is the empty folder view from konq's filemanager mode. Interestingly, if I remove the two default konqueror icons (bottom left of the panel, next to the K menu) and add an individual launcher icon for Konq and edit it's settings to use the filemangement profile, I don't get the attempted http://inode/directory page fetch, it goes straight to the empty directory view.

I'm not that familiar with kde, and haven't yet been able to find where the tasbar saves its config to investigate further.
 
Old 10-28-2013, 08:17 AM   #5
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 922

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Quote:
Originally Posted by GazL View Post
When I click on the default Konqueror launcher on the taskbar, it tries to open http://inode/directory, which annoyingly gets intercepted by my idiotic ISP's failed resolution catcher
Name lookups for Hostnames without any FQDN should never be forwarded to your ISP anyway. There are multiple solutions for this:

1. You can add 8.8.8.8 as your nameserver to /etc/resolv.conf to get rid of your forging ISP resolver.
-or-
2. You can enable dnsmasq (included with Slackware) as a cache for 8.8.8.8 and configure it to never forward plain names. Then remove the nameserver entries from resolv.conf
-or-
3. You can get a proper DNS setup with BIND (included with Slackware) using a zone file for your local domain and acting as a full-recursive resolver. Then remove the nameserver entries from resolv.conf
 
Old 10-28-2013, 08:37 AM   #6
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Original Poster
Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Yep, I was aware of those options with regard to dns, I was more interested in why konq was attempting a http request on inode/directory in the first place, and why it only does it when started from the default icon on the panel.
 
Old 10-28-2013, 09:33 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Original Poster
Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Ok, getting somewhere. It's the quicklaunch widget which appears to be configured to run a "kfmclient openURL %u text/html" and "kfmclient openURL %u inode/directory"

Not sure what %u is supposed to represent but I'm guessing it contains nothing and so the inode/directory and text/html are being treated as URLs. So what is %u meant to contain? Is fixing it simply a case of wrapping it in "" quotes?


Another interesting thing was that the default instance of this didn't show the "Edit launcher" or "quicklaunch settings" right click menu items which was why I was having difficulty tracking down what this launcher was, but by removing it from the panel and re-adding quick-launch I recognised it.

Last edited by GazL; 10-28-2013 at 09:35 AM.
 
Old 04-01-2014, 10:18 AM   #8
jimmydean886
LQ Newbie
 
Registered: Apr 2014
Posts: 1

Rep: Reputation: Disabled
Ok, hi all. Sorry it took so long for someone to get back to you.

I too have been having trouble with this same problem, only on all sorts of systems for as long as I have used KDE. Ubuntu, Fedora, Arch Linux, and even OpenSUSE have this problem.

The %u argument is there to represent a single URL. Therefore, the program is parsing inode/directory as the URL you wish to go to. This allows something like a file manager to be able to send Konqueror a local HTML file, but it really shouldn't show up in the taskbar. If you never need to open an HTML with Konqueror, the quickest way around this is to simply remove the %u argument. The downside is, if you edit the wrong file, you will no longer be able to open HTML files stored locally on your computer with Konqueror from Dolphin, or another file manager. Since Konqueror uses kparts in order to show all content, using it as a file manager and telling it to preview the file with KHTML or webkit instead of using Dolphin to launch it will suffice as a workaround.

Personally, I don't love Konqueror as a file manager, it isn't quite as nice as Dolphin and will preview many files instead of opening them by default unless you tell it otherwise. Therefore, I just got rid of the quicklaunch icon and dealt with the Kickoff menu. But this is another way to handle it.

Hope it helps!

JimmyDean886
 
Old 04-01-2014, 11:06 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,592

Original Poster
Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Quote:
Originally Posted by jimmydean886 View Post
The %u argument is there to represent a single URL. Therefore, the program is parsing inode/directory as the URL you wish to go to.
Yep, that's the conclusion I came too also Jimmy. If I remember rightly I worked around the problem by double-quoting the %u on the launcher settings as I was contemplating doing above. Anyway, I'm not normally a KDE user (I was just reporting what I found while trying it out during the Release Candidate testing phase of Slackware 14.1), but maybe some other kde users will find the info in this thread helpful if they hit the same issue. Thanks for taking an interest.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
root inode is not a directory patrick.begou Linux - Server 2 11-26-2010 04:49 AM
Kupfer- no application for XXX (inode/directory) Oliviakrk Linux - Desktop 0 07-06-2010 04:40 PM
slackware 12.1rc3 installer bug campher Slackware 2 05-01-2008 05:10 PM
konquerror error: you have linked konq to inode/directory ... Tarzan-81 Linux - Software 5 01-13-2006 05:04 AM
how to modify a directory inode xlh3110 Linux - General 2 12-03-2005 11:34 AM


All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration