-   Slackware (
-   -   14.1: Xorg crashes on ATI 3d rage pro cards (

Noony 12-03-2013 10:27 PM

14.1: Xorg crashes on ATI 3d rage pro cards
Out of 22 machines at home, 16 of them have an ATI 3d Rage Pro video card. On all machines with that video card, the X system in Slack 14.1 crashes with a segmentation fault shortly after startup. It appears to be the mach64 driver that crashes. Through a ton of googling, I see that the same thing happens in other distros, too.

I installed the driver from the 14.0 distribution, but the newer server rejected it. Then I also installed the xorg server from the 14.0 distro, but then it choked on another mismatch or 2.

I looked in modules.dep, but that didn't mention any dependencies for these things. Does anyone know the list of things I need to downgrade in order to use the working driver from the 14.0 distro?

ps: The hint in 'changes & hints' about disabling composites has no effect.

pps: Both 'Xorg -configure' and 'xorgsetup' also crash on these machines.

ReaperX7 12-03-2013 10:51 PM

Have you tried at minimum using just the standard VESA driver?

The Mach64 driver is over a year old by now, so I'm not sure how well it has been maintained since that time in regards to newer kernels, x-servers, etc. It may actually have issues with the kernel driver and not just the xorg driver.

If you're using these as a server system setup, the VESA driver should be more than adequate.

Noony 12-04-2013 04:10 PM

On servers, I don't use a GUI. I couldn't remember what happens with vesa, so I went ahead and tried it.

If I use modelines, I get just a mess of lines, smears, and confetti. If I terminate X with a ctl-alt-bksp, the screen turns black, and I think the computer has crashed because I can't switch to any virtual console.

If I don't use modelines, I get a GUI display with extreme flickering (60 Hz). I can terminate using the normal logout from KDE or xfce, but this also turns the screen black and (I think) crashes the whole computer.

The mach64 driver is more like 2 decades old, but new versions are continually released. The newest release (which is in Slack 14.1) is newer than the latest rollup release of Xorg.

ReaperX7 12-04-2013 04:54 PM

Flickering on the VESA, Modesetting, or even the FBDev driver, could be bad sign that you have a possible and/or potential hardware failure with the graphics or AGP memory controller. It also could be an improperly set interrupt for the PCI bus management system as well.

If it's crashing with the actual driver then you have something seriously wrong happening.

Is this repeating on other machines with similar hardware, and do you have a spare video card that is compatible with the system to test out also?

turtleli 12-04-2013 06:26 PM

This bug report about the xorg server segfaulting with a mach64 driver might be relevant to you.

Can you patch and rebuild the mach64 driver and see if it will solve your problem?

mlslk31 12-04-2013 08:32 PM

Last time I had to fiddle with this, I ended up recompiling xf86-video-mach64 with some flags like "--enable-exa --disable-uxa", but there might be xorg.conf directives that you can use instead. It's been a while, though, and I've given up on using X11 on that PC. It's too slow, and there's not enough memory in the PC to get the best out of X11.

ReaperX7 12-04-2013 08:45 PM

Found this on the Arch Wiki. Apparently this is a well known problem with Rage Pro based video adapters:

GVrooman 12-05-2013 09:24 PM

I am a little concerned about this because I have three of these cards, and someday I may want to upgrade to a newer version of Slackware. I found this discussion which pertains to Lubuntu:

The problem seems to be that Xorg dropped support for XAA with xorg-server 1.13. Slackware 14.1 is now using 1.14.3. One workaround seems to be to disable hardware acceleration altogether. I also found this article which doesn't bode well for people who are still using old video cards:

I am not sure how useful all of this is but it will at least help to point people in the right direction.

ReaperX7 12-06-2013 04:13 AM

Older video cards aren't subject to continued support on any OS. For developers they try to keep support of commonly used hardware if driver code is maintained, but all too often older cards that start getting deprecation in driver support, will get pushed back to barebones support through VESA and LLVMPipe in Mesa.

It happens not too often but as older cards see less driver support, and support is at a dead end, it starts showing up.

Often you really have to do extensive homework now when building for Linux, BSD, or any other UNIX family OS.

Noony 12-06-2013 02:59 PM


Originally Posted by turtleli (Post 5075565)
This bug report about the xorg server segfaulting with a mach64 driver might be relevant to you.

Can you patch and rebuild the mach64 driver and see if it will solve your problem?

Thank you, turtleli, that patch does fix the driver so it doesn't crash anymore.

All times are GMT -5. The time now is 10:44 AM.