-   Slackware (
-   -   12.1 automount not working, hald etc (

Pscylo 12-03-2008 04:45 AM

12.1 automount not working, hald etc

I have a reasonably fresh install of of 12.1, and recently wanted to install Gnucash which requierd some gnome libraries.

Therein lies the problem. After installation of Gware (I've uninstalled some parts of it since - thoiugh not all as I want Gnucash), autmounting no longer works. The hal daemon appears to be running OK, I've fiddled with /etc/fstab in various ways, tried reinstalling udev, hal, dbus (which I think are all related). I've removed some files that Gware adds:


(though if memory serves the last one wasnt there). The actual error message is something along the lines of:

wrong fs type, bad option, bad superblock on /dev/(changs depending on device), missing codepage or other error. In some cases useful information is found in syslog, try dmesg | tail.

yet I can mount manually fine. It's more of an irritation than a problem per se, but I would like it to work correctly.

The obvious conclusion is that Gware broke something. I can't see what though and I can't find a huge plethora of information on Gware. According to Gware site it only updates a couple of files, allof which I've tried rolling back to no avail.

Any thoughts?

lumak 12-03-2008 01:36 PM

If you decide on starting over rather than attempting to fix it, a while back i wasted the time to figure out what packages were needed for 12.0.

It is possible to get gnucash installed on slackware without updating core packages. however, gware did not have a version out that would not conflict with the slackware versions of some packages. That would take a lot more time to figure out.


If you want to attempt to undo the damage caused by removing some gware packages, you may be able to reinstall all of gware then follow the uninstall instructions. Also... I know linux often doesn't need to be rebooted... but restarting after an install/setup may help get things on track better than you can do it on your own.

It may be that some of the mount assistants that get installed with gnome (assuming so anyway) is conflicting with something by removing a package.


On the upside of all this.. 12.2 is due to come out soon. If you want to reinstall to fix it and you have the time to spare, i would wait for that then try installing only the packages you need. I would think that the packages mentioned on the gnucash slackware page would still all be around the same versions. Just be sure the read all the directions first AND double check package versions. make sure you don't downgrade any slackware packages.

Good Luck!

Also if you already have binaries installed, there is actually some sort of piped command you can do on a binary to find out all of the required dependencies.... I'll have to search for that again.


Found it!

This will find all the needed dependencies of a binary file.

objdump -x $1 | grep NEEDED

All times are GMT -5. The time now is 12:20 PM.