LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-03-2004, 05:38 AM   #1
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Rep: Reputation: 15
'Whatever' login takes ages...


Hello all,

Since a few days all things concerning logging IN (ssh, su, sudo, hell even console) take ages. For as far I know I didn't change anything. I hoped it would disappear, but it is getting very annoying by now.

I didn't notice anything in my dmesg, nor in my other logs. I don't think it has to do with my uptime either, it is quite low since I had to reboot 3 weeks ago..

And for the record, I did check the reverse-dns 'nslookup <IP>' to check if SSH might be having that problem, but it errored out immediately as it should on my LAN.

Did anyone ever have this before? And more importantly, figure out a way to fix it?

Thanks for your help,

-Worstje

Last edited by Worstje; 10-04-2004 at 08:41 AM.
 
Old 10-03-2004, 09:16 PM   #2
fphillips
Member
 
Registered: Sep 2004
Location: KS
Distribution: Slack 10-current
Posts: 87

Rep: Reputation: 15
hmm, only thing I can think of is maybe your disk is failing, but usually that would log errors...
You could run some tests with smartctl. What kernel is this?
Is it partition-specific (is /var on it's own partition)?
If this box is remote, does it respond to pings quickly?

Last edited by fphillips; 10-03-2004 at 09:19 PM.
 
Old 10-04-2004, 08:01 AM   #3
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Original Poster
Rep: Reputation: 15
When reading your answer I suddenly noticed that I somehow forgot a word in my first sentence (which is in the title however). It should have read: ...all things concerning logging IN ....
I do not have any problems with harddisks (for as far I know). I apologise if I confused everyone with my mistake

However, in case you did understand me, I will run some tests with smartctl later. Currently downloading something which I prefer to have finished as it is rather urgent
The box is semi-remote: I usually access it through putty from the main family computer, but if necessary I can also use the console. The login-delay is there in either case.

The following is the output of df -lh: (yes, /var is on its own partition, hda5).

Code:
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             1.2G  981M  158M  87% /
/dev/hda1              38M   34M  3.0M  92% /boot
/dev/hda5             1.4G  1.2G  131M  91% /var
/dev/hda6             3.7G  1.7G  1.8G  49% /usr
/dev/hda9             373M   34M  320M  10% /tmp
/dev/hda7             7.5G  5.7G  1.4G  81% /home
/dev/hda8             4.2G  1.3G  3.0G  30% /music
Pings from the family computer are <1ms.

I appreciate your help, thanks
 
Old 10-04-2004, 11:17 AM   #4
fphillips
Member
 
Registered: Sep 2004
Location: KS
Distribution: Slack 10-current
Posts: 87

Rep: Reputation: 15
I did some googling, and a remedy for a slow ssh login would be to add the ip address of the other computer into each /etc/hosts file. But if you're also having the same problem after you've logged in w/ su & sudo, those wouldn't be affected by this. I'm not convinced that's the fix for your problem. Could you post the /etc/ssh/sshd_config for the box you're trying to get to.
 
Old 10-04-2004, 03:43 PM   #5
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Original Poster
Rep: Reputation: 15
Yup I tried those but those didn't work. Also didn't seem to be my problem as it worked fine before, hell, I hadn't even rebooted when this behavior began

Code:
worstje@coresausage ssh $ cat sshd_config
#       $OpenBSD: sshd_config,v 1.65 2003/08/28 12:54:34 markus Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCreds yes

# Set this to 'yes' to enable PAM authentication (via challenge-response)
# and session processing. Depending on your PAM configuration, this may
# bypass the setting of 'PasswordAuthentication'
#UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /etc/issue

# override default of no subsystems
Subsystem       sftp    /usr/libexec/sftp-server
 
Old 10-05-2004, 05:21 PM   #6
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Original Poster
Rep: Reputation: 15
I haven't made any progress myself, but I thought it might be useful for any people who are interested to see my /etc/passwd and /etc/shadow (modified a bit naturally )

/etc/passwd:

Code:
root:x:0:0::/root:/bin/bash
bin:x:1:1:bin:/bin:
daemon:x:2:2:daemon:/sbin:
adm:x:3:4:adm:/var/log:
lp:x:4:7:lp:/var/spool/lpd:
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
mail:x:8:12:mail:/:
news:x:9:13:news:/usr/lib/news:
uucp:x:10:14:uucp:/var/spool/uucppublic:
operator:x:11:0:operator:/root:/bin/bash
games:x:12:100:games:/usr/games:
ftp:x:14:50::/home/ftp:
smmsp:x:25:25:smmsp:/var/spool/clientmqueue:
mysql:x:27:27:MySQL:/var/lib/mysql:/bin/bash
rpc:x:32:32:RPC portmap user:/:/bin/false
sshd:x:33:33:sshd:/:
gdm:x:42:42:GDM:/var/state/gdm:/bin/bash
pop:x:90:90:POP:/:
nobody:x:99:99:nobody:/:
user1:x:1000:100:Name blanked,N/A,N/A,N/A,A.k.a. Doggy:/home/user1:/bin/bash
stereo:x:918:918:Stereo Toren Systeem Gebruiker:/home/stereo:/bin/bash
user3:x:1001:100:Name blanked,N/A,N/A,N/A,He's ok... atleast I think so.:/home/user3:/bin/bash
user4:x:1002:100:Name blanked,-,-,deleted:/home/user4:/home/user4/conversatie
/etc/shadow

Code:
root:$1$4Sa0yADt$ArQ3e5t6IFaU.5pzqVsXn1:12600:0:::::
bin:*:9797:0:::::
daemon:*:9797:0:::::
adm:*:9797:0:::::
lp:*:9797:0:::::
sync:*:9797:0:::::
shutdown:*:9797:0:::::
halt:*:9797:0:::::
mail:*:9797:0:::::
news:*:9797:0:::::
uucp:*:9797:0:::::
operator:*:9797:0:::::
games:*:9797:0:::::
ftp:*:9797:0:::::
smmsp:*:9797:0:::::
mysql:*:9797:0:::::
rpc:*:9797:0:::::
sshd:*:9797:0:::::
gdm:*:9797:0:::::
pop:*:9797:0:::::
nobody:*:9797:0:::::
user1:$1$O4etQ5U.$5VcU/ZPUOWa00wnUI0MrJ1:12524:0:99999:7:::
stereo:$1$pgJ/MDCa$Zxfxh/Xh6Y3ik5BlkViCo/:12543:0:99999:7:::
user3:$1$dMx093K6$h7pizG5YVpA/M6B7jaQUP.:12646:0:99999:7:::
user4::12605:0:99999:7:::
I am unfamiliar with the syntax of /etc/shadow, and the repeating 99999 number is a bit worrying since I am not sure whether it belongs there (never looked in /etc/shadow before )

Edit: I just found out that in the opposite of what my first message says, INITIAL console logins do NOT delay at all. But using anything else that wants your password from that point on (sudo, su) IS delayed.

Thanks for taking a look at it everyone!

Last edited by Worstje; 10-05-2004 at 05:44 PM.
 
Old 10-07-2004, 11:32 AM   #7
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Original Poster
Rep: Reputation: 15
Made some more progress (I hope).

On suse lists I found this post: su login delay
It shed some light on the problem. I looked at the other posts too and try the things they mentioned, for as far applicaple on a slackware system

'bash --login' works instantly.
adding 'set -x' to /etc/profile .. shows (like the guy in the thread) a huge delay and suddenly lots of output from bash.
/etc/pam.d/ ? Cannot do, don't have it

In the end this person disabled LDAP. So I googled for it, but it doesnt seem like its part of slackware or manually installed, but I do see that samba and sudo have some kind of support for it (in the packagebrowser wildcard search).

Is there anyway to see what is happening between 'login' and 'shell'? And once again, I don't think it's specific to ssh, su or sudo since its happening in each of them given certain circumstances (not being inital login on console to name something).

Thanks for reading...
 
Old 10-15-2004, 03:06 PM   #8
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Original Poster
Rep: Reputation: 15
Back I am.
Well this must be something to do with the 'windows'-network it's linked to: rebooting the box fixed everything . Wish I had the possibility to have tried that before..

Thanks for all the thought everyone put into this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting takes ages! Steave Linux - General 3 02-23-2006 06:39 AM
Takes ages to connect to smtp Swakoo Linux - General 3 08-23-2005 03:32 AM
Configuring network interfaces..takes AGES! coolblue Linux - Newbie 6 07-20-2005 07:33 AM
X takes ages and ages to load! dcdbutler Slackware 9 03-23-2005 07:53 AM
Webpages/Email takes ages to load after period of inactivity Robstro Linux - Networking 1 05-26-2004 01:31 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration