-   Slackware (
-   -   [Xorg-1.7.5 in Slackware64 -current] still no workie.. Xorg bug? (

GrapefruiTgirl 07-27-2010 10:19 PM

Problem is fixed in software or driver!
July 27 2010 UPDATE:

The problem is now gone!

I didn't solve it, or figure out what it was, but over the last few months, whatever the problem or conflict was, has been repaired either in Xorg or in the nVidia driver. Below are the current versions of stuff I have installed, and which are working as expected right now (relevant parts in bold):


sasha@reactor: glxinfo | less
sasha@reactor: glxinfo | grep version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 2.1.2 NVIDIA 256.35
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
sasha@reactor: glxinfo | grep direct
direct rendering: Yes
    GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
sasha@reactor: ls /var/log/packages | grep xorg
sasha@reactor: ls /var/log/packages | grep input
sasha@reactor: uname -a
Linux reactor #1
  SMP PREEMPT Fri Jul 23 19:30:47 ADT 2010 x86_64
  Genuine Intel(R) CPU            2160  @ 1.80GHz GenuineIntel GNU/Linux

Thread is solved as far as I'm concerned. Thanks everyone for your help & suggestions in this thread!

Didier Spaier 07-28-2010 03:21 AM

Hi Sasha,

I'm happy that the problem be gone - Good bye, problems :cool:

Meanwhile, just for fun:

bash-4.1$ glxinfo|grep version
server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 2.1 Mesa 7.8.1
OpenGL shading language version string: 1.20
bash-4.1$ glxinfo|grep direct
direct rendering: Yes
bash-4.1$ lsmod|grep nouveau
nouveau              534585  2
ttm                    52945  1 nouveau
drm_kms_helper        25629  1 nouveau
drm                  167991  4 nouveau,ttm,drm_kms_helper
i2c_algo_bit            5327  1 nouveau
video                  19705  1 nouveau
i2c_core              19995  5 nouveau,drm_kms_helper,drm,i2c_algo_bit,i2c_i801
button                  4978  1 nouveau
bash-4.1$ modinfo nouveau
filename:      /lib/modules/2.6.35-rc3-00874-g5a7c828/kernel/drivers/gpu/drm/nouveau/nouveau.ko
license:        GPL and additional rights
description:    nVidia Riva/TNT/GeForce
author:        Stephane Marchesin
alias:          pci:v000012D2d*sv*sd*bc03sc*i*
alias:          pci:v000010DEd*sv*sd*bc03sc*i*
depends:        drm,drm_kms_helper,ttm,i2c-core,button,video,i2c-algo-bit
vermagic:      2.6.35-rc3-00874-g5a7c828 SMP mod_unload
parm:          noagp:Disable AGP (int)
parm:          modeset:Enable kernel modesetting (int)
parm:          vbios:Override default VBIOS location (charp)
parm:          vram_pushbuf:Force DMA push buffers to be in VRAM (int)
parm:          vram_notify:Force DMA notifiers to be in VRAM (int)
parm:          duallink:Allow dual-link TMDS (>=GeForce 8) (int)
parm:          uscript_lvds:LVDS output script table ID (>=GeForce 8) (int)
parm:          uscript_tmds:TMDS output script table ID (>=GeForce 8) (int)
parm:          ignorelid:Ignore ACPI lid status (int)
parm:          noaccel:Disable all acceleration (int)
parm:          nofbaccel:Disable fbcon acceleration (int)
parm:          override_conntype:Ignore DCB connector type (int)
parm:          tv_disable:Disable TV-out detection
parm:          tv_norm:Default TV norm.
                Supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J,
                        hd480i, hd480p, hd576i, hd576p, hd720p, hd1080i.
                Default: PAL
                *NOTE* Ignored for cards with external TV encoders. (charp)
parm:          reg_debug:Register access debug bitmask:
                0x1 mc, 0x2 video, 0x4 fb, 0x8 extdev,
                0x10 crtc, 0x20 ramdac, 0x40 vgacrtc, 0x80 rmvio,
                0x100 vgaattr, 0x200 EVO (G80+).  (int)
bash-4.1$ uname -a
Linux darkstar 2.6.35-rc3-00874-g5a7c828 #1 SMP Tue Jul 27 23:38:35 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz GenuineIntel GNU/Linux
bash-4.1$ ls /usr/lib64/xorg/modules/drivers/|grep nouveau*

But the kernel and the X video module, every relevant component is a stock one, i.e. shipped with Slackware64-13.1.

Take care ;)

PS I use krandrtray, shipped with kdebase-workspace-4.4.3-x86_64-1 and find it very handy. It works well under Fluxbox as well.

GrapefruiTgirl 07-28-2010 05:54 AM

@ Didier,

Glad to see all is working for you, and with stock Slackware components. I'm still technically running -current, although that's probably (at this moment) very nearly the same as 13.1 which IIRC just officially came out?

Could you please remind me what-all hardware & number of monitors you're running, and how/where your monitors are connected? I re-read this whole thread but haven't determined that. Since you wrote that you are using krandrtray, I know you're using RandR rather than Xinerama; I don't use KDE stuff much, nor do I have a tray, so I'd hafta set the RandR via xorg.conf, which is fine. Mostly I want to know ( (how many monitors you have) X (how many cards) ).

Finally: what's the status of your "Nouveau Slackware Tutorial" wrt 13.1 or current? Or -- maybe we don't even need a tutorial since all stuff comes with Slackware now..

I'm still keen on trying to see if Nouveau will drive my setup, but I admit, I am not optimistic, and feel like leaving well enough alone for a while..

Didier Spaier 07-28-2010 07:43 AM

@ Sasha,

In fact my configuration is very different from yours, because I have only one GPU on my laptop (Lenovo T61):

bash-4.1$ lspci -k|grep -A3 VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)
        Subsystem: Lenovo ThinkPad T61
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb

In addition to the internal LCD display of the laptop when at home I plug in an LCD external monitor on the VGA port.

I happen to plug in a video projector on the same VGA port for presentations.

In both cases I use krandrtray for the set up (BTW I use Fluxbox, not KDE and do have a tray ;)

Alas, AFAIK xrandr is not able (yet) to manage more than one GPU thus you won't be able to use it.

On the other hand I just tried yo enable xinerama in my xorg.conf and it did work (though i don't need it as xrandr works for me).

So may be when using nouveau xrandr and xinerama can coexist - that doesn't seem to be the case with the blob, though.

The "Nouveau Slackware Tutorial" as you say is still up to date. See the first post of this thread

Be aware though that nouveau can't coexist with the blob, see here

Oh and yes, for now Slackware-13.1 and Slackware-current ship the same X components, as shown is the changelogs.

GrapefruiTgirl 07-28-2010 09:23 AM

Thanks for all that info Didier! I am going to do some more research before resolving to attempt Nouveau again. Mainly I plan to search around for success/horror stories regarding multiple hardware. Also, since this is a desktop machine, I would like for the ?randr to be workable from either xorg.conf or scriptable/configurable during X startup, and not have to use Krandr.. Maybe one day in the future I'll have a tray ;) but not anytime soon; and by that time maybe I'll have gotten KDE all gone from the system..

If I ever get Nouveau to work how I want, I'll make a post about it for sure.
If it doesn't work, but all things indicate that it *should*, I'll start a thread about it.

Thanks & good day :)

All times are GMT -5. The time now is 01:05 PM.