-   Slackware (
-   -   [SOVLED] Problem with Slackware 13 x86_64 ATI driver on using "multilib" (

ollebanan 01-10-2010 05:25 PM

[SOVLED] Problem with Slackware 13 x86_64 ATI driver on using "multilib"
Hi all,

i just upgraded to the latest kernel due some faulty modules in, everything went smoothly, i created an initrd.gz file and rebooted, worked just fine, so far.

However, when trying to re-install the official ati-drivers ( i got a message saying:


AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm-rf *. c *. h *. o *. ko *. GCC *.? * *. symvers
make-C / lib/modules/ SUBDIRS = / lib/modules/fglrx/build_mod/2.6.x modules
make [1]: Entering directory `/ usr/src/linux- '
  CC [M] / lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/ lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: 1: error: kodmodellen "kernel" is not supported on 32-bit mode
make [2]: *** [/ lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make [1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make [1]: Leaving directory `/ usr/src/linux- '
make: *** [kmod_build] Error 2
build failed with return value 2

And trying to run simply "make bzImage" gives me.

CHK include / linux / version.h
  CHK include / linux / utsrelease.h
  Symlink include / asm -> include/asm-x86
  CC kernel / bounds.s
kernel / bounds.c: 1: error: kodmodellen "kernel" is not supported on 32-bit mode
make [1]: *** [kernel / bounds.s] Error 1
make: *** [prepare0] Error 2

Anyone got an idea to what the error might be?

Thanks in advance,


ollebanan 01-11-2010 09:08 AM

Mmm not a single suggestion to what might be causing this?

samac 01-11-2010 10:30 AM

Perhaps the title is too generic you don't actually have a problem with Slackware64-current (multi-lib), or the current kernel, you have a problem installing the ATI driver on your system.

Unfortunately I am an Nvidia devotee and am unable to help with this.

I know this doesn't actually help, but a rephrased title might.


ollebanan 01-11-2010 05:51 PM


Extract the ATI-driver using "--extract", navigate to ${EXTRACTION_DIR}/common/lib/modules/fglrx/build_mod/kcl_io.c Add this line with the rest of the # include statements.

# include <linux/signal.h>

Back to ${EXTRACTION_DIR}, run ./ati-installer 8.5912 --install, do and and load the module.

erickFis 01-14-2010 07:21 PM

Thank you ollebanan!!!

It worked for me too =D

vdemuth 01-24-2010 01:02 PM

Worked for me too, and on a none multilib slack64. How do you even go about finding this sort of thing?

All times are GMT -5. The time now is 11:00 PM.