-   Slackware (
-   -   [SOLVED] Trouble running awesomewm! (

Gumboherpy 03-03-2013 12:17 AM

[SOLVED] Trouble running awesomewm!
After finally compilling and installing awesomewm my fav window manager, I launch startx but it runs into an error. Can't copy/paste the whole error but it says

Code: No such file or directory
I am stump, what am I missing??

willysr 03-03-2013 01:46 AM

try installing all xcb-* package under x/

Gumboherpy 03-03-2013 09:55 AM

I think I know where I went wrong, I think cairo does not have xcb support, where do I go to add it though?

sahko 03-03-2013 10:11 AM

Cairo does have the xcb backend enabled in -current.

Fri Feb 22 01:09:25 UTC 2013
Lots of X updates in this batch! We were finally able to upgrade to the
latest cairo (including the long-requested XCB backend)

Gumboherpy 03-03-2013 10:38 AM

I am on current so that's not the problem.

ponce 03-03-2013 11:26 AM

if you are using -current, you can also try this.

Gumboherpy 03-03-2013 11:31 AM

I fixed it, I had xcb-utils package made but I forgot to issue an installpkg. I'm in awesome now and loving it!

All times are GMT -5. The time now is 09:08 PM.