-   Slackware (
-   -   [Solved] Need to load Nouveau Video Driver earlier (

sqlpython 03-16-2014 04:50 PM

[Solved] Need to load Nouveau Video Driver earlier
I had solved this problem differently with Debian, Arch and Gentoo but required a different approach with Slackware.

My Slackware/Salix now boots to show only 8 lines at 640x480 before Changing to 1440x900.
This was a job for the bootloader.
For some that is lilo and for others that would be grub.

As I boot from the grub2 bootloader my solution is for grub2. I haven't used lilo since about 2001.

You need to modify the line in the /boot/grub/grub.cfg file that loaded my Salix/Slackware 14.1 install
While editing /boot/grub/grub.cfg is frowned upon for newbies while others do editing when needed. I have been editing that file when the need arose for at least a decade. Or since it was named menu.lst.
So I renamed

linux /boot/vmlinuz-huge-3.2.45 root=/dev/sda6

linux /boot/vmlinuz-huge-3.2.45 root=/dev/sda6 ro rootfstype=ext4 video=uvesafb:ywrap,1440x900-32,mtrr:3,splash=silent, resume=UUID=6213ab45-10ea-4c6b-8172-8212637e5c31 elevator=cfq doscsi video=nouveau console=tty1 udev quiet

All times are GMT -5. The time now is 03:46 AM.