-   Slackware (
-   -   [solved] grub (legacy) and slackware-64 (

perbh 09-29-2012 11:39 PM

[solved] grub (legacy) and slackware-64
Well now - I always wondered why we didn't have any legacy grub on slackware-64 - in a previous thread (which I now can't find), I was told it will _not_ compile under 64-bit. Fair enough - but archlinux has legacy grub on their 64-bit version - only ... it turns out that it is actually the 32-bit version - statically linked!!

So - in order to have my beloved legacy grub on slackware-64, all I did was the following: (please note, I use _one_ and only one partition for each distro - so everything belongs to the root filesystem)
Also, I was using my archlinux grub/distro just incase - haven't tried slackware's yet.
So here goes:

mount /dev/sda7 /mnt/hd  # mounting my slackware-64 partition from arch
mkdir /mnt/hd/boot/grub
cp /usr/lib/grub/i386-pc/* /mnt/hd/boot/grub
vi /mnt/hd/boot/grub/menu.lst

So - my menu.lst now looks like the following:

default 0
timeout 5
title slackware-14-64 (huge)
  root (hd0,6)
  kernel /boot/vmlinuz ro root=/dev/sda7
title slackware-14-64 (generic)
  root (hd0,6)
  kernel /boot/vmlinuz-generic-3.2.29 ro root=/dev/sda7
  initrd /boot/initrd-generic-3.2.29.gz

And finally, just install grub on the partition:

grub> root (hd0,6)
grub> setup (hd0,6)
grub> quit

he, he, he!

Woodsman 09-30-2012 12:35 PM

I use grub legacy as well and have for as long as I haved Linux based systems. I maintain grub in 13.1 32-bit system. Although I have read that grub legacy won't build in 64-bit, grub has no problem booting 64-bit systems. I multi-boot between 13.1 32-bit and 14.0 64-bit using grub legacy.

All times are GMT -5. The time now is 09:38 PM.