-   Slackware (
-   -   [SOLVED] Filelight - don't show /home partition (

montagdude 05-29-2016 01:13 AM

[SOLVED] Filelight - don't show /home partition
2 Attachment(s)
I like Filelight as a nice graphical way to show where space is being taken up on my hard drive. I'm having an issue with it, though. When I start it, it presents my root partition and my home partition for scanning, as shown in the first screenshot. However, when I click the root partition, it scans and displays the entire disk, including /home, as shown in the second screenshot. This makes it not useful for investigating just the root partition, because the pie chart is dominated by /home and /usr, and the rest isn't shown. Does anyone know how to make it not display the contents of /home when I scan the root partition? I know it is possible, because that is how it worked in other distros that I used before switching to Slackware.

I know I can use du to do the job, and in fact that's my workaround, but it is a more tedious way to track down what is taking up space, and the pie chart is a nice and clear visualization.

montagdude 05-29-2016 01:22 AM

Gah, I just figured it out. I went to "Configure Filelight" under the Settings menu and added /home to the "Do not scan these folders" list. At first I thought that would make scanning the /home partition not work (clicking the right option in the first screenshot), but it still does. Now that I think about it, the /home partition doesn't contain any /home directory, so I guess it makes sense. There's also an option called "Scan across filesystem boundaries," which was unchecked by default, but that didn't seem to do anything for my particular problem.

Sorry for the question that I solved two minutes later. Maybe it will help someone else in the future, though. :)

All times are GMT -5. The time now is 03:56 PM.