LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   [SOLVED] Elan touchpad (https://www.linuxquestions.org/questions/slackware-14/%5Bsolved%5D-elan-touchpad-4175624653/)

multios 02-28-2018 01:50 PM

[SOLVED] Elan touchpad
 
I bought a Lenovo ideapad 320 laptop.
I installed current and it runs ok. However, having trouble setting sensitivity on the elan touchpad.
Is there a particular driver I need to install for that touchpad?
It shows as Elan 060C.
Oh, I believe it is using the synaptic driver in X.
Thanks.

ferrari 02-28-2018 03:17 PM

Quote:

Oh, I believe it is using the synaptic driver in X.
There's no need to speculate about which Xorg input driver is handling the device. Examine the Xorg log....
Code:

grep "Using input driver" /var/log/Xorg.0.log
Most recent distros/ desktop environments have moved to using libinput. (The evdev and synaptics drivers have been deprecated.)

multios 02-28-2018 06:43 PM

Code:

dmesg | grep Elan
[  10.050252] elan_i2c i2c-ELAN060C:00: Elan Touchpad: Module ID: 0x005b, Firmware: 0x0001, Sample: 0x0002, IAP: 0x000d
[  10.051222] input: Elan Touchpad as /devices/platform/AMD0010:00/i2c-0/i2c-ELAN060C:00/input/input5

Code:

grep "Using input driver" /var/log/Xorg.0.log
[  135.290] (II) Using input driver 'libinput' for 'Power Button'
[  135.327] (II) Using input driver 'libinput' for 'Video Bus'
[  135.333] (II) Using input driver 'libinput' for 'Power Button'
[  135.343] (II) Using input driver 'libinput' for 'EasyCamera: EasyCamera'
[  135.362] (II) Using input driver 'libinput' for 'Ideapad extra buttons'
[  135.375] (II) Using input driver 'synaptics' for 'Elan Touchpad'
[  135.411] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'


ferrari 02-28-2018 07:21 PM

Ok, that confirms that the synaptics driver is in use for the Elan device. Have you tried using the libinput driver instead? Just a matter of inhibiting it loading via it's /etc/X11/xorg.conf.d/ configuration file (eg rename it or comment the driver entry in it). Sometimes, it's just down to the touchpad hardware design and there's not a lot that can be done.

multios 02-28-2018 07:43 PM

I can't find that file via slackpkg, neither is installed.

Do see it in sbopkg tho. Will try that.

Thanks

Update: installed, learning and testing libinput.

ferrari 02-28-2018 11:17 PM

Quote:

Update: installed, learning and testing libinput.
Let us know how that works out for you. :)

multios 03-01-2018 05:48 PM

Can't say libinput is doing any better, but still have different options to try in the config file.

As of about March 1st or 2nd:
# slackpkg search libinput

Looking for libinput in package list. Please wait... DONE

The list below shows all packages with name matching "libinput".

[ installed ] - libinput-1.10.1-x86_64-1
[ installed ] - xf86-input-libinput-0.26.0-x86_64-1

Still need some minor tweaking, but I'm a lot more comfortable with the touchpad right now.
Oh, since using current, the kernel is 4.14.23


All times are GMT -5. The time now is 01:59 AM.