-   Slackware (
-   -   [SOLVED] Audio on Slackware 14 (

borgonero 09-18-2013 03:26 AM

[SOLVED] Audio on Slackware 14
Hi all,
I'm having trouble to configure my audio on Slackware 14 and I'm a little confused: I have an Asus M2V Motherboard with onboard audio but under /proc/asound/cards I have three different cards (HDA NVidia, VIA VTxx and a SAA7134). Can someone tell me how it's possible? And how can I know what is the right one to configure and how can I choose the default one?
Thank you so much

allend 09-18-2013 09:17 AM

Welcome to LQ!

This SlackDocs page may help.
Using 'model=3stack-660' is worth trying according to this.

borgonero 09-18-2013 10:11 AM

Thanks for your reply and welcome. As soon as I get home I'll try to follow your link. In the meantime, I removed an unuseful tv-card from my pc (the SAA7134) and my intention was to disable the kernel module of the HDA NVidia to keep just the VIA one. I'll try everything this evening
Thanks Allend :)

allend 09-18-2013 12:18 PM

For multiple sound device issues, there is another SlackDocs page.

Firerat 09-18-2013 12:36 PM

the nvida is likely HDMI ( from video card ), just lower its priority, you may like to use it at some point

if you are having sound issues ( like none ) make sure you are a member of audio


if audio is not listed, add with the following ( as root )

usermod -a -G audio <yourusername>

ReaperX7 09-18-2013 09:12 PM

A lot of times certain motherboards will use various codec chips on their boards that all work together, but often Linux will pick them up as individual chipsets.

One usually is the master Southbridge MCP controller, the others are usually the HDA(AC97+front+center) and I2S(rear+surround) codecs. If you have the MCP set as the main audio controller, you won't need to worry about setting up the HDA/AC97 and I2S codecs at all.

You're Nvidia HDA is probably your HDMI-Audio.

The VIA VT8237A is the motherboard MCP in this case. This is the main master audio controller and will handle all the audio processing.

The SAA7134 is actually a RealTek ALC66x series audio codec, possibly a ALC662 HDA codec.

Both of these should use the snd-intel-hda driver.

Realtek also has a driver available from their website version 5.18. Realtek is also one of the few OEMs that actually makes their own drivers for Linux systems.

borgonero 09-19-2013 09:14 AM

Ok, I have created a sound.conf file in /etc/modprobe.d like this:

options snd_hda_intel index=0
options snd_hda_intel index=1

and now my audio is working on movies, mp3 and flash (Youtube etc.) and this is my actual /proc/asound/cards:

0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
HDA VIA VT82xx at 0xfbffc000 irq 17
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfbbfc000 irq 25

Finally the damned HDA Nvidia is no more the default one... :)

Now I still have just one problem: the microphone over skype. I have another machine with the same OS but with just one audio card detected and Skype and microphone are working perfectly. The Alsa levels are all at maximum level and correctly stored, what could be the problem?
Thank you so much to all for help

borgonero 09-19-2013 04:46 PM

The microphone is working too, now. It was just a wrong conf in source section of Alsamixer :redface:
Thank you guys :)

All times are GMT -5. The time now is 07:15 PM.